OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
915
First Language
Finnish
Primarily Uses
RMMZ
Hi,

since you wrote that changin to an integer would do the trick, i tried. Unfortunately, i ended up having the same results as before, which is the opacity doesn't change. Here's an image of a test a made.

View attachment 147498

About the layer area, i figured it wouldn't be possible but decided to ask anyway. I guess i'll have to create some sort of fog charset. But thanks for answering.
Thank you for the report I will investigate this more.
 
Last edited:

PresaDePrata

Veteran
Veteran
Joined
Dec 4, 2014
Messages
90
Reaction score
18
First Language
Portuguese
Primarily Uses
RMMV
Another thing i got. When you give the command clear layer, if i set anything above 4 in fade time, the layer instantly disappear. It accepts float values, so if i set 0.5 it will fade slower. However it will change layer opacity several times before really fading, which kind looks like a bug. I don't know if it's a conflict with plugins i have, even though i don't have another who works with layers. I'll test in new project later and will post the results here.

Also, it's not clear how opacity works when you call the plugin command layer. It also accepts a float but that is not easily comparable to frame time.
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
915
First Language
Finnish
Primarily Uses
RMMZ
Another thing i got. When you give the command clear layer, if i set anything above 4 in fade time, the layer instantly disappear. It accepts float values, so if i set 0.5 it will fade slower. However it will change layer opacity several times before really fading, which kind looks like a bug. I don't know if it's a conflict with plugins i have, even though i don't have another who works with layers. I'll test in new project later and will post the results here.

Also, it's not clear how opacity works when you call the plugin command layer. It also accepts a float but that is not easily comparable to frame time.
Hi,

I have now fixed "set_layer opacity" issue. Thank you for the report!

Latest version is now 2.05.

EDIT: Fade will subtract this amount from (opacity * 255). Example if fade = 1 and opacity is 128 (50% = 0.5) fade will take 128 frames.

All OcRam -plugins now available at ocram-codes.net

Please read:
Terms of Use

Latest version: Download from here

All my plugins: Check 'em out!
 

TMFCHEF

Villager
Member
Joined
Jun 22, 2020
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
Thank you for the message,

Command syntax seems to be valid for what you are trying to do... What other plugins are you using?
For some reason i cant get any images to load ?????
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
915
First Language
Finnish
Primarily Uses
RMMZ
For some reason i cant get any images to load ?????
Thank you for the message,

Are there any console errors (press F8 / F12 >> open console tab)?
 

TMFCHEF

Villager
Member
Joined
Jun 22, 2020
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
im not really sure what to look for but when i run game it just says failed to load img/pictures/rain01.png even tho its named rain... im confused
 

TMFCHEF

Villager
Member
Joined
Jun 22, 2020
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
extremely frustrating i dont understand why thiswont work :(
 

TMFCHEF

Villager
Member
Joined
Jun 22, 2020
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
i cant get this plugin to work at all im so confused:(((((
 

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
4,686
Reaction score
1,801
First Language
Dutch
Primarily Uses
RMMV
@TMFCHEF if it searches for rain01 png and you named it rain, than it doesn't
work, you must name it rain01 and not just rain.

if it needs rain01 and you called it Rain01, you get the same error.
make sure it exacly called the same, if it crash the game, press F8 (1.5.x)
or F12 for 1.6.x version (unless SRD_Hudmaker is installed) and its F8 as well.
 

TMFCHEF

Villager
Member
Joined
Jun 22, 2020
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
@TMFCHEF if it searches for rain01 png and you named it rain, than it doesn't
work, you must name it rain01 and not just rain.

if it needs rain01 and you called it Rain01, you get the same error.
make sure it exacly called the same, if it crash the game, press F8 (1.5.x)
or F12 for 1.6.x version (unless SRD_Hudmaker is installed) and its F8 as well.
No I tried changing the file name I used all of the examples tried multiple different images and it just doesn't work idk what I'm doing wrong
Ps: been trying to reply to this for days didn't realize it logged me out lol but yeah cant get plugin to work at all
 

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
4,686
Reaction score
1,801
First Language
Dutch
Primarily Uses
RMMV
@TMFCHEF the only problem I can think off, is that either, another plugin conflict
to ocrams plugin or your plugin arent in the correct order (if you use more ocrams plugins)
and or other while you MUST shift some plugins to get it to work.

can you screenshot your plugin database? if there is an issue or a conflict, Ocram can figure
out where, if everything is correct, than there might be a bug or your events is set up wrong
which is also possible, but than we need to see your event page so ocram can help you out
if it is wrong somewhere.
 

Parallax Panda

Veteran
Veteran
Joined
Oct 29, 2015
Messages
1,106
Reaction score
1,340
First Language
Swedish
Primarily Uses
RMMV
So, this might be a silly question, I'm probably just tired, but how do I get a parallax image to scroll above the default parallax layer but below the tileset/sprite layers? There seems to be no map "note tags" that I can find so I guess I'd have to run a parallel process at the start of every map, use a plugin command, then erase the event?

Still, I seem to not be able to successfully set up the plugin command to work either...
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
915
First Language
Finnish
Primarily Uses
RMMZ
So, this might be a silly question, I'm probably just tired, but how do I get a parallax image to scroll above the default parallax layer but below the tileset/sprite layers? There seems to be no map "note tags" that I can find so I guess I'd have to run a parallel process at the start of every map, use a plugin command, then erase the event?

Still, I seem to not be able to successfully set up the plugin command to work either...
Thank you for the message,

If you use it on every map then I would set plugin parameters for desired layer default zIndex to "Behind tileset"
support1.png

But if you use it every now and then I would use plugin command (in autorun event):
set_layer_z [layer index] [z-index]
Example: set_layer_z 0 1
 

Parallax Panda

Veteran
Veteran
Joined
Oct 29, 2015
Messages
1,106
Reaction score
1,340
First Language
Swedish
Primarily Uses
RMMV
@OcRam
Thanks for the explanation. I'm trying to use templates as it's easier to understand than writing the plugin commands with all the numbers (if I look back a few weeks later I'll have no idea what "layer image 0 2 0 0 3" etc really means. So setting up templates seems to be the way to go for me but... it doesn't work for me. It's probably something I'm missing that'll look real obvious once I get it. Here's what I got going:

OcRam_Layers_hm.png

Also, while you can't see it in the last screenshot. My template layers "OffsetX" and "OffsetY" is untouched (set to 0). I don't think that would matter though...


[EDIT: I should probably mention that it's not like this does nothing. It shows nothing from the get go but slowly over severl seconds(?) fades in some grey-white color to cover the parallax I got scrolling below. This grey-white color is not really what my image looks like and even if it was I'd wand the image to be shown instantly as soon as the mp loads and not slowly, slowly fade in.]
 
Last edited:

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
915
First Language
Finnish
Primarily Uses
RMMZ
@OcRam
Thanks for the explanation. I'm trying to use templates as it's easier to understand than writing the plugin commands with all the numbers (if I look back a few weeks later I'll have no idea what "layer image 0 2 0 0 3" etc really means. So setting up templates seems to be the way to go for me but... it doesn't work for me. It's probably something I'm missing that'll look real obvious once I get it. Here's what I got going:

View attachment 159379

Also, while you can't see it in the last screenshot. My template layers "OffsetX" and "OffsetY" is untouched (set to 0). I don't think that would matter though...


[EDIT: I should probably mention that it's not like this does nothing. It shows nothing from the get go but slowly over severl seconds(?) fades in some grey-white color to cover the parallax I got scrolling below. This grey-white color is not really what my image looks like and even if it was I'd wand the image to be shown instantly as soon as the mp loads and not slowly, slowly fade in.]
Only thing that comes to my mind is that set_layer_z plugin command (or setLayer_OC JS call) is used somewhere to overwrite layers' default zIndex.
Oh just noticed that OcRam_Layers and Yami_SkipTitle might not be compatible together...
 

Parallax Panda

Veteran
Veteran
Joined
Oct 29, 2015
Messages
1,106
Reaction score
1,340
First Language
Swedish
Primarily Uses
RMMV
@OcRam

whaaaat? There is a plugin that’s incompatible with Yami’s ”SkipTitle”? I thought that was such a super basic plugin that it should never get outdated or have any issues. I’m only using it while the game is in development but I’ll try without it when I get back home.

Any idea why the ”white smog layer” (is it a super deformed/enlarged version of my background I wonder?) slowly fades in over time? I don’t think I’ve set any ”over time fading” up in the plugin?

[EDIT: I got the right image to show but it's not acting the way it should. I'm using the Plugin command: layer "name of image file", but it doesn't scroll the image as I've set it up and it slowly fades it in instead of showing it at full opacity from the start.]
 
Last edited:

Mr_taxidermy

Warper
Member
Joined
May 10, 2020
Messages
4
Reaction score
1
First Language
English
Primarily Uses
RMMV
Hi, I'm wondering if anyone could give me a little bit of help here.

I'm simply trying to animate a few frames using commands, but I've gone through various iterations and can't seem to get the thing to work.

"layer 2 DoorTest 0 0 true anim:3,17"

This is the last version I used to no avail. I have looked at the templates and the notes and I'm really unsure of the convention, for instance whether to use commas and variations such as (anim:, animframes:, animrate: ) are any of these used, or do I simply use numbers?

Another thing I'm unsure of is how RPG maker is actually to understand the files you are trying to call. As with other plugins such as Orange Overlay, you specify in the map in the file naming convention. Whereas here I have DoorTest, DoorTest00, DoorTest01 and so on. So that being said does the plugin simply infer the "00, 01, 02" from the filename "DoorTest" or is there something I'm missing to tie the frames to the map?

As it currently stands, I have one still fullscreen image, which is static and central (as planned) but with no animation. If anyone has an example of a command for a simple picture animation I would be extremely grateful as I've been screaming at my computer all day.

I'm sure the instructions are easy to follow for the right person, but unfortunately I am a dumb-ass and only really good for art.
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
915
First Language
Finnish
Primarily Uses
RMMZ
Hi, I'm wondering if anyone could give me a little bit of help here.

I'm simply trying to animate a few frames using commands, but I've gone through various iterations and can't seem to get the thing to work.

"layer 2 DoorTest 0 0 true anim:3,17"

This is the last version I used to no avail. I have looked at the templates and the notes and I'm really unsure of the convention, for instance whether to use commas and variations such as (anim:, animframes:, animrate: ) are any of these used, or do I simply use numbers?

Another thing I'm unsure of is how RPG maker is actually to understand the files you are trying to call. As with other plugins such as Orange Overlay, you specify in the map in the file naming convention. Whereas here I have DoorTest, DoorTest00, DoorTest01 and so on. So that being said does the plugin simply infer the "00, 01, 02" from the filename "DoorTest" or is there something I'm missing to tie the frames to the map?

As it currently stands, I have one still fullscreen image, which is static and central (as planned) but with no animation. If anyone has an example of a command for a simple picture animation I would be extremely grateful as I've been screaming at my computer all day.

I'm sure the instructions are easy to follow for the right person, but unfortunately I am a dumb-ass and only really good for art.
Thank you for the message,

To set custom animated layer isn't easiest thing to do... here is example that works for me:
layer 2 wavytreetops 0 0 1 true 255 loop:0,0 anim:3,250 offset:0,0

In our example: Make sure that you have wavytreetops001.png, wavytreetops002.png, wavytreetops003.png in your pictures folder (please note that wavytreetops was just example).

Explanation for parameters:
layer indx imgName scrollX scrollY opacity fixToMap fade loop:x,y anim:frames,rate offset:x,y

I wish MV had plugin commands like in MZ...
 

Mr_taxidermy

Warper
Member
Joined
May 10, 2020
Messages
4
Reaction score
1
First Language
English
Primarily Uses
RMMV
Thank you for the message,

To set custom animated layer isn't easiest thing to do... here is example that works for me:
layer 2 wavytreetops 0 0 1 true 255 loop:0,0 anim:3,250 offset:0,0

In our example: Make sure that you have wavytreetops001.png, wavytreetops002.png, wavytreetops003.png in your pictures folder (please note that wavytreetops was just example).

Explanation for parameters:
layer indx imgName scrollX scrollY opacity fixToMap fade loop:x,y anim:frames,rate offset:x,y

I wish MV had plugin commands like in MZ...

Oh my god, I am so pleased you would not believe. You have actually made my day, thank you so, so much for that! You truly are a servant of the universe!
 

Mr_taxidermy

Warper
Member
Joined
May 10, 2020
Messages
4
Reaction score
1
First Language
English
Primarily Uses
RMMV
Thank you for the message,

To set custom animated layer isn't easiest thing to do... here is example that works for me:
layer 2 wavytreetops 0 0 1 true 255 loop:0,0 anim:3,250 offset:0,0

In our example: Make sure that you have wavytreetops001.png, wavytreetops002.png, wavytreetops003.png in your pictures folder (please note that wavytreetops was just example).

Explanation for parameters:
layer indx imgName scrollX scrollY opacity fixToMap fade loop:x,y anim:frames,rate offset:x,y

I wish MV had plugin commands like in MZ...

One last thing, how do I actually exit the animation after the final frame? As some of my animations are not intended to loop. Do I need to use other event commands or is there anything in the plugin that would work. I've seen things like "CLEAR ALL sprites with desired id" but that is not good in this situation.

Thanks again for the help earlier this really works well, I'm going to check out some of your other plugins!
 

Latest Threads

Latest Posts

Latest Profile Posts

My new 49" monitor has been dispatched from the warehouse. Will it arrive tomorrow? The day after? I love that we can track packages now, even if it does only tell me when it's left that end and when it's arrived at the local centre. As long as it doesn't end up in Melbourne again, which has happened before ...
My friend's doing a surprise stream of my game Origin Hunt on Twitch here ! Feel free to stop by :yhappy:
Me, designing it a long time ago: Having an optional boss fight as a random chance to trigger when you fish in a certain spot with a certain type of bait is fun! Cool idea!
Me, trying to playtest everything again: oh god just let me see the boss, my bag is so full of fish!
both love and pain have no boundaries

Forum statistics

Threads
117,221
Messages
1,105,611
Members
153,368
Latest member
universalwonder
Top