OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
913
First Language
Finnish
Primarily Uses
RMMZ
One last thing, how do I actually exit the animation after the final frame? As some of my animations are not intended to loop. Do I need to use other event commands or is there anything in the plugin that would work. I've seen things like "CLEAR ALL sprites with desired id" but that is not good in this situation.

Thanks again for the help earlier this really works well, I'm going to check out some of your other plugins!
Thank you for the message,

At the moment I have only looping animations implemented.
 

ScreamingLadybug

Villager
Member
Joined
Jun 6, 2016
Messages
14
Reaction score
0
First Language
English
Primarily Uses
RMMV
The download link doesn't work for me. It just shows up blank
 

LUKElcs

Veteran
Veteran
Joined
Aug 20, 2018
Messages
123
Reaction score
26
First Language
English
Primarily Uses
RMMV
@OcRam Hey, so I've been having some issues with getting this plugin to work... Like, at all.
All I want to do is have a layer bound to map that's above players.
However, that layer appears on the next map, rather than the one I call it on, and it slowly fades in instead of appearing instantly, and I'm not a pro scripter, like, at all, so I'm completely confused.
Here are some screenshots of my plugins, and any parameters that may be of use. (including the event I called it with, as well as the image I'm trying to use.

Thankyou for responding, and thankyou for making this awesome plugin! :D
(also, keep an eye on what plugins are disabled, and what ones are active, I have a few inactive plugins still in there, like bind picture to map) Also, also, the reason for not using bind picture to map is because it conflicts with MOG_Weather effects.
Map004-overhead.pngice_screenshot_20201015-134308.pngice_screenshot_20201015-134327.pngice_screenshot_20201015-134354.pngice_screenshot_20201015-134400.pngice_screenshot_20201015-134405.pngice_screenshot_20201015-134408.png
 

kako05

Veteran
Veteran
Joined
Sep 11, 2017
Messages
191
Reaction score
29
First Language
Australian
Primarily Uses
RMMV
Hey, so I've been having some issues with getting this plugin to work... Like, at all.
All I want to do is have a layer bound to map that's above players.
However, that layer appears on the next map, rather than the one I call it on, and it slowly fades in instead of appearing instantly, and I'm not a pro scripter, like, at all, so I'm completely confused.
Here are some screenshots of my plugins, and any parameters that may be of use. (including the event I called it with, as well as the image I'm trying to use.

Thankyou for responding, and thankyou for making this awesome plugin! :D
(also, keep an eye on what plugins are disabled, and what ones are active, I have a few inactive plugins still in there, like bind picture to map) Also, also, the reason for not using bind picture to map is because it conflicts with MOG_Weather effects.

For me, layers appear in different maps too. Even when you start a new game. Weirdest thing ever.
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
913
First Language
Finnish
Primarily Uses
RMMZ
@OcRam Hey, so I've been having some issues with getting this plugin to work... Like, at all.
All I want to do is have a layer bound to map that's above players.
However, that layer appears on the next map, rather than the one I call it on, and it slowly fades in instead of appearing instantly, and I'm not a pro scripter, like, at all, so I'm completely confused.
Here are some screenshots of my plugins, and any parameters that may be of use. (including the event I called it with, as well as the image I'm trying to use.

Thankyou for responding, and thankyou for making this awesome plugin! :D
(also, keep an eye on what plugins are disabled, and what ones are active, I have a few inactive plugins still in there, like bind picture to map) Also, also, the reason for not using bind picture to map is because it conflicts with MOG_Weather effects.
For me, layers appear in different maps too. Even when you start a new game. Weirdest thing ever.
Thank you for the message,

Personally I don't use templates to do parallax mapping.

I use following plugin command: layer 1 map[mapId] 0 0 1 true 256

Just make sure that you got all maps (in pictures folder) named example map002.png

I have set layer 1 z-index to "Behind weather" and not as "Battle layer"

I also have demo project @ https://ocram-codes.net
 

LUKElcs

Veteran
Veteran
Joined
Aug 20, 2018
Messages
123
Reaction score
26
First Language
English
Primarily Uses
RMMV
Thankyou, though I should have mentioned that I'm not using parallax for every map, would that make any difference in the command?
 

kako05

Veteran
Veteran
Joined
Sep 11, 2017
Messages
191
Reaction score
29
First Language
Australian
Primarily Uses
RMMV
Thank you for the message,

Personally I don't use templates to do parallax mapping.

I use following plugin command: layer 1 map[mapId] 0 0 1 true 256

Just make sure that you got all maps (in pictures folder) named example map002.png

I have set layer 1 z-index to "Behind weather" and not as "Battle layer"

I also have demo project @ https://ocram-codes.net

It's working just fine for me. Enter map, commands to show parallax mapping. Fine.
Save. Load. Parallax mapping disappears.
Back to the title screen. Start a new game and parallax map which was loaded with commands previously appears in the new game, in a map where your plugin was never used.
Probably plugin compatibility issues. Other parallax mapping plugins don't have this issue though.
The strangest thing that the parallax map used previously appears in the new game for no reason.
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
913
First Language
Finnish
Primarily Uses
RMMZ
Thankyou, though I should have mentioned that I'm not using parallax for every map, would that make any difference in the command?
It is same command. Oh and I forgot to mention that you should clear any parallax layers with plugin command: clear_layer 1 256 when ever you leave the map.
 

kako05

Veteran
Veteran
Joined
Sep 11, 2017
Messages
191
Reaction score
29
First Language
Australian
Primarily Uses
RMMV
It is same command. Oh and I forgot to mention that you should clear any parallax layers with plugin command: clear_layer 1 256 when ever you leave the map.
What about when you go back to the title screen and start a new game?
Loading older save etc?
Is this a problem because the game doesn't clean the parallax map itself?
Maybe this is an issue with plugins changing "saving" behavior?
for example
 

OcRam

Servant of the Universe
Veteran
Joined
Aug 2, 2016
Messages
797
Reaction score
913
First Language
Finnish
Primarily Uses
RMMZ
What about when you go back to the title screen and start a new game?
Loading older save etc?
Is this a problem because the game doesn't clean the parallax map itself?
Maybe this is an issue with plugins changing "saving" behavior?
for example
What version of this plugin is in use?

2020/06/12 v2.04
  • Fixed bug where "Test event" crashed game - Requires OcRam_Core v1.5 (Credits to jjraymonds)
  • Fixed bug: Will now properly clear all layers on "Return to title" command and "Game over"

And latest version is v2.05 released (2020/06/16).

EDIT: And OcRam_Core is always included in OcRam -plugins (only for MV)
 

kako05

Veteran
Veteran
Joined
Sep 11, 2017
Messages
191
Reaction score
29
First Language
Australian
Primarily Uses
RMMV
What version of this plugin is in use?

2020/06/12 v2.04
  • Fixed bug where "Test event" crashed game - Requires OcRam_Core v1.5 (Credits to jjraymonds)
  • Fixed bug: Will now properly clear all layers on "Return to title" command and "Game over"

And latest version is v2.05 released (2020/06/16).

Oh. Probably I used an older version. Last time I used this plugin was
Jan 11, 2020
Happy to see it's fixed. Hopefully loading a savegame clears the parallax map and loads the layer made in that save too.
Those were the only issues, but big ones. Otherwise, was working great. One of the best if not best.
 

yeahchris

Veteran
Veteran
Joined
Apr 14, 2020
Messages
89
Reaction score
24
First Language
English
Primarily Uses
RMMV
Oh. Probably I used an older version. Last time I used this plugin was
Jan 11, 2020
Happy to see it's fixed. Hopefully loading a savegame clears the parallax map and loads the layer made in that save too.
Those were the only issues, but big ones. Otherwise, was working great. One of the best if not best.
No idea if you're interested in doing this, but I ended up replacing the normal save function with a common event that:

  1. Faded to black
  2. Cleared all layers
  3. Transitioned to a new area
  4. Set my "layers loaded" switch to 0.
  5. Brings up save prompt
  6. Transitioned player back to previous spot
The end result being that when you load the save it immediately triggers an area transition back to wherever you were when you saved. Since my "layers loaded" switch is off the event that I have in place to load the layers runs normally.

Far easier to manage in the long run and far less prone towards weird or unexpected behavior.

This is all completely invisible to the player if you want it to be.
 

kako05

Veteran
Veteran
Joined
Sep 11, 2017
Messages
191
Reaction score
29
First Language
Australian
Primarily Uses
RMMV
No idea if you're interested in doing this, but I ended up replacing the normal save function with a common event that:

  1. Faded to black
  2. Cleared all layers
  3. Transitioned to a new area
  4. Set my "layers loaded" switch to 0.
  5. Brings up save prompt
  6. Transitioned player back to previous spot
The end result being that when you load the save it immediately triggers an area transition back to wherever you were when you saved. Since my "layers loaded" switch is off the event that I have in place to load the layers runs normally.

Far easier to manage in the long run and far less prone towards weird or unexpected behavior.

This is all completely invisible to the player if you want it to be.

Can't test it, I'm using a different layer plugin atm., but would like to return to this one in the future because it has some nice additions. You're saying that loading breaks layers? IF layers are not loaded correctly upon "load", it's a huge problem, and going all the trouble to set up this is not worth it.
 

yeahchris

Veteran
Veteran
Joined
Apr 14, 2020
Messages
89
Reaction score
24
First Language
English
Primarily Uses
RMMV
Can't test it, I'm using a different layer plugin atm., but would like to return to this one in the future because it has some nice additions. You're saying that loading breaks layers? IF layers are not loaded correctly upon "load", it's a huge problem, and going all the trouble to set up this is not worth it.
My setup involved a parallel event to initialize the layers which set a switch to disable itself when finished. My recollection is that layers would not persist if a save were loaded. Since my parallel event had already triggered the disable switch, and that *was* baked into the save, it would not run again.

I want to say that it actually made a difference if you saved/quit to main menu and then reloaded vs actually saving and quitting the application and then reloading. In any case, it was clear to me at the time that the current state of whatever commands I sent at the plugin were not being baked into the save file, but were rather being stored in memory, such that closing the application wiped it away.

So I came to the determination that it was important to set up my events to account for that.

This was all on a much older version of the plugin, but the issues you described sounded similar to what I experienced and ultimately resolved by customizing my save function, so I thought I would share.

Also, please bear in mind that I went through and fixed all this months ago so my recollection is a bit foggy.

In all the customization to the save behavior took maybe 5 minutes and it made layer behavior fully and reliably persistent regardless of saves/loads/application exits.
 
Last edited:

LUKElcs

Veteran
Veteran
Joined
Aug 20, 2018
Messages
123
Reaction score
26
First Language
English
Primarily Uses
RMMV
I
My setup involved a parallel event to initialize the layers which set a switch to disable itself when finished. My recollection is that layers would not persist if a save were loaded. Since my parallel event had already triggered the disable switch, and that *was* baked into the save, it would not run again.

I want to say that it actually made a difference if you saved/quit to main menu and then reloaded vs actually saving and quitting the application and then reloading. In any case, it was clear to me at the time that the current state of whatever commands I sent at the plugin were not being baked into the save file, but were rather being stored in memory, such that closing the application wiped it away.

So I came to the determination that it was important to set up my events to account for that.

This was all on a much older version of the plugin, but the issues you described sounded similar to what I experienced and ultimately resolved by customizing my save function, so I thought I would share.

Also, please bear in mind that I went through and fixed all this months ago so my recollection is a bit foggy.

In all the customization to the save behavior took maybe 5 minutes and it made layer behavior fully and reliably persistent regardless of saves/loads/application exits.
I just had a parallel process event that didn't disable itself, and instead just kept running.
I never experienced any lag, as a matter of fact, that's something a lot of games do.
That's much easier than customizing your save function I think, but if you really have to, you can do things that way also I guess.
 

yeahchris

Veteran
Veteran
Joined
Apr 14, 2020
Messages
89
Reaction score
24
First Language
English
Primarily Uses
RMMV
I

I just had a parallel process event that didn't disable itself, and instead just kept running.
I never experienced any lag, as a matter of fact, that's something a lot of games do.
That's much easier than customizing your save function I think, but if you really have to, you can do things that way also I guess.
If I recall correctly this works fine for layers that don't scroll, but if you have a scrolling layer having the process keep running will mess with the X,Y position of the layer.

My game had scrolling layers and I had to account for that.
 

KotoYama

Veteran
Veteran
Joined
Apr 20, 2019
Messages
447
Reaction score
80
First Language
Spanish
Primarily Uses
RMMV
I'm trying to make a simple parallax map. One layer below the character, the seconds above, but I'm failing over and over again.
Here are my two plugin commands:
layer 2 dungeons_base 0 0 1 true
layer 3 dungeons_top 0 0 1 true


As a result, the second layer doesn't show at all and the first one slowly fading in until it becomes above the character... Am I doing something wrong?
 

Peter_Snayde

Villager
Member
Joined
Jan 22, 2019
Messages
23
Reaction score
3
First Language
English
Primarily Uses
RMVXA
I'm trying to make a simple parallax map. One layer below the character, the seconds above, but I'm failing over and over again.
Here are my two plugin commands:
layer 2 dungeons_base 0 0 1 true
layer 3 dungeons_top 0 0 1 true


As a result, the second layer doesn't show at all and the first one slowly fading in until it becomes above the character... Am I doing something wrong?

Try next:
layer 1 dungeon_base 0 0 * true 255 loop:0,0
layer 2 dungeon_top 0 0 * true 255 loop:0,0
And be sure that here:
1608414382212.png
all set as You need.
 

Latest Threads

Latest Profile Posts

thanks to a lot of lunatic coding... my game finally has a stun mechanic that I feel really good about. damage enemy's mental psyche (mp), and once empty, hitting with certain attacks trigger combos that can stack the damage.
Waiting for the 1.40 update before testing out my copy of MZ so that I don't end up adding unnecessary work to my plate. Meanwhile the current fourth draft for my story is taking shape, and I'm fleshing out the lore as I realize how things would make better sense here and there for the world that I'm building.
Sword_of_Dusk wrote on BCj's profile.
Just found out about your complications. I'm so sorry that you're going through this. I wish I could do something substantial for you, but our distance from each other makes that an impossibility. Still, if you ever need to talk or vent, I'm here.
Candacis wrote on BCj's profile.
I don't know, if any words will help right now, but here is a hug. And my offer to help you with Escalia, if you ever want or need help with it. Tiles or mapping especially.
MZ weather + title screen update is here! (Also includes MZ and MV RETRO demo project updates)

Forum statistics

Threads
117,110
Messages
1,104,655
Members
153,141
Latest member
bigdaddyloll
Top