Official Bug Report

Status
Not open for further replies.

TNinja

Villager
Member
Joined
Jan 21, 2013
Messages
12
Reaction score
0
First Language
Norwegian
Primarily Uses
It's the same link that you originally used for the download, given to you by the purchase mail.

Alternatively you can simply download the trial (it's the same file) and activate it with your key.
Unfortunately, these solutions change dnothing. The program still freezes.

EDIT: I see now. I only updated the program itself. Previous projects also needed an update.
 
Last edited by a moderator:

Sythian Bard

Self Proclaimed Beard Extraordinaire
Veteran
Joined
Jun 23, 2015
Messages
169
Reaction score
351
First Language
English
Primarily Uses
RMMV
Generator Missing Files??? Does that constitute as Bug?

 

Generator / SV, TV, TVD, & Variation / Front Hair p16 are missing. The Face file only is there.

 

Has this been mentioned? :unsure:  Surely it has! Mod's, please don't smite me if it has.  :p

 
 

A_Higher_Plane

Veteran
Veteran
Joined
Oct 3, 2015
Messages
258
Reaction score
30
First Language
Russian
Primarily Uses
RMMV
Ooooooh I think I have found a bug. I don't know if anyone has said this. I have created skills with "None' as the scope and for different skills it gave different errors. I made the scope none because I wanted a skills that can target ALL beings in the field. Or I can do it without a plug-in? I believe there was one. Which one was it?
 

Prescott

argggghhh
Veteran
Joined
Aug 28, 2014
Messages
507
Reaction score
426
First Language
English
Primarily Uses
RMMV
Don't know if this has been reported or not, but when entering a negative amount into the Attack State trait, it still shows up as positive. Not sure if this is supposed to happen or not since I've never dealt with this stuff... but it certainly seems like a bug.
 
Joined
Oct 25, 2015
Messages
1
Reaction score
0
First Language
Netherlands
When i make a event that uses a tile from the tileset it does not execute
 

brendonx

Veteran
Veteran
Joined
Oct 30, 2015
Messages
85
Reaction score
5
First Language
English
I have this issue (even without any plugins running) where an error occurs when I use a technique in battle that targets the user. It occurs right after the skill animation happens. Is it something I'm doing wrong?

image.jpeg
 
Last edited by a moderator:

Hail4Gaming

Hail4Gaming
Member
Joined
May 30, 2015
Messages
7
Reaction score
0
First Language
English
@Yanfly hey Yanfly. Here is a video of my bug. Where the silence bubble randomly pops up on attack due to Battle Engine Core Plugin.

https://youtu.be/F32JlTBfVRM I have posted it on YouTube. It is only 2:32 in length. So it should not be a problem to watch. I show the issue when the plugin is active and how it gets fixed when I deactivate the plugin.

Also, I just noticed there was another update for the plugins. I downloaded this update a few moments ago, after the video had already been recorded. The update still does NOT fix the issue at hand.
 

HeroicJay

Veteran
Veteran
Joined
Jun 23, 2014
Messages
322
Reaction score
177
First Language
English
Primarily Uses
RMMV
Not this one's kind of subtle and whether it qualifies as a "bug" is arguable. As a music nerd, I don't like it though.

There's a short but noticeable audio lag whenever a new BGM starts to play. VX Ace did not have this lag. This is just enough to mess up the timing of an event I'd already written in VX Ace and hadn't tested much in MV.
 

gamerxp

Veteran
Veteran
Joined
Oct 28, 2015
Messages
30
Reaction score
5
First Language
Russian
Primarily Uses
Did you turn off the TP gauge or something? This error is trying to adjust the gradient of the HP but the HP gauge isn't present or something.
I tried with both TP gauge on and off - it's same. Tried with plugins and without - it's same. Always happens when monster uses skill. Maybe it have something to do with side-view battles - dunno.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,747
Reaction score
7,860
First Language
German
Primarily Uses
RMMV
When i make a event that uses a tile from the tileset it does not execute
Most probably that has something to do with your event code and triggers, not with the tile. Please make a new support topic with screenshots of your event so that we can search a solution there.
 

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
125
Not this one's kind of subtle and whether it qualifies as a "bug" is arguable. As a music nerd, I don't like it though.

There's a short but noticeable audio lag whenever a new BGM starts to play. VX Ace did not have this lag. This is just enough to mess up the timing of an event I'd already written in VX Ace and hadn't tested much in MV.
Preload the audio, and it shouldn't happen. 

The problem with WebAudio is that, at least in node-webkit, it doesn't actually stream from disk. If you watch the memory usage when playing BGM, the audio will increase the memory footprint by like 50MB. 50MB is roughly 8 minutes. Now the reason for that is the looping requirement since if the entire audio isn't in memory, it would have to re-seek from the disk. 

Pre-loading the audio causes the file to be stored in the cache. Though it may be possible to retool (eg with a plugin) so that the scene doesn't load before the audio starts, but this might not be the desired effect. Remember if you create a html5 "web browser" game, the audio may take minutes to download from cheap webhosts. For example the demo game that was put up was stored on Amazon EC2 and took roughly 15 minutes to load all the assets.
 
Last edited by a moderator:

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,299
Reaction score
11,714
First Language
English
Primarily Uses
RMVXA
@Hail4Gaming

This is not the place to report Yanfly bugs, but engine bugs.

Please report either directly to Yanfly's site or, if there is a thread dealing with that plugin here, in the forum for js plugin support.
 

boldpaste2

The Dragon Heretics
Veteran
Joined
Dec 7, 2013
Messages
797
Reaction score
439
First Language
English
Primarily Uses
Not sure if its a missing feature or was intended but I am going to throw it out there.

I notice that in ACE, when going into fullscreen, the monitors resolution changes to match the game to allow for a crisp display. However, in MV, I notice this does not occur which means going into full screen mode will make the game blurry. This means tiles that are 32X32 will look pretty bad and if your going to go smaller then that 16X16 it will become unplayable. I think this is a design oversight and really needs to be in there.
 
Last edited by a moderator:

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
125
Not sure if its a missing feature or was intended but I am going to throw it out there.

I notice that in ACE, when going into fullscreen, the monitors resolution changes to match the game to allow for a crisp display. However, in MV, I notice this does not occur which means going into full screen mode will make the game blurry. This means tiles that are 32X32 will look pretty bad and if your going to go smaller then that 16X16 it will become unplayable. I think this is a design oversight and really needs to be in there.
Can't be done. 

1) The resolution used isn't a valid screen resolution

2) Chromium/node-webkit doesn't do this.

There is a quasi-workaround to it by telling the game engine not to use bilinear filtering using a simple CSS directive, but to actually turn off all filtering, the bitmap loading routine has to be overridden with a plugin AFTER the game engine loads but BEFORE any images are loaded.
 

Liak

Veteran
Veteran
Joined
Mar 13, 2012
Messages
1,788
Reaction score
270
First Language
German
Primarily Uses
There seems to be a bug with the Auto Battle trait.

As far as I could test it, characters with Auto Battle will spam offensive magic until their MP are depleted and never use defensive magic like buffs and debuffs. I could only test this by letting them auto-battle for a while, so maybe someone could have a look at the scripts and confirm this.
 

Kaliya

// Caffeine Overload
Developer
Joined
Nov 1, 2015
Messages
506
Reaction score
566
First Language
English
Primarily Uses
RMMV
I tried with both TP gauge on and off - it's same. Tried with plugins and without - it's same. Always happens when monster uses skill. Maybe it have something to do with side-view battles - dunno.
This bug happens when you have a damage type selected, but no formula entered. Is this the case? Check your skills formula. I'll see about writing up a plugin that fixes this and defaults the damage to 0.
 

voymasa

Veteran
Veteran
Joined
Jul 25, 2013
Messages
124
Reaction score
18
First Language
English
Primarily Uses
I found a bug with the map and starting position. I created a map and placed the starting point on it because the default map wasn't allowing me to remove the grass tiles and make them blank. When I run the playtest the player won't move, but when I return the start position to the default map it works fine. I turned off all plugins and parallax backgrounds, and even switched to the default actor on start. It won't allow the player to move unless the playtest starts in the default map.
 

namsterdamus

Warper
Member
Joined
Sep 23, 2013
Messages
1
Reaction score
0
First Language
English
I had a problem with the Sci-Fi tiles that came with MV for some reason the transparent sidewalk tiles on SF_Outside_A5.png are not transparent, Instead I get the checkered pattern filling in where it should be transparent. This on the default SF tileset, any idea why this is happening? I assume maybe it's was not setup properly.

 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Based on this screenshot alone, which one would you sell, and which to equip?
Some random sketch-letons.

I have a strong urge to make a tutorial video of all the random things I've learned since starting on my game. little helpful tips and stuff that may help people.
Do you guys think it's better to have all members in your team from the beginning (then you can pick who battles) or you gain team members as the story goes?
PL: Patch polonizujący do RPG Makera 2003 prawie gotowy! Mamy przetłumaczoną bazę danych (projekt), polskie fonty, wiadomości walki i jakieś 90% edytora.
Do przetłumacznia pozostało te 10% edytora i plik pomocy. Niedługo więcej informacji!

Forum statistics

Threads
107,477
Messages
1,029,956
Members
139,605
Latest member
Anime_Weeb
Top