Official Bug Report

Status
Not open for further replies.

Skurge

" (GASP) What's going on!? "
Veteran
Joined
Jul 12, 2015
Messages
1,126
Reaction score
231
First Language
English
Primarily Uses
N/A
RPG Maker MV will not let me make my own animations, I cannot move any frames from the list or otherwise- completely useless at the moment with this function.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
38,837
Reaction score
12,251
First Language
English
Primarily Uses
RMMV
@Shin Kitsune, do you have any plugins?  If you disable all of them, does the issue still happen?

@Ice Dragon, there is a pinned thread with update information.  Since you haven't specified what "bugs" your MV has, I can't tell you whether there is an update that fixes them.

@Skurge, doesn't happen to me.  You need to explain what you are doing and what is happening, step by step.
 

GrandmaDeb

Modern Exteriors Posted!
Veteran
Joined
Apr 25, 2012
Messages
4,467
Reaction score
2,887
Primarily Uses
How can we know if our posts are being noticed? Or are already fixed? Or if we aren't seeing a bug but just have poor implementation?


For example, I am not sure if my post was put on a list somewhere or if I am mistaken in my problem solving. =]


Could there be a way - without a killing time burden - let people know if their post is on a "We got that and we will check it out" list or something?


=]
 

Cassta

Villager
Member
Joined
Nov 3, 2015
Messages
15
Reaction score
2
First Language
English
I'm the odd one out and using a Macbook 13". 

In the event creation menu, if the window is too close to the bottom of the screen clicking the "Trigger" dropdown will goof up and appear at top of the screen with no capability to change it. I have to make it so my dock (menu bar for you Window users) automatically disappears for this function to work, but would love a real fix. 
 

Liak

Veteran
Veteran
Joined
Mar 13, 2012
Messages
1,789
Reaction score
269
First Language
German
Primarily Uses
One more from me: If you select an enemy in the database that has its color changed with the built-in hue changer, there is severe lag before the image is fully loaded, and once it's there, the right-click menu opens itself automatically. No idea what's going on there exactly, but it sure needs improvement.
 

Shin Kitsune

KITSUNE Game Design
Veteran
Joined
Oct 15, 2012
Messages
134
Reaction score
32
First Language
ENG/SPA
Primarily Uses
@Shin Kitsune, do you have any plugins?  If you disable all of them, does the issue still happen?
Looks like I found the culprits. I'm using Yanfly's Core Engine Plugin and Message Core Plugin. The glitch happens if I activate at least Core Engine.
 

ScroogeMcDuck

Villager
Member
Joined
Oct 28, 2015
Messages
15
Reaction score
1
First Language
English
Primarily Uses
Out of nowhere, the audio broke. All sounds stutter. They go d-d-d-d-d-d-d-d-d-a-a-a-a-a-o-o-o-o-o-o-o-o... (you get the idea)  it only stutters within the RPG program, so it's an isolated incident. (winmap/mediate player[classic] etc) all play normally.

edit: reinstalling didn't fix this (deleted the main folder)

edit2: i left things as they were (music list open) went out to eat, came back and hit play expecting to hear the stutter, but no.. it plays normal now! It came and went...   just be on the look out for this :)
 
Last edited by a moderator:

xdeath

Warper
Member
Joined
Nov 5, 2015
Messages
4
Reaction score
0
First Language
English
need help... i try the trial ver. but when i click the menus or just highlight it, it crash... ;_;

sorry bad english..

error.jpg
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
38,837
Reaction score
12,251
First Language
English
Primarily Uses
RMMV
@xdeath - this is not a bug with the engine, and this thread is not a support thread.  Could you please post this in its own thread so some troubleshooting can be done?
 

BMASTER

Villager
Member
Joined
Nov 16, 2014
Messages
7
Reaction score
1
First Language
German
Primarily Uses
I have a problem with crackling sounds. While playtesting and soundtesting.
Does anyone know something about that?

EDIT:

Ok, that's weird.
 

I just went back after writing the above text and the crackling wasn't there anymore. So I double checked and restarted the RPG Maker. And there was it again. It kinda looks, like it is loading all the stuff, before it works well. If so, this might be a big problem and probably even the reason for some other bugs o_O
 
Last edited by a moderator:

Tsukihime

Veteran
Veteran
Joined
Jun 30, 2012
Messages
8,230
Reaction score
3,076
First Language
English
Create an parallel process event

if timer <= 0 mins 0 secs open menuendwait 1 frameCreate another event
Code:
control timer: 5 secsshow text "Hello"Show choices "Yes", "no"
Now run the second event and wait for the timer to run down.Parallel process will trigger menu open. Close menu, crash
 

Farr

Veteran
Veteran
Joined
Feb 16, 2014
Messages
247
Reaction score
92
First Language
Portuguese
I dont know if this has already been posted somewhere;

If I talk with a NPC with frequency 5 (Hightest) the message will popup but he will still continue to walk around.
 

ze1

Veteran
Veteran
Joined
Apr 19, 2012
Messages
30
Reaction score
4
Primarily Uses
I found a way to make MV crash

1) Enter the event editor mode on the main screen

2) Press enter, and quickly press up (or any arrow key) and press enter again

Does this happen to anyone else?
 

SuperMasterSword

That Guy You Dont Know
Veteran
Joined
Jun 28, 2014
Messages
117
Reaction score
48
First Language
Javascript
Primarily Uses
RMMV
Okay, so by now I've done much more testing and figured out that Hoppy was right, it wasn't the multi-hit attacks that was making him stop attacking. The guy with the 9-hit attack also had a 25% chance of inflicting the default "Rage" state on the target, and for some reason it seems like this was making him unable to move. Although the restriction is just "Attack An Enemy" so I don't know what's up with it, perhaps it's that he was the only enemy and so he had no targets? But I thought that restriction was supposed to make them attack their own enemies, it also could have to do with the fact that very often, he would inflict the state and cancel it out in the same turn because of how much he attacked and the relatively high removal chance of the state. In fact it wasn't rare that he would inflict it, cancel it out, inflict it again, maybe cancel it out again, such as that, I don't know if that would have anything to do with this weird bug but I thought I'd mention it just in case. (Although it might just turn out that the restriction indeed tries to only attack monsters in which case I know exactly what the problem is and it's not even a bug and I said all this for nothing :( )
 

danielvutran

Villager
Member
Joined
Oct 14, 2015
Messages
19
Reaction score
6
First Language
English! xD
Primarily Uses
Just going to add another +1 to the audio issues party! Sound test preview no longer works for me when previewing BGM or SE. In fact, RPG Maker MV is not even showing up in my volume mixer! Very strange indeed lol as it was working just fine a few days ago... xp 
 

MaxLionheart

Veteran
Veteran
Joined
Aug 23, 2015
Messages
91
Reaction score
28
First Language
French
Hey guys,

I'm getting a weird error sometimes that makes the game crash when I test play my project... The thing that is weird, is I haven't been able to replicate this bug on a steady basis... It seems to happen randomly... Sometimes I can play for 30 minutes without getting it, sometimes I get it twice in a row, sometimes at the exact same place, but often not... But one thing sure, it always ends up happening.

So what happens is that the game crashes and shows me the following error: Uncaught TypeError: "Cannot read property "width" of null". After some research on google, I think it has something to do with the game trying to load an image, but I'm not certain. I'm guessing it has to do with loading images in the picture folder, as I don't see anything wrong on the screen when it happens. Also, I'm pretty sure the bug only happens when an event tries to load an image in the picture folder (and the game crashed before showing that picture).

As mentionned earlier, the bug seems to happen randomly...  To try to replicate this bug, I've created an autorun event on the map with the character starting position that will load a picture then erase it. Sometimes, I can get the bug happen in two new games in a row (I always close and reopen the test play window when I try twice in a row), but sometimes, the event will run normally in 10 new games in a row.

This bug happens to me whether I have no plugin activated or several.

I've attached a screenshot of the debug console.

Thank you



Error.png
 

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
122
Hey guys,

I'm getting a weird error sometimes that makes the game crash when I test play my project... The thing that is weird, is I haven't been able to replicate this bug on a steady basis... It seems to happen randomly... Sometimes I can play for 30 minutes without getting it, sometimes I get it twice in a row, sometimes at the exact same place, but often not... But one thing sure, it always ends up happening.

So what happens is that the game crashes and shows me the following error: Uncaught TypeError: "Cannot read property "width" of null". After some research on google, I think it has something to do with the game trying to load an image, but I'm not certain. I'm guessing it has to do with loading images in the picture folder, as I don't see anything wrong on the screen when it happens. Also, I'm pretty sure the bug only happens when an event tries to load an image in the picture folder (and the game crashed before showing that picture).

As mentionned earlier, the bug seems to happen randomly...  To try to replicate this bug, I've created an autorun event on the map with the character starting position that will load a picture then erase it. Sometimes, I can get the bug happen in two new games in a row (I always close and reopen the test play window when I try twice in a row), but sometimes, the event will run normally in 10 new games in a row.

This bug happens to me whether I have no plugin activated or several.

I've attached a screenshot of the debug console.

Thank you

The code in question is:

Sprite.prototype._onBitmapLoad = function() { if (this._frame.width === 0 && this._frame.height === 0) { this._frame.width = this._bitmap.width; this._frame.height = this._bitmap.height; } this._refresh();};So this means that the this._bitmap.width is "null" which means the object no longer exists. Or in other words it's trying to load something that doesn't have width property.
 

Liquidize

Caffeine Overload
Developer
Joined
Nov 1, 2015
Messages
466
Reaction score
459
First Language
English
Primarily Uses
RMMV
So this means that the this._bitmap.width is "null" which means the object no longer exists. Or in other words it's trying to load something that doesn't have width property.
Which that in itself isn't really a bug per say. What do you expect to happen when a game tries to load a resource that doesn't exists :p ?  Most games crash, or revert to a built in "error" texture (or in this case picture).  Now they could just leave it as is, or modify it to use an error image (which wouldn't be built in, because on actual game deployment the game isn't packed into an exe or anything, its just HTML and JS with images, so the file may still not exists). This is just my opinion though, since some may find it frustrating to try to manipulate a picture that doesn't exists and get crashes. :p

What someone could do if they wanted, is just check if the width and height are null or undefined before continuing. 

Edit:I apologize for sounding a bit condescending wasn't my attention, this also assumes that the image doesn't exists, because otherwise there really isn't a reason that a picture wouldn't have a width property, unless there is an error in their loading pipeline.
 
Last edited by a moderator:

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
122
Which that in itself isn't really a bug per say. What do you expect to happen when a game tries to load a resource that doesn't exists :p ?  Most games crash, or revert to a built in "error" texture (or in this case picture).  Now they could just leave it as is, or modify it to use an error image (which wouldn't be built in, because on actual game deployment the game isn't packed into an exe or anything, its just HTML and JS with images, so the file may still not exists). This is just my opinion though, since some may find it frustrating to try to manipulate a picture that doesn't exists and get crashes. :p

What someone could do if they wanted, is just check if the width and height are null or undefined before continuing. 

Edit:I apologize for sounding a bit condescending wasn't my attention, this also assumes that the image doesn't exists, because otherwise there really isn't a reason that a picture wouldn't have a width property, unless there is an error in their loading pipeline.
In the context of a game, what you really want is the game to "create a dump file" and then exit.

Without knowing what the user is doing, it's hard to say if it's just what the user is doing that is bad coding, or something that can be addressed by RPG Maker MV's developers.

Like one thing I have noticed in several threads are "lots of parallel" things running. This really shouldn't be happening. Especially in a large map. Sure a high end computer may be able to deal with it, but sufficiently weak machines like Android mobile phones certainly will not.

Now what "IS" a bug, or at least probably unintended behavior.... A little while back I created a "plugin" to force the upscaling algorithm to nearest neighbor, in the process I put one line in there to dump to the console log each file it was reading and discovered something:

disabling smoothing for img/system/Shadow1.png2index.html?test:32 disabling smoothing for img/characters/!SF_Door1.png2index.html?test:32 disabling smoothing for img/characters/!SF_Door2.pngindex.html?test:32 disabling smoothing for img/characters/SF_Vehicle.pngindex.html?test:32 disabling smoothing for img/characters/Vehicle.pngindex.html?test:32 disabling smoothing for img/characters/SF_Vehicle.pngindex.html?test:32 disabling smoothing for img/characters/SF_Actor1.pngindex.html?test:32 disabling smoothing for img/characters/Ki.pngindex.html?test:32 disabling smoothing for img/characters/Ai.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/ButtonSet.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/tilesets/SF_Inside_A4.pngindex.html?test:32 disabling smoothing for img/tilesets/SF_Outside_A5.pngindex.html?test:32 disabling smoothing for img/tilesets/SF_Inside_B.pngindex.html?test:32 disabling smoothing for img/tilesets/SF_Inside_C.pngindex.html?test:32 disabling smoothing for img/tilesets/SF_Outside_B.pngindex.html?test:32 disabling smoothing for img/system/Shadow1.png2index.html?test:32 disabling smoothing for img/tilesets/SF_Inside_C.pngindex.html?test:32 disabling smoothing for img/characters/SF_Vehicle.pngindex.html?test:32 disabling smoothing for img/characters/Vehicle.pngindex.html?test:32 disabling smoothing for img/characters/SF_Vehicle.pngindex.html?test:32 disabling smoothing for img/characters/SF_Actor1.pngindex.html?test:32 disabling smoothing for img/characters/Ki.pngindex.html?test:32 disabling smoothing for img/characters/Ai.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/ButtonSet.pngindex.html?test:32 disabling smoothing for img/system/Window.pngindex.html?test:32 disabling smoothing for img/system/Window.pngNotice how many times certain files are being loaded, particularly "Window.png". I can say with some certainty that there is no reason for it to do this. Even if it was re-loading the images every time the map switched, it shouldn't need to reload that file more than once per map. The web browser would already have it cached, but this does point to something weird in the image handling code.  If you then look at the Network tab, you'll notice that only the Map*.json file and the audio file for the door opening is reloaded. So the browser shouldn't be leaking memory from the image accesses. Therefor in referring back to the previous poster, they should be able to hit F8 and look at the Network tab and see which file is missing.

Also in reference to people complaining about stuttering audio. The only way I've been able to duplicate this on my system is by going to the Profiles tab and running the "record Heap Allocations."  That's like taking someone who is doing a 100 meter dash, and stopping them every meter to measure the wear rate on their shoes. The actual measuring causes the slowness.
 
Last edited by a moderator:

MaxLionheart

Veteran
Veteran
Joined
Aug 23, 2015
Messages
91
Reaction score
28
First Language
French
Well, the thing that I don't understand is that sometimes the event showing the picture works correctly, sometimes it makes the game crashes. So not only do the images exist and are correctly named, but most of the time, the game reads them normally. There's a small percentage of times (maybe like 10%?) that I get the bug.

The events that create the bug look like the following (maybe there are other events that create this, but I tested the bug with the following event):

Autorun Event

Show picture 1

Show picture 2

Show picture 3

Show picture 4

Show picture 5

Wait 1 frame

Erase Picture 1

Erase Picture 2

Erase Picture 3

Erase Picture 4

Erase Picture 5

(each picture are like 300X400 pixels I think, I ask the game to "preload" these images because otherwise, the game shows them blank for a split second, loads it, then shows it, which is annoying and looks weird)

I'm gonna try to place 1 frame of waiting between each show picture, but that would pretty weird if the game crashed it struggles to load 5 small images.

Edit: So after 40 attempts with the following event:

Autorun Event

Show picture 1

Wait 1 frame​

Show picture 2

Wait 1 frame

Show picture 3

Wait 1 frame

Show picture 4

Wait 1 frame

Show picture 5

Wait 1 frame

Erase Picture 1

Erase Picture 2

Erase Picture 3

Erase Picture 4

Erase Picture 5

... the game didn't crash once. I guess it's an annoying workaround for now...

However, I find it weird that if it's truly the case, that the game couldn't load a few little images at the same time without crashing. My computer is very decent and is able to run the newest games at high settings, so it's certainly not the cause (unless maybe there's a component in particular with compatibility issues with the game, but that'd surprise me).

 
Last edited by a moderator:
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Welp, finally posted some images to Twitter that I meant to post last year... Better late than never, right?
Just going to leave this here. :LZSexcite:
Going for a spooky theme with my animal crossing home/town. All I gotta do is find that one gravestone recipe out of hundreds for my cemetary ; u;
Asthma has been getting worse because I can't get my paws on a brown (preventer) inhaler. Been without one for over a week now. Struggling to breathe sucks.
I'm wondering, what if I took the time to make a Bee Hive mirco-biome. It sounds cute, and be a home to that hornet monster, but would anyone actually use it?

Forum statistics

Threads
95,781
Messages
931,896
Members
126,197
Latest member
Sinnott
Top