Status
Not open for further replies.

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
127
Well, the thing that I don't understand is that sometimes the event showing the picture works correctly, sometimes it makes the game crashes. So not only do the images exist and are correctly named, but most of the time, the game reads them normally. There's a small percentage of times (maybe like 10%?) that I get the bug.
Well what you're experiencing is consistent with how "garbage collection" works, where the resource is "free"'d up because it thinks it's no longer in use, but that shouldn't be happening unless the object is "deleted" which should only be happening when it encounters the "erase". It's possible that maybe without the "wait" it's sometimes running ahead of itself and erasing picture 2/3/4/5 before it's actually displayed it. As it is, you actually should be "wait"ing at least 1/60th of a second (eg 1 frame) to show the picture otherwise you're relying on the display speed which may be asynchronous to the actual file i/o.
 
Joined
Nov 7, 2015
Messages
1
Reaction score
0
First Language
English
Already mentioned elsewhere but I'll add it to this list for completion:

Elf ears in the generator are missing for the character and SV battler.
That is strange... It shows up for me. Maybe un-install then re-install?
 

Hopelessdecoy

Villager
Member
Joined
Feb 28, 2014
Messages
13
Reaction score
1
First Language
English
Primarily Uses
Unless they changed how it works I can no longer walk on events (ex: retractable bridges) I set the priority to below characters and that's all you used to have to do but now nothing, it even disallows movement when through is checked in the event.

If anyone knows of how to make it work please let me know otherwise this is a bug for me.
 
Joined
Nov 8, 2015
Messages
2
Reaction score
0
First Language
german
hello i have a problem with RPG Maker MV

if i want to run the play test or theBattle test, the window opens correctly, but the inside of the game.exe-window is white all the time.

i uses windows 8.1 (64 bit) need you more?

can anybody help me please?
 

Cinnamon

Veteran
Veteran
Joined
Jun 20, 2014
Messages
606
Reaction score
210
First Language
English
Primarily Uses
BUG: Armor is NOT properly removed when switching an Actor's class.

I just spent several hours debugging my RMMV project. I switched an Actor's class to one that can't equip the same armor that I had given it. RMMV does NOT properly remove the armor if you don't touch it after changing the class. I ended up with a stray Accessory in my inventory. I had to go to the Actor and manually select "None". That removed it.
 

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
127
BUG: Armor is NOT properly removed when switching an Actor's class.

I just spent several hours debugging my RMMV project. I switched an Actor's class to one that can't equip the same armor that I had given it. RMMV does NOT properly remove the armor if you don't touch it after changing the class. I ended up with a stray Accessory in my inventory. I had to go to the Actor and manually select "None". That removed it.
That sounds like it's by design. If you change a character's class you probably should remove the gear that won't work. 
 

Marston

Veteran
Veteran
Joined
Dec 9, 2013
Messages
195
Reaction score
40
First Language
German
Primarily Uses
So, no idea if this is only a problem with the trial or if it's me. I am using Windows 10. Whenever I try to change the duration or % of a buff or an item (healing effect, buff duration etc.) the whole engine freezes and I can only kill the application. Now, for healing items, after like 10-15 seconds, it reacts and I can do stuff again. But for (de)buff duration, no chance. It just freezes and nothing works anymore.

Here is picture, German version (which I don't want to use, but eh, trial and stuff)
 

KisaiTenshi

Veteran
Veteran
Joined
Oct 24, 2015
Messages
310
Reaction score
127
So, no idea if this is only a problem with the trial or if it's me. I am using Windows 10. Whenever I try to change the duration or % of a buff or an item (healing effect, buff duration etc.) the whole engine freezes and I can only kill the application. Now, for healing items, after like 10-15 seconds, it reacts and I can do stuff again. But for (de)buff duration, no chance. It just freezes and nothing works anymore.

Here is picture, German version (which I don't want to use, but eh, trial and stuff)
Make sure you have 1.0.1 , apparently this version fixed the non-english decimal problem, but I can't verify that.
 

Marston

Veteran
Veteran
Joined
Dec 9, 2013
Messages
195
Reaction score
40
First Language
German
Primarily Uses
Make sure you have 1.0.1 , apparently this version fixed the non-english decimal problem, but I can't verify that.
Can I just update the trial? If so, where exactly do I do that?
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,801
Reaction score
14,970
First Language
English
Primarily Uses
RMMV
I am going to close this thread. There are too many people reporting bugs that they have caused themselves, assuming they are bugs with the engine. And then using this thread to troubleshoot and get help fixing it, when it belongs in its own support thread. In short, I can't keep up with the real bugs because of all the non-bugs being reported.


If you have an issue with the engine and it hasn't been resolved yet, please post a NEW thread in the support forum, even if you've already posted it here. Keeping things in their own threads will make it easier to ask questions without having lots of conversations happening over each other. Anything we identify as a real bug can then be kept in isolation in case kdkw need more information.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

User of Mv3d/ Mz3d and Rosse engine. New Resource Pack on development "Halloween Stones" . Leave ideas about what you want to see on this package. :)
SetPreview.jpg
Looking at Code abd knowing that it made sense at one time. Ugh..why did I ever stop? Well I guess it will come back to me.
Well, Blizzard... thanks for making it easy to decide what to delete to free up some hard drive space... I guess. Ugh.
So far, I've rated 5 of the games out of the 120 submitted. Competition is fierce! There are a few which I played and thought "Well, at least my submission is better than this one." but there's at least one which is far better than mine (at least by my judgement.) Trying very hard to rate games fairly and only comment when I have something constructive to say. Good luck everyone!

Forum statistics

Threads
113,545
Messages
1,075,740
Members
147,543
Latest member
Dulldye
Top