Orange Overlay v1.1.4 + Animated Parallax Add-On (Updated 7Jul17)

AdamSakuru

[Null_Value]
Veteran
Joined
Mar 14, 2014
Messages
314
Reaction score
171
First Language
English
Primarily Uses
N/A
Hey, Tsukitsune. There's a bug with your animated parallax addon when it's used with Yanfly's Turn order Icon plugin in the same project. I'm not sure why it's even affecting the battle scene, but I figured out how to cause the error. I made a fresh demo and was wondering if you could fix it? I tried playing around with the placement/order of the plugins in relation to this one but the error kept happening.

https://www.mediafire.com/file/9kgxsahbdlzkmt3/AnimatedParallax_TurnOrderBug.zip
Here's the demo. To see the bug, open the Troop database and start the battle. Note that on turn 0, I use a plugin command which hides/shows the turn order icons for the actors. When you use this command, the error "cannot read property 'trim' of undefined" comes up.

Edit: also attached a log report.
 

Attachments

Last edited:

Krimer

Veteran
Veteran
Joined
May 10, 2013
Messages
147
Reaction score
108
First Language
Ukrainian
@AdamSakuru Open plugin in text editor and find string 288
Then replace 3 strings(288-290) with this:
Code:
    if (command === "animate_layer" || command === "overlay" || command === "stop_layer_animation"){
        layer = args[0].trim().toLowerCase();
        letter = layer.charAt( 0 ).toUpperCase();
        name = letter + layer.split( layer.charAt( 0 ) ).pop();
    }
Anyone who had problems with plugin commands can do the same thing and you will be fine.
 
Last edited:

AdamSakuru

[Null_Value]
Veteran
Joined
Mar 14, 2014
Messages
314
Reaction score
171
First Language
English
Primarily Uses
N/A
Thank you so much!
 

Pots Talos

Veteran
Veteran
Joined
Jun 28, 2012
Messages
119
Reaction score
102
First Language
English
Primarily Uses
RMMV
@AdamSakuru Open plugin in text editor and find string 288
Then replace 3 strings(288-290) with this:
Code:
    if (command === "animate_layer" || command === "overlay" || command === "stop_layer_animation"){
        layer = args[0].trim().toLowerCase();
        letter = layer.charAt( 0 ).toUpperCase();
        name = letter + layer.split( layer.charAt( 0 ) ).pop();
    }
Anyone who had problems with plugin commands do the same thing and you will be fine.
Thanks for this fix, much appreciated!
 

hiro24

Villager
Member
Joined
Jan 17, 2014
Messages
11
Reaction score
1
Primarily Uses
Hey guys. Wanted to see if anybody had a fix or suggestion for a problem I've been having w/ Orange Overlay 1.1.4. I'm using the fog overlay on my overworld to make clouds. It works great, except that since my map scroll loops, I get a lot of odd jumping at the edges of the map. Any ideas?
 

AestheticGamer

Veteran
Veteran
Joined
Dec 27, 2014
Messages
55
Reaction score
24
First Language
English
Primarily Uses
Hey guys. Wanted to see if anybody had a fix or suggestion for a problem I've been having w/ Orange Overlay 1.1.4. I'm using the fog overlay on my overworld to make clouds. It works great, except that since my map scroll loops, I get a lot of odd jumping at the edges of the map. Any ideas?
I don't have a solution but I can vouch in a project that uses RPG Maker Horizontal or Vertical map loops, the fog doesn't carry when looping the map and jumps the fog overlay to a position that looks messy as hell.
 

solaris81

Warper
Member
Joined
Mar 3, 2014
Messages
2
Reaction score
0
First Language
English
Primarily Uses
I have been having issues using the Plugin Commands and the Map Notes for a light layer. The plugin command outright doesn't work. The map note works, but it is not showing to the full resolution. Basically it covers about 1/4 of my town, almost as it's acting as a PAR layer or ground and not a light (light should cover the whole screen like fog right?) Any help would be great. This is the only overlay plugin I can sorta get working. Fog works amazingly!
 

George Halstead

Veteran
Veteran
Joined
Mar 24, 2017
Messages
66
Reaction score
12
First Language
English
Primarily Uses
RMMV
Does anyone have a set of graphics i could use for this plugin, my graphics are very limited. Thank you ahead of time friends.
 
Joined
Jul 16, 2017
Messages
49
Reaction score
9
First Language
English
Primarily Uses
RMMV
Having a weird issue. I have a map with the "animate ground" note tag. I've turned the animation off with a parallel event so that the map doesn't animate upon entering. Then I set an action button event to begin the animation. Strangely enough, when I trigger the animating event I get this error: Unable to load from img/parallaxes32x32//ground142_0.

Not sure why it's looking for this folder. So I created a folder named "parallaxes32x32" and put my images there and....it worked! I'm just wondering why it's looking for that strange folder...

Any thoughts?

Thanks!
 
Last edited:

George Halstead

Veteran
Veteran
Joined
Mar 24, 2017
Messages
66
Reaction score
12
First Language
English
Primarily Uses
RMMV
I have had that issue as well my friend and cannot see where the call is coming from. Cannot wait to see the answer..
 

George Halstead

Veteran
Veteran
Joined
Mar 24, 2017
Messages
66
Reaction score
12
First Language
English
Primarily Uses
RMMV
I guess this plugin is not supported anymore ?
 

4rc4n3

Veteran
Veteran
Joined
Mar 26, 2012
Messages
54
Reaction score
4
First Language
French
Primarily Uses
Hey there,

Quick question, it seems to be there but I haven't sleep and can't think properly.

I want an event that changes the ground parallax I have. I expected that all I had to do was:

1) Create an event
2) Have a single command: ''Plugin Command: Overlay ground ground27.png'' (I also tried ground27 without the .png)

And then it would work. It doesn't. Yes ground27.png is something that exists in the proper parallax folder.

Did I missread that it was possible or am I just not reading the instructions properly?
 
Last edited:

LackeDragon

Veteran
Veteran
Joined
Jun 2, 2012
Messages
30
Reaction score
2
First Language
French
Primarily Uses
RMMV
Unable to load from img/parallaxes32x32//ground142_0
There is a "//" in there. It should be only one "/" like these :
"img/parallaxes32x32/ground142_0

Edit : nevermind doesn't work without that still :p

Got the same problem.

Ok, found the problem.
"Organised folders" option doesn't work with the animated ones :p

Also note that the animated plugin create me a "trim" error for an unknown reason after a message in text box.
 
Last edited:

l8rose

Perpetually Exhausted
Veteran
Joined
Jun 1, 2014
Messages
447
Reaction score
1,445
First Language
English
Primarily Uses
RMMV
I've managed to get the layers to animate with organized folders.

If you have your organized folders from Orange's plugin with the pars, shadows, grounds, etc folder inside of an overall Overlay folder, it won't work. The script is calling to an img folder and then looking for a second folder inside the layer you're animating.

If you change that part of the script from:
img/grounds/
to
/grounds
It will then pull your images from the grounds folder as long as they're labeled right. You'll need to do that for every folder (img/shadows/ to /shadows, img/pars/ to /pars, etc).

I don't know if this breaks anything else in the plugin as it appears to work fine for me but I don't regularly code in anything other then HTML so use this work around at your own risk.
 

gutzs

Warper
Member
Joined
Apr 6, 2018
Messages
1
Reaction score
0
First Language
spanish
Primarily Uses
RMMV
Hi. The first thing to say is thanks for the plugin.
I have an issue, when i set (its the same with grounds or parallaxes)
<ground>
<animate_ground: 3, 40 >
it seems to load the 3 images from \overlays\img\grounds but only 2 from \overlays\grounds\
and this cause a black flickering in the animation
I have to say that if i animate the ground/parallax with only 2 images (<animate_ground: 2, 40 >) this issue don´t appears.
i let here a screenshot so you can understand me better:

can anybody help me? Thanks! (and sorry for my english)

---------------------
EDIT: solved editing the js file with notepad and letting only one folder. Thx anyway!
 
Last edited:

Tonny

Warper
Member
Joined
Mar 19, 2014
Messages
3
Reaction score
0
First Language
English
Primarily Uses
Hey can you give an example for what the stop plugin command is suppose to look like? It just doesn't seem to work for me.
 

Snarkyfork

Veteran
Veteran
Joined
Oct 29, 2015
Messages
308
Reaction score
30
First Language
English
Primarily Uses
I'm having an issue where closing the main menu causes the fog layer added by the plugin command "Overlay addfog fog9 1 180 0.4 0" to appear twice. This issue is happening with a new project and no other plugins but Orange Overlay v1.1.4 and it doesn't happen with v1.1.2 at all from what I see.
 

dgo1980

Villager
Member
Joined
Aug 18, 2016
Messages
15
Reaction score
2
First Language
spanish
Primarily Uses
I've managed to get the layers to animate with organized folders.

If you have your organized folders from Orange's plugin with the pars, shadows, grounds, etc folder inside of an overall Overlay folder, it won't work. The script is calling to an img folder and then looking for a second folder inside the layer you're animating.

If you change that part of the script from:
img/grounds/
to
/grounds
It will then pull your images from the grounds folder as long as they're labeled right. You'll need to do that for every folder (img/shadows/ to /shadows, img/pars/ to /pars, etc).

I don't know if this breaks anything else in the plugin as it appears to work fine for me but I don't regularly code in anything other then HTML so use this work around at your own risk.
can you show me the line to change?
 

dgo1980

Villager
Member
Joined
Aug 18, 2016
Messages
15
Reaction score
2
First Language
spanish
Primarily Uses
the organiced folder with plugyn animate fog not working,
ScreenShot_20181110212105.png
 

l8rose

Perpetually Exhausted
Veteran
Joined
Jun 1, 2014
Messages
447
Reaction score
1,445
First Language
English
Primarily Uses
RMMV
It's different for each piece that you want to change but you're going to look for something that says img/whateverlayer/
As it's been a while since I posted that fix (and I'm not actively using this plugin) I can't remember if you can get by with just removing the last / or the whole point of img/ and that last /.



You'll need to find the others like that if you're going to change those like I did.
They'll be img/pars/, img/shadows, etc.

And again, use this at your own risk.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

So I'm practicing ITC with a spirit box, and decide to try to contact my deceased soulmate. It actually gave me multiple identifiers. Me, still a bit skeptical, asked aloud "Fine but does he still love me?" and the box spoke and printed the word "Forever" at the same time. Been a mess of tears since. :kaocry:
Been scratching away at my game and making progress, but just had a revelation. I'm working in full screen and adjusting all my pictures accordingly, but will they resize if someone's screen is smaller?? I hope this doesn't turn out to be a problem later.
Why is there so much month left at the end of money? D=
Hello humans! How goes your day in this journey of living? I hope it is good, for I am human like you, and I am feeling great! Worship the altar.

Forum statistics

Threads
105,628
Messages
1,015,076
Members
137,288
Latest member
GmOcean
Top