Passive States with augments not working

Lucresia

Villager
Member
Joined
Jul 27, 2019
Messages
11
Reaction score
3
First Language
English
Primarily Uses
RMMV
I'm trying to make a passive state that works through an augment.

Basically, when the augment is equipped, the hero gains 10% of their Mana and 3+5% HP back, then the passive cools down via a common event. The thing is, no matter what I do, the passive will not activate at all. The only passive condition it has is mp must be below 1%. This is the only effect the augment has, and I plan on having many augments use passive states for effects, I need this to work but I'm lost
 

rainyday

Veteran
Veteran
Joined
Nov 5, 2019
Messages
37
Reaction score
19
First Language
English
Primarily Uses
RMMV
Could you clarify what plugins you're using?
 

Lucresia

Villager
Member
Joined
Jul 27, 2019
Messages
11
Reaction score
3
First Language
English
Primarily Uses
RMMV
Could you clarify what plugins you're using?
I'm using most of yanflys scripts, Hime's summon core and replace summons, and Hime's script for using events with states, the only plugins that should be affecting this particular case are

YEP Autopassive states
YEP BuffsStates Core
YEP Equip Core
YEP AttachAugments

And I have the Item and skill Cores if that affects any of this

EDIT

The passives are working on everything except augments, they just won't work with augments
 
Last edited:

rainyday

Veteran
Veteran
Joined
Nov 5, 2019
Messages
37
Reaction score
19
First Language
English
Primarily Uses
RMMV
Can you post screenshots of your passive state, the augment item, and their respective noteboxes?
 

Lucresia

Villager
Member
Joined
Jul 27, 2019
Messages
11
Reaction score
3
First Language
English
Primarily Uses
RMMV
I'm using most of yanflys scripts, Hime's summon core and replace summons, and Hime's script for using events with states, the only plugins that should be affecting this particular case are

YEP Autopassive states
YEP BuffsStates Core
YEP Equip Core
YEP AttachAugments

And I have the Item and skill Cores if that affects any of this
Can you post screenshots of your passive state, the augment item, and their respective noteboxes?
Okay, I guess the screenshots are too large for the server to process... Okayy, it's literally just a very simple state and augment.


The augment only has this in the notebox-

<Augment: Rune>
<Passive State: 25>

And the state has

<Regen Formula: 3>

(Note in notebox- it has 12% Mana Regen and 2% hp Regen) no auto removal, no restrictions, priority is 50



The augment is an armor however, would this matter?
 
Last edited:

rainyday

Veteran
Veteran
Joined
Nov 5, 2019
Messages
37
Reaction score
19
First Language
English
Primarily Uses
RMMV
<Augment Type: Rune>
Add Passive State: 25
</Augment Type: Rune>

Try that
 

MushroomCake28

KAMO Studio
Global Mod
Joined
Nov 18, 2015
Messages
2,624
Reaction score
3,793
First Language
English
Primarily Uses
RMMV

I've moved this thread to Javascript/Plugin Support. Please be sure to post your threads in the correct forum next time. Thank you.

 

rainyday

Veteran
Veteran
Joined
Nov 5, 2019
Messages
37
Reaction score
19
First Language
English
Primarily Uses
RMMV
Whoops, it should be
<Augment: Rune>
Add Passive State: 25
</Augment: Rune>
 

rainyday

Veteran
Veteran
Joined
Nov 5, 2019
Messages
37
Reaction score
19
First Language
English
Primarily Uses
RMMV
Are you putting this in the augment's notebox, or the armor you want to augment?
 

Lucresia

Villager
Member
Joined
Jul 27, 2019
Messages
11
Reaction score
3
First Language
English
Primarily Uses
RMMV
Are you putting this in the augment's notebox, or the armor you want to augment?
The actual augment. See I know how to do it, I have several augments that actually work, it's literally just the ones with passive State effects that don't work. They'll still add to stats, but the passive won't work at all. The exact same passive and augment will however work if I give the passive to a hero's notebox and equip the augment separately... But the augment with passive, the thing I need is the only thing not working
 

rainyday

Veteran
Veteran
Joined
Nov 5, 2019
Messages
37
Reaction score
19
First Language
English
Primarily Uses
RMMV
Hmm. Do you have Yanfly's passive states plugin below the augment plugin in the plugin manager? I'm not sure why it's not working for you, because on both my current project and a fresh project, the snippet I provided adds passive state 25.
 

Lucresia

Villager
Member
Joined
Jul 27, 2019
Messages
11
Reaction score
3
First Language
English
Primarily Uses
RMMV
I found out what was going on, I had a plug-in from a different developer for flat stat raises in with states/weapons/armor/actors/classes, when I got around to trying to use it, it just would not work at all... So I deleted it, and suddenly everything is working just fine, I'm kinda confused but maybe there was just conflicting code with the two plugins?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Had no time to work more on my Redwood tiles yesterday and no time yet still today--But! Somehow found time to make sit health potion props.
Today I learned that George Washington was not the first president of my country, and that there were technically over a dozen presidents before him. My own ignorance astounds me, I mean it always does but the sheer scope of this revelation astounds me. I guess George Santayana really was quite astute when he said:
Currently enjoying FF7 Remake :biggrin:
Day 753: I think im just about ready to finish the planning stage of my game creation and actually start to make it :0
I usually don't enjoy survival games, but I absolutely love Conan Exiles.

Forum statistics

Threads
95,775
Messages
931,817
Members
126,184
Latest member
Rumham
Top