HyperStream

Villager
Member
Joined
Sep 21, 2023
Messages
16
Reaction score
0
First Language
English
Primarily Uses
RMXP
This is my first post on this site so I apologise for anything I do wrong.

What I'm trying to do is:
Have an animation play centred on an event that isn't visible so I can make it become visible halfway through the event.

The animation is 12 frames long and I want the graphic of the event to appear 6 frames into the animation. I have tried multiple things that seem to either also hide the animation from appearing or delay the animation until the events graphic is visible.

If anyone knows how to do this please leave a comment, thanks

Update: Figured out how to make some gifs XD

this is what I want it to look like:
giphy.gif1695298842923.png

this is what happens when using opacity:
giphy (3).gif1695298789270.png

As you can see, the first animation has a small white ball before the Pokémon appears, which is not present with the second. The way I created the first animation is by setting the default graphic of the event to be identical to the tile set below it although I don't think I can use this method easily as I need these animations to be dynamic and not only able to play from one specific square.

Update 2:
Thanks to KK20 I know have a working method, however sadly I have come across a bug that I cannot understand why it is not functioning.

using KK20s method I have these commands on an onix appearing that works perfectly, no issues at all
1695373302479.png

however, when I use this method on the players starter with what seems like no changes that should effect it
1695373364408.png
the @transparent = false script doesn't seem to be functioning. The animation plays fully but the players starter graphic does not display at all, if I remove the first move route of @transparent = true, then the players starter is completely visible throughout the animation so it doesn't appear there is an extra command that is messing with the system. The only difference between the "grunts onix" and "players starter" is that the starter has 3 event pages, but the pages are not swapped through during this animations process so I don't see why that would make a difference.

thanks for any help guys, sorry I'm asking so many questions

1695373655995.png1695373670526.png1695373683366.png1695373699181.png

haven't included the event window for these guys as its completely empty

Update 3:
After messing around with my events for ages for some incredibly stupid and unexplainable reason (at least from my point of view XD) moving the "wait 5 frame(s)" outside of the move route somehow made the move route take effect again, This is not an issue in the example of my onix animation, as you can see the wait being inside the move route caused no issues.
index.php

but moving it outside the move route made my other example start working

Old:
index.php

new (working):
1695377066365.png

thanks everyone for your help, idk wtf was going on there, I'm sure I will come across more problems in my future of learning how to use RPGmakerXD so see you soon lol.
 
Last edited:

SGHarlekin

Orc Jester
Regular
Joined
Jun 29, 2020
Messages
1,597
Reaction score
2,528
First Language
German
Primarily Uses
RMMV
1695296948425.png
I don't know what makes your event invisible, but if you just have a separate page with no graphic that plays the animation and then turns on a switch for the page with the graphic, that's of course not going to work. Have your event be opacity 0 and then do it like the screenshot. This should give it a nice little fade in effect 6 frames into the animation.
 

HyperStream

Villager
Member
Joined
Sep 21, 2023
Messages
16
Reaction score
0
First Language
English
Primarily Uses
RMXP
I've tried messing with opacity and when the event's opacity is set to 0 the animation doesn't seem to be visible, I will try this exact setup with the graphic fading out.

I didn't specify how I was making the event invisible because I have tried multiple different methods from setting opacity to 0 to having no graphic, I didn't want to overload the post with information XD
 

SGHarlekin

Orc Jester
Regular
Joined
Jun 29, 2020
Messages
1,597
Reaction score
2,528
First Language
German
Primarily Uses
RMMV
Opacity.gif
Works without issue.
 

HyperStream

Villager
Member
Joined
Sep 21, 2023
Messages
16
Reaction score
0
First Language
English
Primarily Uses
RMXP
View attachment 277317
I don't know what makes your event invisible, but if you just have a separate page with no graphic that plays the animation and then turns on a switch for the page with the graphic, that's of course not going to work. Have your event be opacity 0 and then do it like the screenshot. This should give it a nice little fade in effect 6 frames into the animation.

Sadly as I expected doing it this way cuts off the first 6 frames of the animation as the opacity of the animation seems to also be effected by this so only the last 6 frames are played when the graphic is at 50 opacity
 

SGHarlekin

Orc Jester
Regular
Joined
Jun 29, 2020
Messages
1,597
Reaction score
2,528
First Language
German
Primarily Uses
RMMV
Well, as you can see in the gif, the animation plays fine long before the sprite is visible, so I would assume you're doing it wrong. Try sending screenshots of the entire event set up so people can actually give you advice and not just guess.

also double posting is prohibited, if you need to add additional text, you can edit your previous post.
:p
 

HyperStream

Villager
Member
Joined
Sep 21, 2023
Messages
16
Reaction score
0
First Language
English
Primarily Uses
RMXP
Well, as you can see in the gif, the animation plays fine long before the sprite is visible, so I would assume you're doing it wrong. Try sending screenshots of the entire event set up so people can actually give you advice and not just guess.

also double posting is prohibited, if oyu need to add additional text, you can edit your previous post.
:p

double posting? sorry should I be editing the original post instead of sending replies? Like I have made a post on this site before, sorry for making any mistakes
 

SGHarlekin

Orc Jester
Regular
Joined
Jun 29, 2020
Messages
1,597
Reaction score
2,528
First Language
German
Primarily Uses
RMMV
No worries, just don't make a new post after your own post, edit the old post. Anyway, we need screenshots of your eventing to see what you did wrong to help ya.
 

HyperStream

Villager
Member
Joined
Sep 21, 2023
Messages
16
Reaction score
0
First Language
English
Primarily Uses
RMXP
No worries, just don't make a new post after your own post, edit the old post. Anyway, we need screenshots of your eventing to see what you did wrong to help ya.
everything you need should now hopefully be in the original post
 

SGHarlekin

Orc Jester
Regular
Joined
Jun 29, 2020
Messages
1,597
Reaction score
2,528
First Language
German
Primarily Uses
RMMV
So is your first example not your game? Since it does what you want, why not use that? Otherwise I have no idea why it wouldn't work aside from the animation just not having the 6 "ball frames" perhaps. But I'm also no expert on XP since... It's been like what? 20 years +? haha.
 

HyperStream

Villager
Member
Joined
Sep 21, 2023
Messages
16
Reaction score
0
First Language
English
Primarily Uses
RMXP
So is your first example not your game? Since it does what you want, why not use that? Otherwise I have no idea why it wouldn't work aside from the animation just not having the 6 "ball frames" perhaps. But I'm also no expert on XP since... It's been like what? 20 years +? haha.
the first example is making the graphic of the event into the same graphic as the tileset tile below it and then changing the graphic to the onix. this appears to work because there is always a graphic for the animation to go off of, however i wanted to find a better method for doing this as you cannot use the "set move route" to assign a graphic to an event that is from the tileset meaning I wouldnt be able to dynamically change the location of the event before playing the animation as the graphic wouldnt match the tile below it anymore would look out of place

hopefully that makes sense
 

SGHarlekin

Orc Jester
Regular
Joined
Jun 29, 2020
Messages
1,597
Reaction score
2,528
First Language
German
Primarily Uses
RMMV
Yeah it makes sense. I just don't know why this wouldn't work for you since it clearly does for me. It's been too long for me to remember the ins and outs of XP tho so maybe someone else can jump in and help out further.
 

KK20

Just some XP Scripter
Regular
Joined
Oct 11, 2018
Messages
495
Reaction score
204
First Language
English
Primarily Uses
RMXP
Not sure what's going on with SGHarlekin's GIF as I tried the same event commands on vanilla XP and got the same results as HyperStream.

To explain why you can't use opacity, the animation sprites' opacities are averaged against the character's own opacity. This is shown in the Help File for RPG::Sprite under the method animation_set_sprites:
Code:
# def animation_set_sprites(sprites, cell_data, position)
sprite.opacity = cell_data[i, 6] * self.opacity / 255.0

If you don't need to do a gradual shift in opacity like SGHarlekin's example does, then what you want is to set the event's "transparent" flag to true. Unfortunately the event command "Change Transparent Flag" only applies to the player, so you'll need to use a script call to access the event's.

Your event page should play the animation first, followed by a Move Route command with the following:
Code:
>Script: @transparent = true
>Wait: 5 frame(s)
>Script: @transparent = false
 

HyperStream

Villager
Member
Joined
Sep 21, 2023
Messages
16
Reaction score
0
First Language
English
Primarily Uses
RMXP
Yeah it makes sense. I just don't know why this wouldn't work for you since it clearly does for me. It's been too long for me to remember the ins and outs of XP tho so maybe someone else can jump in and help out furt

Not sure what's going on with SGHarlekin's GIF as I tried the same event commands on vanilla XP and got the same results as HyperStream.

To explain why you can't use opacity, the animation sprites' opacities are averaged against the character's own opacity. This is shown in the Help File for RPG::Sprite under the method animation_set_sprites:
Code:
# def animation_set_sprites(sprites, cell_data, position)
sprite.opacity = cell_data[i, 6] * self.opacity / 255.0

If you don't need to do a gradual shift in opacity like SGHarlekin's example does, then what you want is to set the event's "transparent" flag to true. Unfortunately the event command "Change Transparent Flag" only applies to the player, so you'll need to use a script call to access the event's.

Your event page should play the animation first, followed by a Move Route command with the following:
Code:
>Script: @transparent = true
>Wait: 5 frame(s)
>Script: @transparent = false
Hey, thanks for the comment, I am calling the animation and the transparently effect from a 2nd event that is handling my cutscene, how do I change the transparent script to make it effect a specific event?

Update:
I've just figured out that's why you told me to place it in a move route, thankyou, this works perfectly. Just so I have options could you possibly add a further comment showing how you would use this script outside of a move route to effect a separate event?
thanks again :)
 

SGHarlekin

Orc Jester
Regular
Joined
Jun 29, 2020
Messages
1,597
Reaction score
2,528
First Language
German
Primarily Uses
RMMV
Not sure what's going on with SGHarlekin's GIF as I tried the same event commands on vanilla XP and got the same results as HyperStream.

To explain why you can't use opacity, the animation sprites' opacities are averaged against the character's own opacity. This is shown in the Help File for RPG::Sprite under the method animation_set_sprites:
Code:
# def animation_set_sprites(sprites, cell_data, position)
sprite.opacity = cell_data[i, 6] * self.opacity / 255.0

If you don't need to do a gradual shift in opacity like SGHarlekin's example does, then what you want is to set the event's "transparent" flag to true. Unfortunately the event command "Change Transparent Flag" only applies to the player, so you'll need to use a script call to access the event's.

Your event page should play the animation first, followed by a Move Route command with the following:
Code:
>Script: @transparent = true
>Wait: 5 frame(s)
>Script: @transparent = false
What's going on in my gif is what I posted in the post before. It's a fresh project and I've never openen XP before on this machine. No idea what you guy's trouble is. Maybe the issue is that it's called from a separate event or an autorun.
 

HyperStream

Villager
Member
Joined
Sep 21, 2023
Messages
16
Reaction score
0
First Language
English
Primarily Uses
RMXP
What's going on in my gif is what I posted in the post before. It's a fresh project and I've never openen XP before on this machine. No idea what you guy's trouble is. Maybe the issue is that it's called from a separate event or an autorun.
It may be possible calling it from a seperate event changes things but the example i set up with the bulbasaur was editing itself and the problem was still persisting sadly
 

KK20

Just some XP Scripter
Regular
Joined
Oct 11, 2018
Messages
495
Reaction score
204
First Language
English
Primarily Uses
RMXP
What's going on in my gif is what I posted in the post before. It's a fresh project and I've never openen XP before on this machine. No idea what you guy's trouble is. Maybe the issue is that it's called from a separate event or an autorun.
Can you upload the map rxdata file here?

Also, we're not the ones having trouble, your's is the outlier as I explained in my post. The fact that your battle animation is unaffected by the event's opacity implies an edit to the default scripts.

Here's your event on XP v1.04 on a completely new project
  • First few frames of animation are missing
  • The opacity change is significantly slower
CXZERGV.gif


Just so I have options could you possibly add a further comment showing how you would use this script outside of a move route to effect a separate event?
Show Animation at the top as usual. Follow it up with the following event commands:
Code:
@>Script: $game_map.events[ID].transparent =
 :      : true
@>Wait: 5 frame(s)
@>Script: $game_map.events[ID].transparent =
 :      : false
replacing ID with the event's ID (e.g. if ID:015, then put 15)
 
Last edited:

Latest Posts

Latest Profile Posts

Help, I can't stop! :kaohi:

alice_ornament.png
I'm happy to join this community.
about this argument. I expressed myself badly, I did it on my own, my English was mixed with Google Translate. And I believe chatGPT didn't even exist in 2016
I have to take sleeping pills :rtear:
Now that the forum is running smoothly, I can run around and react to posts the millisecond they're posted.
patrick-star-spongebob.gif

Forum statistics

Threads
136,812
Messages
1,270,316
Members
180,574
Latest member
PastorGary
Top