Playtest stopped working on RPGMV

Abashi76

Veteran
Veteran
Joined
Aug 6, 2018
Messages
32
Reaction score
0
First Language
English
Primarily Uses
RMXP
I have Windows 7 32-bit, which is according to this site to be able to use the RPG Maker MV program.

At first everything worked alright and I was able to do everything. But recently the program stopped play-testing the game and testing the battle formations. Every time I click the green triangle and/or hit the test battle tab, nothing happens. I did not do anything to mod the program. I even tried testing the game on a new project, but still nothing happened. I tested compatibility options as well, and that only makes it worse. I think I have Direct X 9 as well since all my computers always have it.
 

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
4,501
Reaction score
1,728
First Language
Dutch
Primarily Uses
RMMV
did you update the software from 1.5.x to 1.6.x?
if so, did you also update your project to the latest version?

playtest mostly stops working if you update the software but not the project.
so you need to update the project as well.

another issue that is possible is outdated drivers, so update those.
driverboost 6 can help you with that easy and fast. (free)

else we need more information if those are corrected.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,903
Reaction score
8,597
First Language
German
Primarily Uses
RMMV
@ShadowDragon the update to 1.6.x is the only one which did that, you previously you could playtest a 1.0 project on a 1.5 editor.

However that still means that this is the most likely cause.
@Abashi76 you can check the editor version in the menu under help-about.
to check the project version you need to go into the project folder and open the rpg_core.js file with a text editor (do not doubleclick it), the version is in the title line (no number means 1.0)
 

Abashi76

Veteran
Veteran
Joined
Aug 6, 2018
Messages
32
Reaction score
0
First Language
English
Primarily Uses
RMXP
did you update the software from 1.5.x to 1.6.x?
if so, did you also update your project to the latest version?

playtest mostly stops working if you update the software but not the project.
so you need to update the project as well.

another issue that is possible is outdated drivers, so update those.
driverboost 6 can help you with that easy and fast. (free)

else we need more information if those are corrected.

I don't remember ever updating the program. That couldn't be it. As I said, I tried making a new project already.

I have version 1.6.2! The .js file says my project is exactly the same version.
 
Last edited:

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
4,501
Reaction score
1,728
First Language
Dutch
Primarily Uses
RMMV
if you use steam, it mostly auto update to the latest version.
but what version does your project core says (rpg_core) on the top line?
and what version does the RPG version say of the editor (help -> about)?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,903
Reaction score
8,597
First Language
German
Primarily Uses
RMMV
I have version 1.6.2!
that is not enough information, please read my post above.
we need two numbers from you, not one - you need to specify both editor version and project version, and those numbers might not be the same (which is why we need both stated).

And if there is no critical version problem, then that points out to either a damaged editor (and before you reinstall, we would have to know exactly which version you have) or that your computer hase blocked all chromium-based browsers.
 

Abashi76

Veteran
Veteran
Joined
Aug 6, 2018
Messages
32
Reaction score
0
First Language
English
Primarily Uses
RMXP
if you use steam, it mostly auto update to the latest version.
but what version does your project core says (rpg_core) on the top line?
and what version does the RPG version say of the editor (help -> about)?

They're both the same version. Both are 1.6.2
Everything is the same version. I never even needed an updated. This is the second time I posted this information.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,903
Reaction score
8,597
First Language
German
Primarily Uses
RMMV
then - as I wrote above - the problem has nothing to do with the project itself, it is either a damaged editor or another program or setting blocking the playtest.

have you tried reinstalling? do you have the standalone or the steam version of 1.6.2 - they are identical, but in case of steam the steam download cache can be damaged and prevent a reinstall.

and what browser is your default browser? have you disabled chrome or chromium anywhere on your computer? please check the logs of any antivirus if it has disabled the playtest due to falsely believing it to be an infected website.
 

Abashi76

Veteran
Veteran
Joined
Aug 6, 2018
Messages
32
Reaction score
0
First Language
English
Primarily Uses
RMXP
I use Chrome. I don't understand why the program would become corrupt all of the sudden. It's possible that something on my computer is blocking the program from play testing anything. I am able to play RMMV games just fine.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,903
Reaction score
8,597
First Language
German
Primarily Uses
RMMV
If you can play the games without problem, then it is most likely that the program itself has been damaged. There are a lot of ways how that could have happened.

but you didn't answer all the questions
Do you have the standalone or the steam version of RMMV, and have you tried reinstalling it?
 

Abashi76

Veteran
Veteran
Joined
Aug 6, 2018
Messages
32
Reaction score
0
First Language
English
Primarily Uses
RMXP
I have the standalone version. How could the program be corrupted? It worked at first, but also had a delay in loading playtests.

I'll try to re-install. Could it be a RAM problem? My RAM is only 4GB but i'm supposed to get more soon.
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,903
Reaction score
8,597
First Language
German
Primarily Uses
RMMV
How could the program be corrupted?
lot's of reasons - from virus infections (no antivirus is perfect) to interrupted shutdowns destroying files (there is a reason why shutdown is neccessary before power off) to installing incompatible other programs (yes, programs can destroy other programs especially if the programmer isn't very experienced) to data failures on download at your internet provider to...
There are so many ways programs can be corrupted that a decade ago (before protection programs were as advanced as they are now) it was considered normal to delete and reinstall the entire Windows because that 3-hour-workload was considered easier then solving the program problems.

It is very unlikely to be a RAM problem, because Windows can create virtual RAM from the HDD. And when even that is blocked, you get a message from Windows telling you about that. The delay could have been caused by not enough RAM (virtual RAM is much slower), but not the complete block you have now.

Please re-download the newest installer from this site, then use windows system properties to deinstall RMMV (never just delete program files, that is another way to destroy other programs than the one intended for deletion). After that, shutdown the computer, wait twenty seconds, restart and reinstall with the new installer.
 

Latest Threads

Latest Posts

Latest Profile Posts

finally drew 3 of the enemies that appear as students from the high school that's in my game.
Finnuval wrote on ShuBun-Kin's profile.
Loving the avatar :D
Introducing the premium bagel
I have a micro economics midterm tomorrow. I'm not worried.
Should be a...small exam :kaojoy:
While was working on one of the monsters that will appear in my horor game I may have made harold a Lovecraftian monster. (I used his head to keep things aligned.)

Forum statistics

Threads
115,927
Messages
1,094,098
Members
151,183
Latest member
Yoshua2050
Top