Plugins don't work

Discussion in 'Javascript/Plugin Support' started by GlavHunter, Jul 9, 2019.

  1. GlavHunter

    GlavHunter Warper Member

    Messages:
    1
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    So I've been working on a game in MV for a few days now, and I've been messing around with a few plugins, most of them being by Sumrnde. My problem is that for seemingly no reason, the plugins stopped working.

    The plugins appear in the plugin manager, but even when they're on, they don't work at all, as if they weren't there. For example, for Sumrnde's Summon Core plugin, which allows you to make skills that summon actors, when using skills with the summon notetags, the actor uses the skill and nothing happens. No animations, no summoned actor, but it still says "actor casts summon" and drains mp.

    Now I'd probably think this was a problem with the specific plugin if it weren't for the fact that this isn't the only plugin that does this. Another example is Sumrnde's PKM Type System, which allows you to implement the Pokemon type system into your games. Nothing. His eqquiped comparison upgrade. Nothing. And even when I switched over to the Victor Engine by Victor Want, none of those plugins would work, too.

    Knowing me and my lack of experience with specifically MV, I probably made a really stupid mistake somewhere, but I followed the procedures for both downloading and using these plugins.

    What gives?
     
    #1
  2. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,393
    Likes Received:
    10,410
    First Language:
    English
    Primarily Uses:
    RMVXA
    Tech Support is for when you can't get the engine to run.

    I've moved this thread to JavaScript/Plugin Support. Please be sure to post your threads in the correct forum next time. Thank you.


    In addition please edit your post to include a link to the web pages where you got the plugins you mention so that people don't have to hunt for them if they need to check something before making a suggestion.
     
    #2
  3. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,776
    Likes Received:
    11,804
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    Sumrmde stopped updating their plug-ins a long time ago, and they will usually not work with the newer versions of MV as a result. You will either need to get them to update their plug-ins, or use someone else's.
     
    #3
  4. Andar

    Andar Veteran Veteran

    Messages:
    28,141
    Likes Received:
    6,372
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    additionally, several of those plugins are windows-only and will not work after deployment to non-windows.

    but if you don't want to replace them with more modern plugins, you should be able get them to run again by going back to 1.5.1 for both editor and project core versions. That is the main reason why the project updates are never automatic: so that people can keep compatibility of older versions to finish their projects.
     
    #4

Share This Page