Status
Not open for further replies.

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,699
Reaction score
12,249
First Language
English
Primarily Uses
RMMZ
I have removed all the graphics I don't want to use, but when I try to load the game I get the error message:
1653128317045.png
Where do I get rid of the command which leads to this? As far as I can see the VisuStella Core Engine only gives the option to add additional images, not to preload anything.

Sorry if this is such a basic question, but I'm only now switching from Ace to MZ, and am finding a lot of things baffling.

Thanks.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
36,278
Reaction score
9,702
First Language
German
Primarily Uses
RMMV
You might not want to use it, but the message itself is proof that you are still using it somewhere.
because that message can only happen if that picture is used, and if you don't want it you have to find the place where it is used in your game and change it to another picture.

the best way to do that is to use a multifile text editor. I use textpad, but there are others.
within that text editor, you load all json files from the data directory.

and then you search for Actor1 over all files.

you'll get a list of lines where it is used, and that list should be enough to point out to you where the picture is used - if it is in a mapfile for example you'll know that one of the events on that map uses that sprite.

then change all references and the error message will be gone. You might get another one after that however if there are other deleted pictures that are still referenced somewhere, then simply repeat with the other filename
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,699
Reaction score
12,249
First Language
English
Primarily Uses
RMMZ
@Andar At the moment the game consists of one map and two events - one the player, the other an NPC with a couple of lines of dialogue so that I can check if my custom window looks good. I have put no commands in anywhere for anything else, so it's not calling up this image from within the game itself. It must be in the default settings somewhere, presumably in whatever it uses to load a game.
 

caethyril

^_^
Global Mod
Joined
Feb 21, 2018
Messages
3,673
Reaction score
2,760
First Language
EN
Primarily Uses
RMMZ
@Kes - might seem like a silly question, but did you check the Actors tab of the database?

Edit: otherwise it may be a good idea to specify more exactly when "load the game" happens, e.g. on game boot (likely plugins/database) or on trying to load an old save?
 
  • Like
Reactions: Kes

Lady_JJ

Veteran
Veteran
Joined
May 6, 2019
Messages
413
Reaction score
303
First Language
English
Primarily Uses
RMMZ
Do you have any saves that may have used that image? It's happened to me because of old saves. Remove your saves and see what happens.
 
  • Like
Reactions: Kes

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
36,278
Reaction score
9,702
First Language
German
Primarily Uses
RMMV
even those default settings are stored in the json files.
most likely you'll find the database tab where it is still used
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,699
Reaction score
12,249
First Language
English
Primarily Uses
RMMZ
@Lady_JJ and @caethyril There are no old saves - partly because I can't get past the initial loading to arrive at the stage where I could make a save. Brand new game, consisting, as I said to Andar, of one map and 2 events.

For the Actors tab in the database, I started off just with the character sprite from a sheet called Actors 1-8. Got the problem.
Reimported the Actor 1 face set so that I could put something there, and used a default SV battler image, so all 3 of those image requests are now filled. Still got the problem. I don't see whereabouts on the actor's tab it asks for anything else.
 

caethyril

^_^
Global Mod
Joined
Feb 21, 2018
Messages
3,673
Reaction score
2,760
First Language
EN
Primarily Uses
RMMZ
Ideas:
  1. So you see the New Game, Continue, Options title screen, right? I wonder what happens if you change the title image? If that doesn't change anything in-game, that suggests the game is reading the wrong files. In that case, check step 5 at the bottom of this post.

  2. Actor1-8.png is a custom spritesheet, right? The default asset Actor1_8.png (closest name) is a sideview battler sheet (img/sv_actors), not a map character sheet (img/characters). Have you tried setting all actor images to "(None)" to see if that works?

  3. You can press the F8 key during playtest (or F12 if F8 fails) to show the dev tools window. The Console tab there should display any errors in red text. Some errors can be expanded to a full trace by clicking them. A screenshot of any error message/trace may be helpful to narrow down exactly what is asking for that image.

  4. You could also try turning off (uncheck) all plugins in the Plugin Manager, then save your project to apply changes. If that fixes the problem, it may help to share screenshot(s) of your Plugin Manager showing all plugins you're using.

  5. Do you see a www subfolder in your project folder? If not, that's good! Otherwise you have probably deployed into your project folder (not recommended!). A quick remedy for that is to delete your project's package.json file (it should automatically "respawn" a default on playtest). A more complete solution involves copying only your project data (data, img, audio, movies, and js/plugins folders, and plugins.js file) over into a new project.
 
  • Like
Reactions: Kes

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,699
Reaction score
12,249
First Language
English
Primarily Uses
RMMZ
@caethyril In the end, I changed the name of the sprite sheet to Actor1 as per the default, and it worked fine. I feel a bit miffed that I have to use default naming, as that may cause problems further down the line, but at least - for the very first time - I have opened a game in MZ started by me. I suppose I must consider that a step forward. I think this engine transition is going to be torture.

Thank you very much for your time and help. It is much appreciated.
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
9,715
Reaction score
6,169
First Language
Dutch
Primarily Uses
RMXP

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Latest Threads

Latest Profile Posts

Messing around with fragment shaders (filters). This thing is HUGE and I'm surprised almost no one makes good use of. Even the number of plugins that do this stuff are limited.
ScreenShot_6_28_2022_3_2_40.png

There's 7 main areas in the game that are all connected. This train get's you from an underground lab to the center of someone's subconscious. inside the train you can talk to some of the passengers. but going to the top of it, there's battles.
Speedrunning all character portraits just so they all have the same quality. Not sure if this was a good idea, but now I'm almost done.
We now have a gameplay video!
DrBuni wrote on Akiritas's profile.
That is a cute Link picture, reminds me of the Samurai Jack artstyle.

Forum statistics

Threads
123,151
Messages
1,154,416
Members
161,498
Latest member
lennonmchugh01
Top