Hamau11

Warper
Member
Joined
Jun 30, 2017
Messages
2
Reaction score
0
First Language
English
Primarily Uses
RMMV
Okay, so, I have an event which starts "Battle Processing..." and begins a certain encounter when the character steps on it. The problem is that, after deployment, the three enemies in the encounter keep reviving on their own at the end of every turn! I have nowhere set anything like this to happen and the enemies have no skill that would allow them to revive but the game just says "Foot Soldier has revived." and brings the enemy back. I did not have this problem when I was playtesting the game earlier but the deployed version does it.

Edit: Just playtested it again in RPG Maker. It does it as well. Sorry for the mixup, but it did not do it before! I wonder what changed since I haven't edited that event since.

Edit #2: Battle testing the Troop itself does this as well. What am I doing wrong? I'm almost sure this is something really stupid and I'm just blind but I really need help!
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,763
Reaction score
8,975
First Language
German
Primarily Uses
RMMV
Most likely you messed up with the states.
State #1 has to be the death state, and removing that will revive anyone.

There are a few other possibilities, but we need to see what you've done (screenshots of the map event and possible troop events) before we can give more detailed help.
 

Hamau11

Warper
Member
Joined
Jun 30, 2017
Messages
2
Reaction score
0
First Language
English
Primarily Uses
RMMV
Oh, yes! That did it! Thank you for the help. I am new to this and it appears I misunderstood the meaning of "Knockout". :D
 

Latest Threads

Latest Profile Posts

Feels like I've been butting heads with people more often, especially on here. Hoping I'm not being unreasonable, I've been trying to be more honest about how I'm feeling.
SF_People2.png added!
index.php

I wrote a script everything worked fine until IDs and Names weren't being stored/called proper.. Turns out I used ' j ' instead of ' i ' for grabbing array element. 2 days of bug testing and rewriting to overlook a single little letter. I'm changing my default loop variables. Any recommendations? Maybe n & m? Kidding lol.
5 months and no progression at all, i love me.

Forum statistics

Threads
118,747
Messages
1,118,414
Members
155,901
Latest member
ilskur
Top