Problem with adding new character in game

Parlu10

Veteran
Veteran
Joined
Jul 30, 2018
Messages
35
Reaction score
7
First Language
Italian
Primarily Uses
RMMV
Hi everyone,
I've had a problem with adding new characters in my game. After a timeskip, my game introduces a new character; however, this new character is invisibile, it doesn't have any sprite and it's like adding an empty slot, even if the character has all the sprites, his own class and equipment.
Someone knows why this error occurs?

After some testing, I noticed that if i start a new game after the timeskip, the character acts like normal.
 
Last edited:

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,579
Reaction score
877
First Language
Dutch
Primarily Uses
RMMV
depends how file is.
if the actor is a single while, does it have $! in front, if it's on an actor sheet
4x2 actors, than it should show, else we need some more details and screenshot
where possible, to see where the issue lies.

normally, when you add a party member, it is visible.
 

Parlu10

Veteran
Veteran
Joined
Jul 30, 2018
Messages
35
Reaction score
7
First Language
Italian
Primarily Uses
RMMV
depends how file is.
if the actor is a single while, does it have $! in front, if it's on an actor sheet
4x2 actors, than it should show, else we need some more details and screenshot
where possible, to see where the issue lies.

normally, when you add a party member, it is visible.
The problem is not the file, since it's a default Rpg Maker Mv file.
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,579
Reaction score
877
First Language
Dutch
Primarily Uses
RMMV
you can have $!actor1.png and actorsheet.png, if actor.png has no $! it will read
the 8 indexes, meaning, it might be somewhere in the middle. so the actor will
be invisible.

another way is, if you can have max 4 party members, add those at start, and
remove them at start up, this way, it will be visible at all times :)
 

Parlu10

Veteran
Veteran
Joined
Jul 30, 2018
Messages
35
Reaction score
7
First Language
Italian
Primarily Uses
RMMV
you can have $!actor1.png and actorsheet.png, if actor.png has no $! it will read
the 8 indexes, meaning, it might be somewhere in the middle. so the actor will
be invisible.
It's not that because not only the sprite is invisible, but also the character's class changed to the default one. Even the faceset is invisible in the menu.

another way is, if you can have max 4 party members, add those at start, and
remove them at start up, this way, it will be visible at all times
This might work, but I have more than 4 playable characters in my game. Are you sure that if I do that, another character won't have the same bug?
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,579
Reaction score
877
First Language
Dutch
Primarily Uses
RMMV
so far I know, it doesn't, somehad had similair issue with this, adding before hand
should work when removing the party members on start up and no issue.

in case your party is working, but the image is not loading, it's a loading issue.
you can use a preload images plugin in order to fix those. (if this may be teh cause.
 

Parlu10

Veteran
Veteran
Joined
Jul 30, 2018
Messages
35
Reaction score
7
First Language
Italian
Primarily Uses
RMMV
so far I know, it doesn't, somehad had similair issue with this, adding before hand
should work when removing the party members on start up and no issue.
I'll try this. But I'll add some screenshot to see if there are other explanations or solutions.
This is how the character should look like.

Scarlet Shadow v 0.5.6 - RPG Maker MV 21_09_2020 11_57_11.png

This is how the character looks in menu

Scarlet Shadow v 0.5.6 21_09_2020 11_56_37.png
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,579
Reaction score
877
First Language
Dutch
Primarily Uses
RMMV
the 2nd screenshot target a swordsman instead of gunner (the one above), does it show
up when clicking on it and re-open for the 2nd time?

I also mean the party setup in "system" tab.

while I build my game with 1 actor, I dont have this problem.
can also be a plugin issue or compability, cant tell though, but normally, it should work.
 

Parlu10

Veteran
Veteran
Joined
Jul 30, 2018
Messages
35
Reaction score
7
First Language
Italian
Primarily Uses
RMMV
the 2nd screenshot target a swordsman instead of gunner (the one above), does it show
up when clicking on it and re-open for the 2nd time?
No, it remains a swordsman.
Also, I noticed that if I start a new game after the timeskip, the character acts like normal.
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,579
Reaction score
877
First Language
Dutch
Primarily Uses
RMMV
I dont know what timeskip does, but adding new things (actors, plugins, maps, etc
always require a new start, continue the game on a save file and than interact can
cause errors or not displaying when not existed on the savefile before.
 

Parlu10

Veteran
Veteran
Joined
Jul 30, 2018
Messages
35
Reaction score
7
First Language
Italian
Primarily Uses
RMMV
I dont know what timeskip does, but adding new things (actors, plugins, maps, etc
always require a new start, continue the game on a save file and than interact can
cause errors or not displaying when not existed on the savefile before.
But I'm not adding any new plugin, and the actor that I added was already in the database.
 

ShadowDragon

Veteran
Veteran
Joined
Oct 8, 2018
Messages
2,579
Reaction score
877
First Language
Dutch
Primarily Uses
RMMV
strange, I cant help you much further on the road, you can try preload plugin like
Galv_ImageCache and load them upfront, so they can be used.

other images can you preload upon map transfer or autorun event when you need
them. otherwise, someone else might know a soluton.

Good luck on your project further :)
 

AfroKat

Veteran
Veteran
Joined
Feb 4, 2017
Messages
74
Reaction score
43
First Language
English
Primarily Uses
RMMV
But I'm not adding any new plugin, and the actor that I added was already in the database.
Depending on how old you save it it's still an issue when updating. If that empty character in your menu is the same as character slot #10,11,12 etc etc then you probably have to restart your entire save file for them to show up. I had something like that happen to me before.
 

Parlu10

Veteran
Veteran
Joined
Jul 30, 2018
Messages
35
Reaction score
7
First Language
Italian
Primarily Uses
RMMV
strange, I cant help you much further on the road, you can try preload plugin like
Galv_ImageCache and load them upfront, so they can be used.

other images can you preload upon map transfer or autorun event when you need
them. otherwise, someone else might know a soluton.

Good luck on your project further :)
Thank you very much for your help!

Depending on how old you save it it's still an issue when updating. If that empty character in your menu is the same as character slot #10,11,12 etc etc then you probably have to restart your entire save file for them to show up. I had something like that happen to me before.
I guess the save file I was using was older than I thought, however, at least I've understood why it wasn't working.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Its been almost 6 months since i've been here last and 5 years before that. the worst part is losing the game you were working on in a cpu fire.

Well time to go at it again.
my game is coming together im so happy
In this day and age, i might switch back to RMXP. I’ve lost faith in all the new plugins.
Wow it's been forever since I last logged in! I STILL want to make a game... I'll start it one day for sure!! It's a dream of mine.
This days I couldn't do anything... My mind is so confused and I couldn't work at all, I only wanted to play video games with my friends and that made all my projects delay a lot. Someone else feels this kind of thing sometimes? :/

Forum statistics

Threads
104,286
Messages
1,005,262
Members
135,797
Latest member
Famas
Top