Problem with custom tileset

Discussion in 'Resource Support' started by KST_, Apr 12, 2019.

  1. KST_

    KST_ Villager Member

    Messages:
    11
    Likes Received:
    6
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    Um... sorry if I'm posting on the wrong place, however, I tried making my own test tileset, and my "roofs" straight up 101% bugged
    [​IMG] for some reason my "roof" stay like this even if it's only one tile
    [​IMG] when it's multiple tiles, some random things may happen such as these lol

    Could someone please help me with this?
     
    #1
  2. MushroomCake28

    MushroomCake28 KAMO Studio Veteran

    Messages:
    1,714
    Likes Received:
    3,065
    Location:
    Montreal, Canada
    First Language:
    English
    Primarily Uses:
    RMMV
    Well we need more info:
    1) First of all, can you link us the image of your tileset containing the roof?
    2) Which RPG Maker are you using? (although I'd guess MV based on those screenshots)
    3) Did you use that tileset as a A tileset (they behave differently) or other?
     
    #2
  3. KST_

    KST_ Villager Member

    Messages:
    11
    Likes Received:
    6
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    Welp here it goes:
    1) I only made this of the tileset lol
    [​IMG]
    2) Yup, I'm using RPG Maker MV
    3) I'm using this "tileset" as an A4 (I think it's right but it may be wrong lol)
     
    #3
  4. MushroomCake28

    MushroomCake28 KAMO Studio Veteran

    Messages:
    1,714
    Likes Received:
    3,065
    Location:
    Montreal, Canada
    First Language:
    English
    Primarily Uses:
    RMMV
    Hmm, assuming you really did use it as an A4 tileset, that your tiles are 48x48 and that your image is 768x720, I have no idea why it would behave like that.
     
    #4
  5. hiddenone

    hiddenone Lurker Extraordinaire Moderator

    Messages:
    1,943
    Likes Received:
    4,593
    First Language:
    english
    Primarily Uses:
    RMMV

    I've moved this thread to Resource Support. Please be sure to post your threads in the correct forum next time. Thank you.

     
    #5
  6. Andar

    Andar Veteran Veteran

    Messages:
    28,447
    Likes Received:
    6,492
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    you have several problems here.

    There are six different formats for tilesheets, containing four different types of tiles, and the RM-Engines require the exact positioning of a tile based on its type - you simply can't position any tile anywhere.
    your example sheet contains three tiles - one ceiling type autotile and two wall type autotiles. And from the look of those tiles you made them without knowing what autotiles are. And that is why they mess up when used.

    I suggest you go to the official blog and search for a tutorial "anatomy of an autotile", and then place your resulting tiles into an existing sheet (replacing only tiles of the same type), because you also cannot use an incomplete tilesheet, all tilesheets need to have the correct dimensions.
    Theoretically you could fill a tilesheet with transparent tiles if you don't want the other tiles, but that you should only do when you know the exact placement of the tiles you do use.
     
    #6
  7. KST_

    KST_ Villager Member

    Messages:
    11
    Likes Received:
    6
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    Thanks for the help! I actually managed to fix that even though it took some time, I found out that I should basically "invert" the upper right tile of the railing (also thanks for telling that the proper name is railing l o l)

    lol my tiles are so bad that I' found out that the top and bottom corners of the railing have different sizes
     
    #7
  8. Sharm

    Sharm Pixel Tile Artist Veteran

    Messages:
    12,615
    Likes Received:
    10,300
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    Is railing the right word? Generally a railing refers to the fence like thing along a balcony. Who said that was the name of the wall top, I'm not seeing it and I'm now confused?

    I'm glad you fixed the problem. Just FYI, I noticed in the earlier version that there's no top outline of the main wall tile, you probably forgot about it due to the two corner images on the top having an outline along the bottom, making it look correct casually. If you didn't catch it yet, that might be something else to fix.
     
    #8
  9. KST_

    KST_ Villager Member

    Messages:
    11
    Likes Received:
    6
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    I didn't quite understand what you're talking about, the right wall is not intended to have a top outline, while the left one has an outline
     
    #9
  10. Sharm

    Sharm Pixel Tile Artist Veteran

    Messages:
    12,615
    Likes Received:
    10,300
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    I'm talking about the left one. Here, I'll show you:

    wallline.png

    The bright blue line is where the outline should be, but it's the fill color.
     
    #10
  11. KST_

    KST_ Villager Member

    Messages:
    11
    Likes Received:
    6
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    Oh, I didn't even notice that lol, I'll fix it ASAP, thanks!
     
    #11
    Sharm likes this.

Share This Page