Status
Not open for further replies.

S.Court

Veteran
Veteran
Joined
Oct 17, 2012
Messages
394
Reaction score
98
First Language
Español
Primarily Uses
RMVXA
Hello, I have a trouble... For some strange reason when I try to use the debug window (F9 button) or reset the game (F12 button) the game just get paralyzed and does nothing! If my memory is not wrong that was after I installed Yanfly's debug extension script, but I erased it and the game keeps the same! Does someone know how to fix that? Thank you
 
Last edited by a moderator:

Dacuna

Veteran
Veteran
Joined
Feb 19, 2013
Messages
143
Reaction score
10
First Language
English
Primarily Uses
If you have it, you should try reinstalling the RTP.

Something weird went on with my parameters and they didn't show up, but that fixed it.

This is may not be the solution to this problem, but just a suggestion.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,560
Reaction score
8,159
First Language
German
Primarily Uses
RMMV
The RTP has absolutely nothing to do with the problem of the first poster.


@OP:


Please give us a link to that script, and also check if the script is possible still in your project in an unnamed script slot.


Yanfly's scripts are all tested and used by thousands of users, they're stable - which means that this is either a wrong configuration of the script or an incompatibility between two or more scripts, or a damaged editor (which would need a complete reinstall, not just RTP reinstall)
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,203
Reaction score
14,679
First Language
English
Primarily Uses
RMMV
I've moved this thread to RGSSx Script Support. Please be sure to post your threads in the correct forum next time. Thank you.


I'm also wondering if you've still got it in your project - maybe you put in more than one copy (though that might cause problems of its own). Check any unnamed slots to see if it's there.


F9 and F12 do completely different things, and it's unlikely that it's a single script that's causing your game to freeze in both instances.


Put Yanfly's script into a completely new project and see if the problem happens.
 

S.Court

Veteran
Veteran
Joined
Oct 17, 2012
Messages
394
Reaction score
98
First Language
Español
Primarily Uses
RMVXA
I'm also wondering if you've still got it in your project - maybe you put in more than one copy (though that might cause problems of its own). Check any unnamed slots to see if it's there.

F9 and F12 do completely different things, and it's unlikely that it's a single script that's causing your game to freeze in both instances.

Put Yanfly's script into a completely new project and see if the problem happens.
Hi Shaz! Well, I did that and it works normally in a new project, and I looked in unnamed slots and this script is not there

I checked and there's not anything affect anything when I press F9 Key, except Yanfly Script and the Scene_Map script

The RTP has absolutely nothing to do with the problem of the first poster.

@OP:

Please give us a link to that script, and also check if the script is possible still in your project in an unnamed script slot.

Yanfly's scripts are all tested and used by thousands of users, they're stable - which means that this is either a wrong configuration of the script or an incompatibility between two or more scripts, or a damaged editor (which would need a complete reinstall, not just RTP reinstall)
Here is the link Andar https://github.com/Archeia/YEARepo/blob/master/Utility/Debug_Extension.rb but as I could see, it's not the problem itsef

Also, when you mean reinstall it means just to install again the program, or do you mean do I have to do something in specific in my project?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,560
Reaction score
8,159
First Language
German
Primarily Uses
RMMV
I originally meant the editor reinstalling, nothing in the project - but with your added information I can now say that this wouldn't help.

Because if the editor were damaged, it would also happen in the new project - since the new project worked normally, it has to be something in your project, not in the editor.

And since yanfly does change the F-keys, and works in a new project, it has to be something else changed in your project that causes this incompatibility.

Somehow, somewhere, you changed part of the default scripts handling the F-Keys, and that change now prevents you from using the debug menu.

And you'll have to find out where you did that, and replace the changed default script with an undamaged from another project.
 

S.Court

Veteran
Veteran
Joined
Oct 17, 2012
Messages
394
Reaction score
98
First Language
Español
Primarily Uses
RMVXA
I originally meant the editor reinstalling, nothing in the project - but with your added information I can now say that this wouldn't help.

Because if the editor were damaged, it would also happen in the new project - since the new project worked normally, it has to be something in your project, not in the editor.

And since yanfly does change the F-keys, and works in a new project, it has to be something else changed in your project that causes this incompatibility.

Somehow, somewhere, you changed part of the default scripts handling the F-Keys, and that change now prevents you from using the debug menu.

And you'll have to find out where you did that, and replace the changed default script with an undamaged from another project.
So, I have to replace all the default scripts from a empty project, if that doesn't work, that should be one of the multiple scripts I have installed right?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,560
Reaction score
8,159
First Language
German
Primarily Uses
RMMV
probably - unless you have any other idea or remember where else you experimented when you tried out the debug script, you'll have to do it the hard way and test it with everything...
 

S.Court

Veteran
Veteran
Joined
Oct 17, 2012
Messages
394
Reaction score
98
First Language
Español
Primarily Uses
RMVXA
probably - unless you have any other idea or remember where else you experimented when you tried out the debug script, you'll have to do it the hard way and test it with everything...
I'm pretty sure I haven't edited a single line of default scripts, but I'll try it
 

S.Court

Veteran
Veteran
Joined
Oct 17, 2012
Messages
394
Reaction score
98
First Language
Español
Primarily Uses
RMVXA
I'll apologize for double posting from now, but I made a discovery of this problem:

It looks like it's not the fact the game paralyzes, it's the fact there is A LOT of lag when I try to open the debug window with F9 key, and the lag is EVEN bigger when I use the debug extension (of course, that has a lot of sense because has more options) it's as big than I can wait more than 3 minutes and it doesn't appear, however when I erase it the lag is more like 30-35 seconds... Still it's very big, and maybe is related with the quantity of scripts I'm using in the game, does someone know how to fix that?
 
Last edited by a moderator:

YoraeRasante

Veteran
Veteran
Joined
Jun 6, 2014
Messages
1,647
Reaction score
428
First Language
Portuguese
Primarily Uses
RMMV
some script you are using may be the reason...
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,203
Reaction score
14,679
First Language
English
Primarily Uses
RMMV
I've moved this thread to RGSSx Script Support. Please be sure to post your threads in the correct forum next time. Thank you.


Piers, please avoid double posting, as it is against the forum rules. You can review our forum rules here. Thank you.


Don't apologise - just don't do it ;) You can edit your post to add extra info so you don't need to double post.


How many debug scripts do you have? How many variables and switches are in your program? Is it lagging because of the sheer amount of stuff it's got to load before displaying?


Add links to the debug script(s).
 

S.Court

Veteran
Veteran
Joined
Oct 17, 2012
Messages
394
Reaction score
98
First Language
Español
Primarily Uses
RMVXA
Don't apologise - just don't do it ;) You can edit your post to add extra info so you don't need to double post.

How many debug scripts do you have? How many variables and switches are in your program? Is it lagging because of the sheer amount of stuff it's got to load before displaying?

Add links to the debug script(s).
Switches and variables... OF COURSE, THAT'S THE PROBLEM WITH THIS! I used database limit breaker (http://forums.rpgmakerweb.com/index.php?/topic/1267-database-limit-breaker-11/) recently because I KNOW I'll need the extra space, but I forgot to delete the ones I'm not using still!

Now I erased the ones I'm not using and the lag was reduced a lot (I used Yanfly's debug extension and it's still laggy, but at least now the debug window opens!) Well... That's kinda embarrasing  :headshake:   but at least I know which was the problem and I could solve, thanks a lot, you can close this post now Shaz
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,203
Reaction score
14,679
First Language
English
Primarily Uses
RMMV
This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

FirestormNeos wrote on Neikoku's profile.
the cat in your profile picture is adorable
Are the default-size "chibi" sprites really a bad thing for a project? I'm not planning to sell my game anyway but I was wondering if they were as hated as some videos seem to claim...
Only 9 things left on the to-do list before my game's next big update. Minus the soul-crushing playtesting session, of course! So close...
Retired from RPG Maker.
Anyone else who initially created a character to be a villain only to end up liking them so much that you made them a hero? :)

Forum statistics

Threads
111,428
Messages
1,061,050
Members
144,788
Latest member
fmoviesfco9
Top