Problem With Yanfly Plugins Cannot read property 'height' of undefined

Discussion in 'Javascript/Plugin Support' started by mixta, Mar 14, 2018.

  1. mixta

    mixta Warper Member

    Messages:
    1
    Likes Received:
    0
    First Language:
    Spanish
    After installing the AnimatedSvenemies plugin, I tried to put an animated enemy but when my character tries to hit the enemy he jumps this error can not read property 'height' of undefined. I have tried to disable all the plugins.


    https://ibb.co/ngfj2x

    https://ibb.co/iQRGhx
     
    #1
  2. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,358
    Likes Received:
    10,404
    First Language:
    English
    Primarily Uses:
    RMVXA
    'MV School' is a place where various "lessons" (interactive tutorials) will be posted. It is not for asking Support questions.

    I've moved this thread to Javascript/Plugin Support. Please be sure to post your threads in the correct forum next time. Thank you.



    Could you please edit your opening post to include a link to the page on Yanfly's website where you got that plugin. That way, if anyone who wants to help you needs to check something, they don't have to go hunting for it.
    Thanks.
     
    #2
  3. Shaz

    Shaz Veteran Veteran

    Messages:
    37,307
    Likes Received:
    11,119
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Please search before posting. There are a dozen thread on this, including one with SOLUTION written all over it.

    Your core files are old. Update them.
     
    #3
  4. caethyril

    caethyril ^_^ Veteran

    Messages:
    1,035
    Likes Received:
    641
    Location:
    UK
    First Language:
    English
    Primarily Uses:
    RMMV
    Last edited: Mar 14, 2018
    #4
  5. Shaz

    Shaz Veteran Veteran

    Messages:
    37,307
    Likes Received:
    11,119
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    It's not Yanfly's plugins that are out of date. This problem happens when you use the later versions of the plugins but are using a very early version of the core files. When you start a project in an old version of MV, and MV gets updated and you don't manually update all of your existing projects. Your projects are still at the old version, even though you are opening them in the new editor. The plugins require stuff that is in the newer core files but was not in the older ones.
     
    #5
  6. caethyril

    caethyril ^_^ Veteran

    Messages:
    1,035
    Likes Received:
    641
    Location:
    UK
    First Language:
    English
    Primarily Uses:
    RMMV
    Oh. Yes, confirmed. :kaoslp: The issue used to occur when using an old version of Yanfly's plugins shipped with MV, as they tried to reference the old objects in the newer base code, but it seems those plugins have been updated sufficiently now that the error no longer occurs. Edited my post above, the link's still relevant. :kaoswt:
     
    #6

Share This Page