QPlugins - Latest: QABS

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
@Skurge it's part of the options, so it follows the format:
Code:
qAudio start [AUDIONAME] [list of options]
So as long as it's after 'qAudio start [AUDIONAME]' it'll work. The order of options doesn't matter. Also looking at that, the text for the type option is a bit confusing: "type - bgm, bgs, me, or se (Default: bgm)" but there's examples for that, so thats fine for now.
An example fadein is:
Code:
 qAudio start Battle1 bgm idAb1 fadein2
Could have left out bgm, since default is bgm. But for a clear example I added it in.
 

Skurge

" (GASP) What's going on!? "
Veteran
Joined
Jul 12, 2015
Messages
1,068
Reaction score
219
First Language
English
Primarily Uses
N/A
OK, think I got it worked out in ways of execution.
Here is the start of said audio command
qAudio start fadein5 Sedan se id7 radius12 bindTo7 loop
Here is the end of said audio-which seems to crash.
qAudio stop id7 fadeOut
These are screen caps of the crash reports.


NOTE: I have tried to send my JS plugins file to expand my report for investigation- but the forum for some reason is not allowing me to upload js files...
 
Last edited:

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
Just updated it, go ahead and grab QAudio 2.1.1, was a bug with the stop command.

Also your play isn't exactly correct, i think you mean:
Code:
qAudio start Sedan se fadein5 id7 radius12 bindTo7 loop
the way you had it, it was looking for an se called fadein5, since fadein5 was the 3rd word, which needs to be the file name, after the 3rd word the order for options doesn't matter
 
Last edited:

Skurge

" (GASP) What's going on!? "
Veteran
Joined
Jul 12, 2015
Messages
1,068
Reaction score
219
First Language
English
Primarily Uses
N/A
That seems to fix the problem, glad you could further clarify that for me :)
Also I think I picked up a bug with your speed plugin, it seems the updated version has somehow made the players sprinting speed the default movement where has holding shift has reverted it to the standard movement. Would you mind checking that plugin?
 

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
@Skurge Not sure what you mean. But I went ahead and testing QSpeed, and the dash parameter still seems to work if that's what you meant.
 

Skurge

" (GASP) What's going on!? "
Veteran
Joined
Jul 12, 2015
Messages
1,068
Reaction score
219
First Language
English
Primarily Uses
N/A
Oh boy. I know what's happening now- turns out my project for some reason decided to set always dash ON without my consent.
I was getting confused as to why holding down shift was slowing me...
Sorry for the false alarm, now I need to find a plugin to remove that option.

Was just curious to ask about momentum and such, i understand what you said earlier about it being out of the question, but just theoretically if the vehicle had it's separate speed parameters and acceleration just like the normal player does, would by default the vehicle having the slowest speed possible and when holding shift it proceeds to the top speed with it's acceleration delay by large frames i.e 200?
 
Last edited:

Kest

The Ecstasy of Gold
Veteran
Joined
Dec 4, 2014
Messages
147
Reaction score
24
First Language
English
Does anyone else get a black screen when attempting to run the Master Demo?

Additionally, I can't get the QInput plugin group working properly. It seems to have no effect besides disabling the menu.

 
Last edited:

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
@Skurge You might have enabled it inside the projects options. In the menu > options, there's an option to always dash.
And yeah that is possible, though you might need a plugin to enable dash while in a vehicle.

@Kest For both questions, did you push F8 to check if there's any errors in the console? Also I would avoid using InputRemap, with the latest QInput for now. InputRemap only allows 1 input per action, the main issue here is if someone wants to use the gamepad and they remap gamepad keys, the keyboard will no longer be functional. I'll be remaking that plugin eventually.
 

Skurge

" (GASP) What's going on!? "
Veteran
Joined
Jul 12, 2015
Messages
1,068
Reaction score
219
First Language
English
Primarily Uses
N/A
I managed to find a plugin called TDD_ManageDashing which allowed me to remove the dashing option.
However my searches for vehicle dashing settings are on a halt- I've looked around and I can't find any, before I make a move to request one do you know of any plugins that can?
 

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
Nope I don't know of any, but it would be a simple edit. So from what you're describing, you should probably just request a whole plugin to handle that. Cause if you do enable dashing while in vehicles, it would use the players dash inc.
 

Skurge

" (GASP) What's going on!? "
Veteran
Joined
Jul 12, 2015
Messages
1,068
Reaction score
219
First Language
English
Primarily Uses
N/A
You know better than me regarding the functions of the program and plugins, if I make this request and if someone wishes to extend there helping hand and require to modify the Qspeed plugin is that OK?
 

Kest

The Ecstasy of Gold
Veteran
Joined
Dec 4, 2014
Messages
147
Reaction score
24
First Language
English
@Kest For both questions, did you push F8 to check if there's any errors in the console? Also I would avoid using InputRemap, with the latest QInput for now. InputRemap only allows 1 input per action, the main issue here is if someone wants to use the gamepad and they remap gamepad keys, the keyboard will no longer be functional. I'll be remaking that plugin eventually.
Console doesn't appear when pressing F8 in the blackscreen demo. None of the other keys work either.

For my personal project, there were no errors in the console. Disabling and rearranging mods has no effect on QInput hiding the menu. I even tried adding keys like #o to the Menu parameter, still nothing.
 
Last edited:

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
@Skurge Yup, like it says in the terms:
  • Free to use, modify and distribute.
As well as:
  • Any of my plugins may be edited and redistributed as a completely new plugin. You can even add on your own terms onto the edited version. You just need to add "This plugin was created/modified from ORIGINAL PLUGIN NAME by Quxios, + link to github js of that plugin", somewhere publicly visible ( in the help, or above terms, ect. ).
@Kest For the 1st issue, try disabling certain plugins, see which one is causing it. That issue seems like it's trying to load something that doesn't exist, so it's stuck loading.

For the 2nd, I'm assuming you are still using Input Remap. If you've ever used the plugin in game, then that's the issue. Adding / Changing the inputs in QInput will not change anything, because you've already remapped them. So when you load you're game it's loading you're remapped inputs and uses those, not the ones you set in the plugin parameters. To reset this either delete your options save "saves/config.rpgsave" or click on the "Set Default" in the input remap window (not sure if 2nd method will fix it, but it might)
 

Kest

The Ecstasy of Gold
Veteran
Joined
Dec 4, 2014
Messages
147
Reaction score
24
First Language
English
For the 1st issue, try disabling certain plugins, see which one is causing it. That issue seems like it's trying to load something that doesn't exist, so it's stuck loading.
Doesn't seem like a plugin - I disabled each of them and still got a blackscreen. It might be an event with a typo.

For the 2nd, I'm assuming you are still using Input Remap.
Not anymore.



I deleted the file you mentioned, but it looks like you forgot to include a keyboard input for Menu in the QInput default parameters.
 
Last edited:

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
@Kest go ahead and disabled quick test parameter in QPlus, then try again. That time you should start on the title screen, then you should be able to push F8. Hit new game and see if it still black screens, if it does this time you have the console out and see if there's an error. If it's a bad event, it would throw an error.

Either way I still need to edit the demo to add in QMovement examples. So I'll work on updating the demo asap, hopefully in 1-2 days.

For QInput, the Menu input was added in 2.1.X. The menu action, by default, is a gamepad only action. But with being able to map keys to actions with QInput, you can make it work for the keyboard as well. For example:

Now I can open the menu by pushing the p key.

QInputRemap, doesn't have the Menu input, since again, it was a gamepad only action. And in QInput 2.1.X I added gamepad support. And QInputRemap still needs a massive rewrite to work better with 2.1.X

On final note, make sure your MV files are 1.3.x+ since these plugins are written based on those versions. So using them with old mv versions might not work.

Edit: Also note that the Escape / Cancel actions will also open the menu
 

Kest

The Ecstasy of Gold
Veteran
Joined
Dec 4, 2014
Messages
147
Reaction score
24
First Language
English
No, I got the Menu working again with my last post. Was just giving you a heads up, the default settings for your latest version of QInput:
  1. the Menu parameter is missing a keyboard input
  2. #esc or #cancel do not open the menu (because of #1 - you need to add them)
 
Last edited:

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
@Kest ah yeah I see now, thanks! I'll update the default parameters in the new update to include #esc in the menu action
 

Kest

The Ecstasy of Gold
Veteran
Joined
Dec 4, 2014
Messages
147
Reaction score
24
First Language
English
@Kest go ahead and disabled quick test parameter in QPlus, then try again. That time you should start on the title screen, then you should be able to push F8. Hit new game and see if it still black screens, if it does this time you have the console out and see if there's an error. If it's a bad event, it would throw an error.
This also blackscreens before the title. :kaoswt2:

 

Quxios

Veteran
Veteran
Joined
Jan 8, 2014
Messages
1,055
Reaction score
782
First Language
English
Primarily Uses
RMMV
Updates
QMovement 1.0.2
  • Fixed some bug with circle colliders
  • Fixed the default player / event collider config not being used
  • + couple of other stuff

QPathfind 1.0.1
  • Small change on restarting pathfinds. Don't remember what it was for, if I finished the fix. But think it was related to QMovement compatibility
New Plugin
QM+CollisionMap - v1.0.x
Download - https://github.com/quxios/QMV-Master-Demo/tree/master/js/plugins/QM+CollisionMap.js
This is an addon to QMovement plugin. This addon adds a feature that lets you use images as a collision map.
Main difference from old version is that: white and transparent colors are now passable, all other colors are impassable. I made it this way because have "precise" colors can cause issues. For example, I have my monitor calibrated and have my gamma value changed. So if I make an image thats pure #FF0000, all red, and load it into MV and check the pixel color I'll get something like #FF0302 instead of #FF0000 because the gamma correction was applied when the png is being decoded. So only black, white and transparent are accurate colors. For this reason I won't be bringing back region maps since that requires exact colors.

The demo has also been updated.

 

josaaku

Villager
Member
Joined
Jun 7, 2016
Messages
10
Reaction score
5
First Language
German
Primarily Uses
RMMV
QMovement: Is diagonal movement with QSprite implemented yet? It doesn't seem to work as it should: "move1", "move3", "move7" and "move9" have no effect.

Testfile: Put in in the data-folder on Master demo. I implemented move1 to move9 with Sprite Animator, it should change the appearence of the character. But it doesn't.

Other than that: Wonderful plugin!
 

Attachments

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

I'm having such a hard time thinking of an interesting battle system. and not being a coder, certain things I wanna do seem a lot harder lol.
Created a character outline with some code. I have no use for this. I'm....bored.....
Having lots of fun using different PS brushes to add a lil' texture to the floors and walls in my maps.
Setup a system to cull enemies that are too far from the player to matter, and to spawn new ones just outside of view. Take that lag! :LZSexcite:

Forum statistics

Threads
93,719
Messages
914,897
Members
123,321
Latest member
harmlessgamedev
Top