Quasi Sprite

Discussion in 'JS Plugin Releases (RMMV)' started by Quxios, Feb 28, 2016.

  1. Quxios

    Quxios Veteran Veteran

    Messages:
    1,055
    Likes Received:
    780
    First Language:
    English
    Primarily Uses:
    RMMV
    Sorry for the late reply. I'm no longer supporting any of my plugins so I hardly read any msgs. But since this is related to the app, I will look into fixing it soon.
     
  2. lonewolph

    lonewolph Veteran Veteran

    Messages:
    194
    Likes Received:
    14
    First Language:
    English
    Any word on this yet Quasi? :) My whole project is depending on you
     
  3. Quxios

    Quxios Veteran Veteran

    Messages:
    1,055
    Likes Received:
    780
    First Language:
    English
    Primarily Uses:
    RMMV
    I'm rewriting the app from scratch now that I've learned more front-end dev stuff. So it's nearly done, I think I'll need like 2-3 more days. The UI is all done, I just need to add in the canvas related stuff and then test everything + test everything when it's deployed ( which I didn't do last time ). But so far it's already running much smoother and quicker then before.
     
    SpookySoul and Fafs like this.
  4. Quxios

    Quxios Veteran Veteran

    Messages:
    1,055
    Likes Received:
    780
    First Language:
    English
    Primarily Uses:
    RMMV
  5. WackySwacky

    WackySwacky Warper Member

    Messages:
    2
    Likes Received:
    0
    First Language:
    English
    Thanks Quasi, it seems to be working now.
     
  6. Selvalanch

    Selvalanch Villager Member

    Messages:
    16
    Likes Received:
    0
    First Language:
    Thai , English
    excuse me. does sprite image name have to match a config name? for ex. i name a config " #player-b " do i need to have a character use "#player-b.png" for its sprite?

    also, i use prebuilt 32bit and animation speed didn't change when i set it from 15 to another value.
     
  7. Quxios

    Quxios Veteran Veteran

    Messages:
    1,055
    Likes Received:
    780
    First Language:
    English
    Primarily Uses:
    RMMV
    @Selvalanch The config name is the prefix for that config. So if you made a config named:
    player
    Then the images that you want to use that config will be named:
    #player-somefilename.png


    Though doesn't have to be #CONFIGNAME-filename, that is the default setting but you can change it inside the plugin parameters since files starting with # doesn't work on android, you might want to change it the # to like % or some other character

    As for the speed value, I just tested and yeah it's not changing the speed, will fix it soon.


    Edit:
    The animator as been updated.


    https://github.com/quasixi/SpriteAnimator#prebuilt


    Also as a note, the speed values are updating in the json. But it wasn't updating the speed value in the preview sprite. So if you had already set speed values before, no need to reset them as they should work in mv correctly. Was only a visual bug in the editor.
     
    Last edited by a moderator: Nov 27, 2016
  8. Selvalanch

    Selvalanch Villager Member

    Messages:
    16
    Likes Received:
    0
    First Language:
    Thai , English
    Got it. Thank you very much!
     
  9. brandos

    brandos Veteran Veteran

    Messages:
    147
    Likes Received:
    31
    First Language:
    German
    I get the error when I try to run the game. Any help? :/

    Code:
    TypeError: Cannot read property 'anchorX' of undefined
        at Sprite_Character.updateBitmap (file:///I:/BUILDS/Super/js/plugins/QuasiSprite.js:338:50)
        at Sprite_Character.update (file:///I:/BUILDS/Super/js/rpg_sprites.js:213:10)
        at Sprite_Character.update (file:///I:/BUILDS/Super/js/plugins/QuasiMovement.js:3910:35)
        at Sprite_Character.update (file:///I:/BUILDS/Super/js/plugins/QuasiABS.js:3529:35)
        at file:///I:/BUILDS/Super/js/rpg_core.js:4199:19
        at Array.forEach (native)
        at ShaderTilemap.Tilemap.update (file:///I:/BUILDS/Super/js/rpg_core.js:4197:19)
        at file:///I:/BUILDS/Super/js/rpg_core.js:3570:19
        at Array.forEach (native)
        at Sprite.update (file:///I:/BUILDS/Super/js/rpg_core.js:3568:19)
     
  10. Emperor DragonBreath

    Emperor DragonBreath Veteran Veteran

    Messages:
    156
    Likes Received:
    4
    Location:
    The Second Circle of Hell
    First Language:
    English
    Quasi, your app did not pop up for me at all!
     
  11. Quxios

    Quxios Veteran Veteran

    Messages:
    1,055
    Likes Received:
    780
    First Language:
    English
    Primarily Uses:
    RMMV
    @brandos Your error is showing that the QSprite config isn't being found. So make sure the config name is correct in the json and on the sprite.


    @Emperor DragonBreath Did you try the latest version? 2.0.x ? If so maybe try the 32bit version if you tried the 64.
     
  12. HasdrubalBarca

    HasdrubalBarca Veteran Veteran

    Messages:
    160
    Likes Received:
    56
    First Language:
    English
    Did you get an error message? I got one and googling it led me to find out that it was because I'm still using Vista.


    Thankfully the previous versions of the app works fine.
     
    Last edited by a moderator: Dec 20, 2016
  13. Quxios

    Quxios Veteran Veteran

    Messages:
    1,055
    Likes Received:
    780
    First Language:
    English
    Primarily Uses:
    RMMV
    I just updated the editor:


    v2.0.3
    https://github.com/quxios/SpriteAnimator

    Fixed a bug with pose preview not working correctly when hovering over a pose in the pose list.
    Also added the Adjust button, apparently I never added it in.


    @HasdrubalBarca Was that issue with both 32 and 64 bit versions? Also what was the error / whats the source that you found? Maybe I can look into it to see if there's a fix.
     
  14. HasdrubalBarca

    HasdrubalBarca Veteran Veteran

    Messages:
    160
    Likes Received:
    56
    First Language:
    English
    I get the "QuasiSprite.exe - Entry Point Not Found. The procedure entry point GetCurrentProcessExplicitAppUserModelID could not be located in the dynamic link library SHELL32.dll." Both with the 32 and 64 bit versions.
     
  15. Quxios

    Quxios Veteran Veteran

    Messages:
    1,055
    Likes Received:
    780
    First Language:
    English
    Primarily Uses:
    RMMV
    @HasdrubalBarca Ah yeah just looked into it. Looks like electron only works on windows 7+ sadly. So sorry to anyone with older windows!
     
  16. Kogemashita

    Kogemashita Veteran Veteran

    Messages:
    37
    Likes Received:
    28
    Location:
    Ontario, Canada
    First Language:
    English
    Primarily Uses:
    RMMV
    wait so will I be able to use json files exported from programs such as spriter or spine 2d as sideview battlers using this plugin?
     
  17. Quxios

    Quxios Veteran Veteran

    Messages:
    1,055
    Likes Received:
    780
    First Language:
    English
    Primarily Uses:
    RMMV
  18. jobar

    jobar WonderLang Veteran

    Messages:
    49
    Likes Received:
    47
    First Language:
    french
    Primarily Uses:
    RMMV
    Have you found the solution? I am encountering the same problem
     
  19. Ewick

    Ewick Warper Member

    Messages:
    2
    Likes Received:
    0
    First Language:
    Tagalog
    Primarily Uses:
    N/A
    is there a sample newbie guide on how to use this plugin? I cant seem to understand how to implement the poses...
     
  20. blakebishop1989

    blakebishop1989 Villager Member

    Messages:
    27
    Likes Received:
    4
    First Language:
    english
    Hello I'm having an issue while using Q Sprite and Q Movement I seem to be getting 6 images at once instead of an altogether render of
    the hero player. Is there anyone who has a suggestion to fix this?
    [​IMG]
     

Share This Page