Astfgl66

Veteran
Veteran
Joined
Jan 5, 2016
Messages
740
Reaction score
613
First Language
French
Primarily Uses
Please send me a screenshot of your plugin parameters.
It seems to be crashing when trying to eval your icon array parameter so something fishy must be going on in there.

I'm still looking into the action sequence crashing. It doesn't look good for now, as it seems to be an interaction between my plugin and yanfly's but I can't find where they overlap.
 

nanashiXz

Villager
Member
Joined
Jun 14, 2021
Messages
6
Reaction score
0
First Language
English
Primarily Uses
RMMV
Please send me a screenshot of your plugin parameters.
It seems to be crashing when trying to eval your icon array parameter so something fishy must be going on in there.

I'm still looking into the action sequence crashing. It doesn't look good for now, as it seems to be an interaction between my plugin and yanfly's but I can't find where they overlap.

You got it! I'll send over all the screen shots I have. Including how it is working but not showing anything anymore. If I can do anything to help test this, please let me know. I will send over the plugins I have and whatever you need.
 

Attachments

  • Quoted Up on array.PNG
    Quoted Up on array.PNG
    426.1 KB · Views: 13
  • New whole array script.PNG
    New whole array script.PNG
    392.3 KB · Views: 9
  • Current Plugins.PNG
    Current Plugins.PNG
    349.4 KB · Views: 14
  • Icon blank.png
    Icon blank.png
    437.4 KB · Views: 12

Astfgl66

Veteran
Veteran
Joined
Jan 5, 2016
Messages
740
Reaction score
613
First Language
French
Primarily Uses
Yeah, it's just like I thought You have put a wrong datatype into the parameters.
This plugins draws icon from your iconset to use as a way to display QTE inputs.
You're going to have to make or find icons for arrows and buttons you'd like to use, put them into your iconset and then reference their index in the plugin parameters.
Here's how it should look like.
rmfxM8d.png


No news about action sequences not working properly. Still have no idea what causes it.

Spoiler'd below is my very ugly template iconset for testing purposes.
kIn1wpj.png


Indexes start from 0 for the first empty space. You can find the iconindex without having to count by going into any window that has you choosing an icon and looking at the bottom left part of the UI window: notice how guard is icon n*81, it's also writen on the spell itself once you've chosen an icon as you can see.
2QjkZXY.png
 
Last edited:

nanashiXz

Villager
Member
Joined
Jun 14, 2021
Messages
6
Reaction score
0
First Language
English
Primarily Uses
RMMV
Perfect! I have reset the parameters for the IconSet arrays and the icons appear as needed. And your array isn't ugly! It looks like it mathces perfectly. So far each test has pulled up my janky looking icon until I put some better ones down. Unfortunately the script call with <setup array> is the one that will actually cast the spell (pass or fail no matter what), but the skill name won't be shown as a call as if the character casts it. On the other hand <whole array> will call the skill name, but won't cast. I'll leave it as is just in case I screw it up further. I can run other tests if you want.
Yeah, it's just like I thought You have put a wrong datatype into the parameters.
This plugins draws icon from your iconset to use as a way to display QTE inputs.
You're going to have to make or find icons for arrows and buttons you'd like to use, put them into your iconset and then reference their index in the plugin parameters.
Here's how it should look like.
rmfxM8d.png


No news about action sequences not working properly. Still have no idea what causes it.

Spoiler'd below is my very ugly template iconset for testing purposes.
kIn1wpj.png


Indexes start from 0 for the first empty space. You can find the iconindex without having to count by going into any window that has you choosing an icon and looking at the bottom left part of the UI window: notice how guard is icon n*81, it's also writen on the spell itself once you've chosen an icon as you can see.
2QjkZXY.png
 

arsMori

Drawer of Images
Veteran
Joined
Jul 21, 2021
Messages
161
Reaction score
184
First Language
Filipino
Primarily Uses
RMMV
Good morning!

Is it possible to change the color for the note display for rhythmic QTE or change it to an image?
 

KeniisuGG

Warper
Member
Joined
Oct 30, 2021
Messages
4
Reaction score
0
First Language
English
Primarily Uses
RMMZ
I found this plugin to be incredibly useful, thanks for making it!
 

Maja McCloud

Villager
Member
Joined
Aug 21, 2017
Messages
9
Reaction score
6
First Language
German
Primarily Uses
RMMV
Hi there!
First: What a great plugin! Love it!

But know I have a problem:
I testet it in a blank projekt and everything workted fine.
But when I put my event into my projekt, right when I start testplayed, it says:

TypeError
Cannot read property 'getResult' of undefined


And that befor even the title screen shows...

Help, please???


Just in case, this is the first page of my event:

Screenshot (77).png



I found out that

SumRndmDde's TitleMapBackground Plugin is causing the problem...
But I neeed that Plugin! Anybody any Idea in how to fix that?
 
Last edited:

Latest Threads

Latest Posts

Latest Profile Posts

By far, the weirdest flex I've ever seen on the internet is "I don't have the attention span to read what you wrote, but I REALLY want the world to know I don't have that attention span!".
Why... the FACK... do I work in customer service?!?!
Excuse me while I go question allllll my life choices.
DamageEvil_6.png added!
index.php

Sometimes I wonder why I still try and recruit others to help with my games. It never works.

Forum statistics

Threads
125,777
Messages
1,173,418
Members
164,930
Latest member
alantangyl
Top