Range error problem, help pls

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
So the problem I have is when I finish a battle there a screen that appear in the middle of my computer screen
and it 's say
Game has encountered a bug. Please report it

Range error: Maximum call stack size exceeded
at Array.reduce ()
at Game_Ennemy.Game_BattleBase.allTraits (rpg_objects.js:2375.32)

and other sentence like this. I don't know what to do and im pretty sure it's because
of the plugins.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
12,953
Reaction score
13,309
First Language
English
Primarily Uses
RMVXA
Sounds like you got some misspelled variables in your plug-ins, as there is no Game_Ennemy. But yes, it is probably due to a plug-in. You'll need to list all the plug-ins you have, as well as what version of MV your project is (not editor, project).

I've moved this thread to Plug-In Support. Please be sure to post your threads in the correct forum next time. Thank you.

 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
I don't really know what you are talking about ? I mean I know when you say project I go in the little button

'' project '' but after that I don't know what to do and for the plugins I re-download it and there always error
even if I turn off all the plugins.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,009
Reaction score
7,019
First Language
German
Primarily Uses
RMMV
The project is the game you're developing.
to check the project version, you go to your project directory and then to js and then you use a text editor to open the rpg_core.js file (no doubleclicking, that won't work). the core version is at the end of the title line.


as for checking the plugins, you need to give us a screenshot of your projects plugin manager before we can give better help. Please use [alt]-[prtscrn] instead of only [prtscrn] to make that screenshot.
 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
and my game need to be the same version of the plugins ?
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
12,953
Reaction score
13,309
First Language
English
Primarily Uses
RMVXA
It needs to be using plug-ins designed for that version. For instance if you are using 1.1 of MV you won't be able to use the newest plug-ins as they were designed for 1.5 or higher. But some other authors dropped support so you can only use their plug-ins with older versions of MV.
 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
oooooh it's explain a lot of things because I just get the new plugins I will try the old one just for fun
 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
I didn't find the old plugins. Do anyone know where I can find them ?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,009
Reaction score
7,019
First Language
German
Primarily Uses
RMMV
nowhere.
all plugin creators present only their laters plugins, the older versions are no longer available.
Only if you downloaded them while they were current, then you might still have them around and might be force to stay with an older version - otherwise it is always better to update and use the latest versions.

There is absolutely no way to search for old versions, you can only search for a script and then check to which core versions it is compatible..

Please show us a screenshot of your plugin manager and we can help you solve your problem.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
12,953
Reaction score
13,309
First Language
English
Primarily Uses
RMVXA
You also should open one of your core files and check which version of MV they are for. Once you find that post that info here please.

Also if your core version isn't 1.6.1 you will want to update it. I know there is a thread for directions on how to update it.
 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
The version of my RMMV is 1.6.1 and here my plugins manager and also I want to thank you for the help I know
I don't look like but it's been a while since I use RPG maker and after that im pretty sure I would be
finish with the base
 

Attachments

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,009
Reaction score
7,019
First Language
German
Primarily Uses
RMMV
@NagisaHeart
1) you have renamed some of your plugins, that is the most probably cause of the errors.
NEVER rename the plugin files, they have to have exactly the names they were written with because that name becomes part of the code.
2) we didn't ask for your RMMV editor version, we asked for your project core version. That is NOT automatically the same, and your projects core version can only be determined by opinging one of the projects rpg files with a text editor.
 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
it's weird cause all the plugins that were not with the game automatically I downloaded them and never done anything after that
So now im wondering what are the plugins that are renamed ?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,009
Reaction score
7,019
First Language
German
Primarily Uses
RMMV
the last two plugin names on that picture have spaces instead of underlines in them
additionally, can you give us the project's core version? Like I explained it is not automatically the same as the editor version, and it is another possible problem.
 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
For the plugins don't know why but they are normal and my project's core version is… I can't find it can you make a screenshot
of a project's core version ?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,009
Reaction score
7,019
First Language
German
Primarily Uses
RMMV
go to your project folder, into the js folder and then open the rpg_core.js file with a text editor (no doubleclick!!!)
the version is at the end of the title line
 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
Yes you already said that but I don't know where is the title line. The only version that I see is the RPG MAKER version that is 1.6.1
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,009
Reaction score
7,019
First Language
German
Primarily Uses
RMMV
which text editor do you use to open the file? windows notepad or something else?
The title line is usually the second line in the file.
Just to make sure - you cannot read the number inside the MV editor, the RM editor has to be closed at that time.
then you get a text line with the name of the file followed by a version number, and that version number might be the same as a editor version number, but in this place the number has a different function.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,130
Reaction score
12,404
First Language
English
Primarily Uses
RMMV
The RM editor doesn't have to be closed. You just can't see the core version from the editor - you need to open the script file manually to find it.

From the Game menu, choose Open Project Folder. Then go into the js subfolder, and find the file called rpg_core.js (or if you have extensions hidden, it'll just say rpg_core). Right-click on that file and choose Edit. Any editor will do - even Notepad if that's all you have.

On the first couple of lines there should be a version number. If you don't see anything that says a version number on the first 5 lines, you are using 1.0.0

When you close the window, make sure you don't save the file.
 

NagisaHeart

Villager
Member
Joined
Jul 5, 2017
Messages
18
Reaction score
1
First Language
English
Primarily Uses
RMMV
yes and the number I see is RPG Core v1.6.1 and it's only one does that mean I need too update my core ?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Yesterday, for my youngest sibling's birthday, we watched one of his favorite movies.
Ponyo is such a beautiful, but certainly strange, movie.
I just have to say that I prefer the majority of Studio Ghibli's works to those of Disney.
*sees work place in incoming call history* .... =www= hisssssSSSSSssss.
Please pop up a storm. Please pop up a storm.
So I tried composing a battle theme for the Linear Motion Battle System that I'm probably going to implement into my game. I really love real time combat, and I think that this theme might help give some energy to battles. Tell me what you think of it in the comments! Also, please do not use my music in your games.
My LMBS battle theme
* Me start speak in voice chat
"Lol, you're actually a girl?!"
(But I'm a guy tho... well, let's just pretend and see how long it will last)
* Years has passed... I have changed.

Forum statistics

Threads
97,807
Messages
947,083
Members
129,016
Latest member
TheRealElohim
Top