Resolution Problems with fullscreen across all versions of RPG Maker

Discussion in 'Tech Support-All Makers' started by Praygon, Oct 7, 2018.

Thread Status:
Not open for further replies.
  1. Praygon

    Praygon Villager Member

    Messages:
    16
    Likes Received:
    6
    First Language:
    English
    Hey everyone.

    I have a problem with RPg makers that seems oddly constient between games from almost every version of RPG Maker. When ever I fullscreen a RPG maker game with F4 or Alt + Enter the resolution forces itself into 640 X 480 (My native resolution being 1360 x 768) but rather than stretching the game window the display remains tiny within the middle of the screen while the rest has a thick black border (Iv attached a picture below as an example)

    [​IMG]

    Any ideas what's causing this and how I can fix it? I'm really not to fussed what resolution I play games at just so long as it actually fills the screen.
    Cheers.
     
    #1
  2. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,891
    Likes Received:
    12,009
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    Are you talking about this for games you wish to play? If so you may want to hit F1 and see if you have any options to change how it is displayed. Otherwise, that would have to be something the developer would have to code into the game, and all makers except MV have a hard cap of 640 x 480 resolution so all it can do is stretch it to try to fill it.
     
    #2
  3. MushroomCake28

    MushroomCake28 KAMO Studio Veteran

    Messages:
    1,675
    Likes Received:
    3,004
    Location:
    Montreal, Canada
    First Language:
    English
    Primarily Uses:
    RMMV
    Try to hit F3 while in fullscreen.
     
    #3
  4. Praygon

    Praygon Villager Member

    Messages:
    16
    Likes Received:
    6
    First Language:
    English
    Yup im only looking to play other peoples games. Tried hitting F1 But no dice none of the options had any effect on the game size. What confuses me is on a previous only very slightly smaller monitor RPG maker games when full screened would force the resolution change and then stretch the play area leaving no black borders. I don't fully understand why on my current setup the games remain in the same window size as before being fullscreened.

    F3 had no effect ether i'm afraid but thanks for the suggestion.
     
    #4
  5. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,891
    Likes Received:
    12,009
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA
    That would be a setting then in your video or monitor drivers then if there was nothing in F1 that can help. You'll have to set it to stretch when in full screen. Right now you have it set to not which is why you are getting what you are on this monitor. Or you could try right click on the command to run the game -> properties -> Compatibility -> run in 640 x 480. That might fix it as well, or at least make it better.

    However, you may still get black borders if your resolution isn't a multiple of the games set resolution, as some part of it will not fully fit. There's no fix for that short of use a different resolution (and that's true for even AAA games unless they code in an option to force your monitor to a resolution for the game, then switch it back when you exit).
     
    #5
  6. Shaz

    Shaz Veteran Veteran

    Messages:
    37,552
    Likes Received:
    11,260
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    This is a function of your display card / graphics driver, and is not controlled by the game or the developer. It explains why it happens to ALL RPG Maker games.

    The solution is in right-clicking on the desktop and looking at your graphics settings - what version of windows you are running and the graphics card will determine where you go next. You're looking for a setting that will allow you to change what happens in full screen mode - whether it maintains the aspect ratio (leaving black borders), stretches, or does what you're seeing.
     
    #6
  7. Praygon

    Praygon Villager Member

    Messages:
    16
    Likes Received:
    6
    First Language:
    English
    Ahhh I see. Thank you guys I enabled GPU upscaling via my graphics cards control center and now the game upscales as much as it can on my screen.

    Cheers everyone for the help and this is pretty much done & dusted now.
     
    #7
    Shaz likes this.
  8. Shaz

    Shaz Veteran Veteran

    Messages:
    37,552
    Likes Received:
    11,260
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    If your problem is solved, just report your first post and ask the mods to close the thread :)
     
    #8
  9. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    11,891
    Likes Received:
    12,009
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA

    This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

     
    #9
Thread Status:
Not open for further replies.

Share This Page