Resolution Stretch Causes Peculiar Blur.

Discussion in 'RPG Maker MV' started by KanaX, Oct 7, 2016.

  1. KanaX

    KanaX Just being a mouse Veteran

    Messages:
    1,463
    Likes Received:
    1,277
    Location:
    My Apartment
    First Language:
    Broken English.
    Primarily Uses:
    N/A
    I just recently started moving my project on MV from Ace. While still using Ace, I utilized a script that allowed me to double the size of my game window and stretch the 544x416 screen to fit it.


    After using Shaz's plugin to resize my tiles to the classic 32x32, I tried tinkering with the boxwidth/height and screenwidth/height values. The result resembles closely what I had on Ace, but it's noticeably more blurry.
     

    [​IMG]



    I tried using different resolutions, that would be common multipliers of 32 and 48, but nothing really worked.

    Any ideas?
     
    #1
  2. SumRndmDde

    SumRndmDde Follower of RNGesus Veteran

    Messages:
    224
    Likes Received:
    409
    Location:
    an alternate dimension.
    First Language:
    English
    Primarily Uses:
    RMMV
    Try adding:


    <style type="text/css">
    CANVAS{image-rendering: pixelated;}
    </style>


    in the index.html file of your project.


    (Place it within the <HTML></HTML> tags)


    I use it and it works.


    Got it from:
     
    #2
  3. KanaX

    KanaX Just being a mouse Veteran

    Messages:
    1,463
    Likes Received:
    1,277
    Location:
    My Apartment
    First Language:
    Broken English.
    Primarily Uses:
    N/A
    @SumRndmDde Thank you, it's better, but I still cannot get the original crispness that I had from Ace.
     
    #3
  4. SumRndmDde

    SumRndmDde Follower of RNGesus Veteran

    Messages:
    224
    Likes Received:
    409
    Location:
    an alternate dimension.
    First Language:
    English
    Primarily Uses:
    RMMV
    Did you see the solution thing in the forum post I pasted?


    I think there was also something about using a quick plugin:


    ImageManager.loadBitmap = function(folder, filename, hue, smooth) {
    if (filename) {
    var path = folder + encodeURIComponent(filename) + '.png';
    var bitmap = this.loadNormalBitmap(path, hue || 0);
    bitmap.smooth = false; //Smooth is always false (might fix bluryness...?)
    return bitmap;
    } else {
    return this.loadEmptyBitmap();
    }
    };




    That would set it so bitmaps loaded will always have smooth turned off. I haven't trued it myself, but that might work also.
     
    Last edited by a moderator: Oct 7, 2016
    #4
    RicoRob likes this.
  5. KanaX

    KanaX Just being a mouse Veteran

    Messages:
    1,463
    Likes Received:
    1,277
    Location:
    My Apartment
    First Language:
    Broken English.
    Primarily Uses:
    N/A
    @SumRndmDde I did check that out too, at some point. Didn't do much. I have to put the js file in the plugin folder, right?
     
    Last edited by a moderator: Oct 7, 2016
    #5
  6. SumRndmDde

    SumRndmDde Follower of RNGesus Veteran

    Messages:
    224
    Likes Received:
    409
    Location:
    an alternate dimension.
    First Language:
    English
    Primarily Uses:
    RMMV
    Yeah, just stick it in a .js file and install it into the project.
     
    #6
  7. KaYsEr

    KaYsEr Koruldia Veteran

    Messages:
    208
    Likes Received:
    441
    Location:
    London
    First Language:
    French
    Primarily Uses:
    RMMV
    @SumRndmDde Do you think it would be possible to have an option to toggle this "bilinear filtering" OFF/ON directly from the Option Menu like in the FULLSCREEN plugin you did?


    Thank you for that one, this is how it should be done, giving the choice to the player.


    (I discovered your channel last week and had a video-marathon!... really great stuff.)
     
    #7

Share This Page