EmeraldSpecter

Veteran
Veteran
Joined
Feb 14, 2021
Messages
68
Reaction score
21
First Language
English
Primarily Uses
RMMV
Hey all... I wanted to add a "shadow" to my walkers and battlers for my actors, but they don't seem to have what I added when I go into the game itself. What I'm talking about is:

ActorWalkers.png

I have the unshadowed default on the right but I wanted to add the shadowed one on the left to give a little depth. Same with the battler example below:

ActorBattlers.png

Is there a reason they wouldn't show up in the game that I'm not aware of? It's literally still a PNG, I only added a small, mostly transparent shadow. On the white background it looks really dark but I promise it isn't that dark.
 

Tarzanthecat

(Meow)
Veteran
Joined
Jan 18, 2017
Messages
93
Reaction score
67
First Language
English
Primarily Uses
N/A
Make sure that you updated the image in your resource manager, and that the battler is using the correct sprite.
 

Nowis-337

Veteran
Veteran
Joined
Oct 29, 2019
Messages
65
Reaction score
120
First Language
English
Primarily Uses
RMMZ
What does your whole sprite sheet PNG look like?
What does your character in game with your sprite sheet look like (screenshot would help).
Also, just double check that the correct edited sprite sheet is selected for the character (and the png file is placed in the correct corresponding folder).
 

EmeraldSpecter

Veteran
Veteran
Joined
Feb 14, 2021
Messages
68
Reaction score
21
First Language
English
Primarily Uses
RMMV
These are the sheets that are being used in the correct folder. The whole actors sheet looks like that:
GemscapeWalk2.png

And before I converted all the other actor battlers, I just changed the main actor's battler:
GemscapeElectroaugur2.png
These are the ones chosen in the database right now for this character (this is the only character available at the point in the story I've managed to program to). She's Sparq.

There's just no shadow when I go to the game. It still uses the unshadowed sprite.
 

Nowis-337

Veteran
Veteran
Joined
Oct 29, 2019
Messages
65
Reaction score
120
First Language
English
Primarily Uses
RMMZ
Hmmm, the spritesheets look fine. Do a screenshot on what the editor screen looks like in the actor database - do the preview of selected character sprite, face, sv battler show the shadows?
 

SoftCloud

Aspiring Game Alchemist
Veteran
Joined
Nov 28, 2018
Messages
107
Reaction score
472
First Language
English
Primarily Uses
RMMV
Have you tried restarting the engine? Sometimes assets won't be updated until you do so. I agree with @Nowis-337 the sheets look correct.
 

EmeraldSpecter

Veteran
Veteran
Joined
Feb 14, 2021
Messages
68
Reaction score
21
First Language
English
Primarily Uses
RMMV
Screen Shot 2021-02-25 at 7.12.36 PM.png
I assume you meant this...

And I'd like to report that after having another program needing a reboot, the RPG Maker came back up and suddenly it's showing. So, apparently I should restart when I make an image change, I guess. :)
 

Nowis-337

Veteran
Veteran
Joined
Oct 29, 2019
Messages
65
Reaction score
120
First Language
English
Primarily Uses
RMMZ
Yeah sometimes a reboot will help with updating assets in the editor, but usually running a playtest should work as well.
 

Latest Threads

Latest Posts

Latest Profile Posts

Dev be like: "I'll make the character goes amnesia so I could explain the world and the lore better and immersive to the players"
Whoever decided that the 5th area of Xenoblade 3 had to be THAT big and be explored in the manner it does needs to be shot. My OCD cannot leave a tiny shard of the map hidden and those controls can go right on and f*** themselves. -.-

/rant off
Raggon wrote on NoPatience's profile.
:kaohi:

Forum statistics

Threads
124,435
Messages
1,163,622
Members
163,246
Latest member
BagOfAnts
Top