Joined
Dec 24, 2018
Messages
59
Reaction score
3
First Language
Finnish
Primarily Uses
RMMV
So, I reordered my plugins, after which the game was working fine. Now when I try battle testing against the default bats, I get thefollowing:
snvXelQ.png


In addition, even on a completely fresh project, if I try testing against anything, I just get a black screen with no text.
Already tried re-installing the maker.
 

Silva

Scoobityboo
Veteran
Joined
Nov 5, 2018
Messages
402
Reaction score
226
First Language
English
Primarily Uses
RMMV
Can you provide an image of the console when this is happening?

To access the console press F8 and navigate to the "console" tab at the top of the window that opens.
 
Joined
Dec 24, 2018
Messages
59
Reaction score
3
First Language
Finnish
Primarily Uses
RMMV
Can you provide an image of the console when this is happening?

To access the console press F8 and navigate to the "console" tab at the top of the window that opens.
jE48QVR.png

You need the top of the log?
 

Silva

Scoobityboo
Veteran
Joined
Nov 5, 2018
Messages
402
Reaction score
226
First Language
English
Primarily Uses
RMMV
That's the elements tab. I need the console - it should look like this (yours will have error messages in red):

upload_2019-3-8_18-14-32.png
 

Attachments

  • upload_2019-3-8_18-13-26.png
    upload_2019-3-8_18-13-26.png
    82.9 KB · Views: 6

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,761
Reaction score
8,969
First Language
German
Primarily Uses
RMMV
@The_Black_Knight what is your project's core version?

Please open its rpg_core.js file with a text editor and read the number in the title line to us.
Because this error often happens if you use an extremely old core-version together with some recent plugins.

(and no, the core version is not automatically the same as the editor version, that's why you need to open the file with a text editor)
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,646
Reaction score
15,730
First Language
English
Primarily Uses
RMMV
The core version of the scripts? Open your js/rpg_core.js file and confirm that that also says 1.6.1? My guess is that there may not be any version there at all, which means you have 1.0.0, because that issue stopped happening from 1.3.1 at least.
 
Joined
Dec 24, 2018
Messages
59
Reaction score
3
First Language
Finnish
Primarily Uses
RMMV
The core version of the scripts? Open your js/rpg_core.js file and confirm that that also says 1.6.1? My guess is that there may not be any version there at all, which means you have 1.0.0, because that issue stopped happening from 1.3.1 at least.
I'm not sure what you mean, but I went to check, and in the "NewData" folder the script is actually 1.6.2, and in the project with the "height" issue 1.6.1.
However:
If I make a new project the file is 1.6.2 too, but I get black screens without text. The window wont even have a name, and I can't use F8 to open the console.
These issues appeared at the same time.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,761
Reaction score
8,969
First Language
German
Primarily Uses
RMMV
then please give us a screenshot of your plugin manager with all plugins listed.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,646
Reaction score
15,730
First Language
English
Primarily Uses
RMMV
Not in the NewData folder. In the folder of your project.

You can have many projects all at different versions, if you update MV whenever there's a new version, but you don't also update your project.
 
Joined
Dec 24, 2018
Messages
59
Reaction score
3
First Language
Finnish
Primarily Uses
RMMV
Not in the NewData folder. In the folder of your project.

You can have many projects all at different versions, if you update MV whenever there's a new version, but you don't also update your project.
Yeah, it's 1.6.1

then please give us a screenshot of your plugin manager with all plugins listed.
Wbin4vZ.jpg

They should be in order, I hope, as I just reordered them. Even if I had all the non-yanfly plugins off, I still had the issue.
 
Last edited by a moderator:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,761
Reaction score
8,969
First Language
German
Primarily Uses
RMMV
as I just reordered them
Have you startzed a new game after reordering them?
Whenever you either reorder plugins or turn them off/on, that makes the older savefiles incompatible because part of the plugin data gets stored into them. And then continuing a game that contains that old data can result in a lot of "undefined" errors, simply because the plugin that defined that data has been turned off or is no longer at the expected position.

That said, here is some background info so that you better understand why that error has us asking and doublechecking your project version:
"height" is a property that was introduced in 1.4.0 or 1.5.0 or so to make a lot of things easier - it didn't exist in older versions.
And if a plugin then tried to use this property with older core files, they gave this error because "height" was not yet defined in them.

So whenever that error message came up previously, it was always someone using current plugin versions with a core version 1.3.0 or older.
You are literally the very first case with this error message that has a newer core version.

And I can now only think of two remaining options why you get this error:
1) you have always tested with an old savegame that contained the data of the old core-structure
2) your last update was incomplete and only some of the core files were updated to 1.6.1 (including the rpg_core.js) while others failed to update correctly and are still at pre-1.4
In the second case make a backup and try to update that to 1.6.2 and see if that corrects such a failed update.

correction:
I just thought of a third possibility. Can you go into your project folder and check if it contains a www folder?
Hopefully not because that folder should only exist in a deployed version, never in a project directory - but it would redirect all tests and we would have looked at the wrong folders if that is the case.
If you have a www folder inside your project directory, then delete it and replace your package.json file in the project directory with one from a new project - a failed deployment will create the ww folder and exchange the packages file with the wrong one for the project directory.
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,510
Reaction score
12,012
First Language
English
Primarily Uses
RMVXA
'Tech Support' is for when you cannot get the engine to run.

[mod]As this looks like it is an updating issue, I am moving this to RPGMaker MV. [/mod]
 
Joined
Dec 24, 2018
Messages
59
Reaction score
3
First Language
Finnish
Primarily Uses
RMMV
Have you startzed a new game after reordering them?
.

Okay, things are running for some reason, for now:
I checked the integrity of the files on steam, but it didn't say there was any issues.
Like an idiot I hadn't checked other troops for encounter. It appeared only the troop id 01 caused the issue, I cleared it, and set enemies there again, and boom, it's working.

With the new projects, the old new project still gave me black screens, but I tried out a new new project, and it works.
Maybe someone can questimate what the issue was from that?
 

Silva

Scoobityboo
Veteran
Joined
Nov 5, 2018
Messages
402
Reaction score
226
First Language
English
Primarily Uses
RMMV
My understanding is that an enemy or multiple enemies within the troop had their .bitmap property set to undefined. The bitmap from what I can see is a reference to their spritesheet so for whatever reason this wasn't being picked up correctly. I can replicate your exact problem by adding an enemy to a troop that doesn't have an image set and running a battle test, so I suspect this is what the issue was.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,646
Reaction score
15,730
First Language
English
Primarily Uses
RMMV
could you have deleted some enemies from the troop? Or added some enemies to the troop but then deleted them from the Enemies tab?
 

Latest Threads

Latest Profile Posts

Is RPG Maker VX (rgss2) still relevant? xD
ZyCHqk2.png

Something about top-downs.
I have never felt so attacked by a tree before :LZSlol: it took 10++ hours to make but at least it looks pretty LOL

Untitled-1.png
now seems like the worst time for me to need a better computer with how much stuff is costing. that and I don't thing there's much else I can do to make MV run any better with what I have.
Sigh... to have some variety in this weather. More than just sun and rain and wind and thunder.
In the meantime, I've discovered that I'm slowly becoming fatigued from the many sleepless nights my neighbors cause. Or at least their dogs. Always barking at something.
I might need a day to just sleep and recharge.

Forum statistics

Threads
118,453
Messages
1,116,093
Members
155,431
Latest member
fshwthoutaneye
Top