xlostlightx

Villager
Member
Joined
Jul 26, 2013
Messages
11
Reaction score
0
First Language
English
Primarily Uses
RMMV

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,268
Reaction score
8,722
First Language
German
Primarily Uses
RMMV
"Lag" is a very unspecified term and there are dozens of possible causes

If the lag happens with such a delay and without any parallel process events, then either the problem is with a plugin or it is external like an AntiVirus program trying to block the programs access because it falsely believes that the game is an Internet Website trying to again local access (the game is a local Website, not on the Internet).
 

xlostlightx

Villager
Member
Joined
Jul 26, 2013
Messages
11
Reaction score
0
First Language
English
Primarily Uses
RMMV
"Lag" is a very unspecified term and there are dozens of possible causes

If the lag happens with such a delay and without any parallel process events, then either the problem is with a plugin or it is external like an AntiVirus program trying to block the programs access because it falsely believes that the game is an Internet Website trying to again local access (the game is a local Website, not on the Internet).

Sorry about that! I meant that the game suddenly begins running slowly. Sprite movements, battle processes, opening/closing menu, etc all suddenly go slowly.

I've turned off most of my plugins, and that didn't help. I'll see what to do about the antivirus part.
 

AuralPC

Veteran
Veteran
Joined
May 25, 2018
Messages
48
Reaction score
14
First Language
Chinese
Primarily Uses
RMMV
Have you tried to create a brand new project with nothing in it and played with it?

Will the brand new project still be lagging?
 

xlostlightx

Villager
Member
Joined
Jul 26, 2013
Messages
11
Reaction score
0
First Language
English
Primarily Uses
RMMV
UPDATE//////
I didn't try creating a new game, but deleting some old plugins I got in ~2015 seemed to do the trick. Everything works fine now except that there's now this thing where battles start fine then suddenly get slower after a few seconds. This happens both ingame - where subsequent battles START and remain slow - and within battle testing.

I'm. not sure what to do o<-<

UPDATE 2////////
me: maybe they're slow because my plugins are like 2 years outdated. lemme update
result:
Capture.PNG
I MADE IT WORSE

UPDATE 3////////
updated rmmv manually and everything seems fine now @v@/
 
Last edited:

Latest Threads

Latest Profile Posts

I'm listening to iiluminaughtii talking about the secrets behind shady businesses and scams. Meanwhile I'm writing a fanfic about Sephiroth from FF7, one specifically for my stepmom. I'll get to give it to her, too, because my boss said I could take the holidays off! Dec. 22-27 I will be in Orlando, and maybe Fort Myers too, visiting my dad and stepmom!
Of course, I bought a handful of games on the Steam Black Friday sale. Will I try them? Will I complete any? Who knows...
I don't really have any neat updates today about how I screwed up programming... But if you want to observe the intensenes of me programming, then you can check out my stream :)
New Weapons.gif
No more spam from me today, I promise! Just wanted to upload this, people have been giving me feedback that my weapon sprites (which were RTP) clashed badly with my battlers for ages, so today I finally took the plunge and updated them! Really happy with how they came out :D :D
So Facebook fraudulently took money from me. They even went through my PayPal accounts to find a card that had the money on it. Thinking about deleting my Facebook account because this doesn't happen on twitter, not even close.

Forum statistics

Threads
117,001
Messages
1,103,712
Members
152,895
Latest member
tmsvan
Top