[RMVXA] Victor's Step Sound Engine - Problem with execution

Discussion in 'RGSSx Script Support' started by CarlosDavilla, Aug 18, 2018.

  1. CarlosDavilla

    CarlosDavilla The Insolent One Veteran

    Messages:
    55
    Likes Received:
    5
    First Language:
    Portuguese
    Primarily Uses:
    RMVXA
    Hello. Here I am once again.

    Today I have a problem with the Victor's Step Sound Engine Script.
    You see, I put the script and the region tiles on the map, then I selected the sound. When I was going to test it on the game, the game just lags before I move.

    For example:

    I press the right arrow key to move, my selected footstep sound plays, then my player actor move.

    Any way to solve this? I've tested with Galv's script as well, but it occurs the same problem.
     
    #1
  2. Sixth

    Sixth Veteran Veteran

    Messages:
    2,130
    Likes Received:
    800
    First Language:
    Hungarian
    Primarily Uses:
    RMVXA
    What format is your sound file?
    Try to play that sound using regular event commands and see if it makes a lag-spike than too or not.
    If it does, than it is a "problem" of playing that certain sound file type on your system. Try to install some new audio drivers or codecs, or change the file type to something else.

    If it doesn't lag with the regular event command, than it can be a script problem. Although I didn't experience anything like this with Galv's script, so I doubt that it comes from that script. Do you use any other custom scripts, maybe something that changes audio processing?
     
    #2
  3. CarlosDavilla

    CarlosDavilla The Insolent One Veteran

    Messages:
    55
    Likes Received:
    5
    First Language:
    Portuguese
    Primarily Uses:
    RMVXA
    Yes, that was totally the case.
    I manage to get it to work by changing the audio format from .wav to .ogg. Now it works like a charm.
    Thanks for the help. This thread can be closed now.
     
    #3

Share This Page