RPG Maker 2000 and 2003 General Bug Reports Thread

Joined
Jun 14, 2012
Messages
6
Reaction score
0
First Language
英語
Primarily Uses
Holy!!!!!!!!
I just got back to working with RPG Maker 2000 and... WOW, DXGL fixes the problem!!!
I can deal with this for now. But can't there be an in-engine fix for this?
Is it not possible that a custom DLL or Game Launcher can be made to change how RPG Maker 2000 games boot?
I really wouldnt want to have to tell everyone to install DXGL just for my game...

THANK YOU KAMILLO!!
It worked for me as well. Only problem is that you can't switch between fullscreen and windowed by pressing F4 (unless there's some setting in DXGL that enables this, but I haven't been able to find it). And yes, I agree with you that it'd be nice if there were an in-engine fix.

Edit: Another issue is with playing movie files (which Kamillo mentioned). It crashes the game for me.
 
Last edited:

jay_are

Veteran
Veteran
Joined
Apr 26, 2015
Messages
71
Reaction score
15
First Language
English
Primarily Uses
That is indeed a problem I found too, you kinda have to choose what you're gonna use...
I like fullscreen better, and I almost never use window mode. It does suck that the program is not completely compatible, but what it does is already a miracle to me. I expect that since they're only at version 0.5.15, that they would make it fully compatible later.
We probably need to contact the developer. PROBABLY. I'll try that soon.
 

Tayruu

・ ゚*。・゚(幸)
Veteran
Joined
Apr 27, 2014
Messages
38
Reaction score
61
First Language
English
Primarily Uses
RM2k
In RM2k 1.62, the text for the Picture Settings is the wrong way around: Rotation is displayed for Wave, and vice-versa.



Additionally, the bug from 1.60/1.61 about Show Battle Animation in troop events still exists.
A bit of a minor and unusual bug in RM2k (v1.61 non-Steam): it seems the rendering for Show Battle Animation is broken for battle events. It displays in the editor as follows:
Code:
@> Show Animation: [NAME], [X: ?],
NAME: Name of battle animation.
X: ID of battle animation + 1
?: Just "?".
(Note it may also be appended by "Wait", though that trailing "," is there regardless.)

What should really be displayed instead of [X: ?] is the target, or Entire Troop.
EDIT: oops I discovered some weird new thing, still RM2k, no point in double-posting about it though.
I can scroll the Fight/Auto/Escape battle menu while the "escape successful" message is on-screen? If I hold up/down while it's displayed, I can hear the menu sound effect.
 
Last edited:

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,290
Reaction score
11,694
First Language
English
Primarily Uses
RMVXA
@superman This thread is for reporting bugs in the engine, not bugs in a game. As you have opened a Support thread asking the same question, I have deleted your post from here.
 
Joined
Jun 14, 2012
Messages
6
Reaction score
0
First Language
英語
Primarily Uses
I'm not sure if this is a bug, but it is something strange I noticed.

RPG Maker 2003 1.12a: When editing Troops in the Database, the condition to trigger a Battle Event when the player or enemy's HP is between a certain percent seems to only sometimes trigger right away when the condition is met, while other times there's a delay where it only happens after another character uses a move. After editing various different things to try and find out what's causing it, the cause seems to be the amount of frames of the animation that causes the condition to be met. But even then it's not a guarantee since sometimes the event will trigger regardless. I've made a video showcasing this here:


However, in the unofficial version of RPG Maker 2003, the event triggers immediately 100% of the time as far as I can tell.

Another note about the fullscreen issue in RPG Maker 2000 1.62 that I posted about earlier: It seems to work the same way as the "DirectDraw (for older machines)" setting in the video options of RPG Maker 2003 1.12a. I can just use GDI, but there's no such option in 2000. Though I still find it strange that the unofficial versions of both 2000 and 2003 worked fine in fullscreen, even on my modern(-ish) machine, yet the official ones don't (outside of GDI mode in 2003).
 
Last edited:

booberpls

Uh Oh, Stinky
Member
Joined
Jun 30, 2020
Messages
1
Reaction score
5
First Language
English
Primarily Uses
RM2k3
So uh,,, I noticed that there's a possible bug in RPGmaker2003 1.12a? Basically, when an Enemy appears midway battle and you have some Fancy sound effects and even One(1) flash, then it just keeps going, repeating and repeating over and over again?

STINK.PNG

Sorry if this was already talked about or if it's actually not a bug !!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Staring at all the RPG Maker versions I have and realizing that my project has been a long time coming. But, I finally feel like I have the knowledge and experience to make it into something good.
We're almost done with the jam game! :D
I get scam calls all the time so today I gave them a piece of my mind. They hung up on me. Sweet revenge.
There’s a beehive in my wall

Forum statistics

Threads
104,319
Messages
1,005,532
Members
135,842
Latest member
Nagamatsu1945
Top