RPG maker 2003 won’t run/play test

Discussion in 'RPG Maker 2000/2003' started by Emanzi, May 16, 2018.

  1. Emanzi

    Emanzi Veteran Veteran

    Messages:
    34
    Likes Received:
    9
    First Language:
    English
    Primarily Uses:
    RMMV
    ***SOLVED***

    Whenever I try and play test I get a white screen and then the game crashes. This happens for battles and normal play testing as well.

    My specs are
    Operating System: Windows 10 Pro 64bit
    Processor: Intel Celron CPU N2840 @ 2.16GHz (2CPUs) 2.2GHz
    Direct X Version: 11.2
     
    Last edited: May 17, 2018
    #1
  2. Faherya

    Faherya The Knight of the Sad Figure Veteran

    Messages:
    194
    Likes Received:
    467
    Location:
    Brazil
    First Language:
    Português
    Primarily Uses:
    RM2k3
    I think RPG Maker 2003 no longer works well on Windows 10, unfortunately.
     
    #2
  3. CleanWater

    CleanWater Indie Dev Veteran

    Messages:
    540
    Likes Received:
    623
    Location:
    Brazil
    First Language:
    Pt-BR
    Primarily Uses:
    RM2k3
    I have RM2k3 and it runs fine on my Windows 10.

    Is there any more info you can give about your project?
     
    #3
  4. kaine

    kaine Veteran Veteran

    Messages:
    109
    Likes Received:
    49
    First Language:
    Italian
    Same here!
    @Emanzi Which version? steam or from the store?
     
    #4
  5. Emanzi

    Emanzi Veteran Veteran

    Messages:
    34
    Likes Received:
    9
    First Language:
    English
    Primarily Uses:
    RMMV
    I bought rpg maker 2003 from the store not steam. The project is absolutely new just the default stuff when you start a new project.

    Do you think maybe it’s a 32bit version or something or could it be my video card compatibility?
     
    #5
  6. CleanWater

    CleanWater Indie Dev Veteran

    Messages:
    540
    Likes Received:
    623
    Location:
    Brazil
    First Language:
    Pt-BR
    Primarily Uses:
    RM2k3
    @Emanzi, my PC specs are identical to yours, except that my processor is a bit slower.
    For my graphics card, I use the Integrated Intel Graphics Card in the motherboard.

    Did you tried to re-install the maker? You installed the correct RTP? Are you running it with any other (heavy) software also open?
     
    #6
  7. Dungeonmind

    Dungeonmind Lvl 4000 Humanoid Veteran

    Messages:
    370
    Likes Received:
    188
    Location:
    Canada,Ontario
    First Language:
    English
    Primarily Uses:
    RMMV
    Also try running it in compatibility mode for xp and windows 7 ?
     
    #7
    kaine likes this.
  8. Emanzi

    Emanzi Veteran Veteran

    Messages:
    34
    Likes Received:
    9
    First Language:
    English
    Primarily Uses:
    RMMV
    I re-installed RPG Maker 2003 and I installed the RTP and now everything works great.. Thanks
     
    #8
    Dungeonmind, CleanWater and Faherya like this.

Share This Page