Status
Not open for further replies.

Lord Vectra

Master Eventer
Veteran
Joined
Dec 6, 2015
Messages
239
Reaction score
348
First Language
English
Primarily Uses
RMVXA
It's not lagging in-game. It's in the editor where it gets weird. When I go to the database, it takes it awhile to open, and if I click to move to any tabs, its slow. When I try to open an event, it's also slow. It's not like this all the time, but I don't know what's causing it, and it's happening on all the RPG Makers. I tried putting it in compatibility mode for Windows7, XP, and Vista while also having it open as administrator.

Any other ideas?
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,728
Reaction score
8,511
First Language
German
Primarily Uses
RMMV
the most common cause of this is a too large tileset. That is actually the reason why no maker after XP allowed unlimited size tilesets anymore.

that said, it is definately some resource problem with too much data, so if it is not the tileset then start looking where else you're using large pictures or large sounds or extreme data numbers.

EDIT:
Did you edit out the reference to RMXP?
Which maker are you actually using with that problem?
 

Lord Vectra

Master Eventer
Veteran
Joined
Dec 6, 2015
Messages
239
Reaction score
348
First Language
English
Primarily Uses
RMVXA
the most common cause of this is a too large tileset. That is actually the reason why no maker after XP allowed unlimited size tilesets anymore.

that said, it is definately some resource problem with too much data, so if it is not the tileset then start looking where else you're using large pictures or large sounds or extreme data numbers.

EDIT:
Did you edit out the reference to RMXP?
Which maker are you actually using with that problem?
I was originally using XP, but I tried it on a clean project with XP and Vx Ace and both are doing the same thing.
 

Willibab

The Lord of Whackery
Veteran
Joined
Jun 22, 2017
Messages
247
Reaction score
807
First Language
Norwegian
Primarily Uses
RMMZ
Is the rest of your pc working as usual while it happens? I sometimes get the nwjs problem. It hogs memory like crazy, slowing down my pc. Maybe check task manager while it happens?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,728
Reaction score
8,511
First Language
German
Primarily Uses
RMMV
both are doing the same thing.
in that case my guess would be a background program trying to block them, like a false positive from an antivirus or a background capture program trying to record all "steam-games" even if the editor isn't a game.

@Willibab RMXP and RMVXA don't use nw.js (or javascript) at all.
 

Lord Vectra

Master Eventer
Veteran
Joined
Dec 6, 2015
Messages
239
Reaction score
348
First Language
English
Primarily Uses
RMVXA
in that case my guess would be a background program trying to block them, like a false positive from an antivirus or a background capture program trying to record all "steam-games" even if the editor isn't a game.

@Willibab RMXP and RMVXA don't use nw.js (or javascript) at all.
Still lags. I tried running it as administrator and running it in Windows 7 Compatibility mode, but is seems to lag still - even on a fresh one. I disabled my antivirus and closed everything :/
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,728
Reaction score
8,511
First Language
German
Primarily Uses
RMMV
I disabled my antivirus and closed everything
I specifically mentioned that video capture case to point out that the background can be some other program. The video-capture was installed by the display driver setup and the computer owner didn't even know it was running at all.

That said, you didn't give enough data to even guess more precisely what else it might be.
at minimum we would need the technical specifications of your computer and what else you have running in the background to guess what lag can be caused by what.
 

Lord Vectra

Master Eventer
Veteran
Joined
Dec 6, 2015
Messages
239
Reaction score
348
First Language
English
Primarily Uses
RMVXA
I specifically mentioned that video capture case to point out that the background can be some other program. The video-capture was installed by the display driver setup and the computer owner didn't even know it was running at all.

That said, you didn't give enough data to even guess more precisely what else it might be.
at minimum we would need the technical specifications of your computer and what else you have running in the background to guess what lag can be caused by what.
Processor AMD Ryzen 9 3900X 12-Core Processor 3.79 GHz
Installed RAM 32.0 GB
Device ID CA25A27E-03C8-45A4-81B0-79303DCE697D
Product ID 00325-82057-83082-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display
Display Adapter NVIDIA GeForce RTX 3090

These are the PCs specs. I don't know exactly what or how you want me to show the background part since I closed everything via Task manager and the "Show hidden icons" button which also shows programs running in the background. SO I'm not exactly understanding what you're asking for.

EDIT: I'm an idiot. I think it was lagging because I haven't ever restarted/turned off my PC in the past few days. Of all the things to do, I didn't do the basic "Turn it off and on" lol. Thanks though; it works just fine now.
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,728
Reaction score
8,511
First Language
German
Primarily Uses
RMMV
The processor and RAM were the important parts, and with those numbers what you experience is definately not processing lag - those numbers are top of the line and more than enough to handle anything the editor and most background programs could demand. Unless you have opened a CAD program or photoshop with an extra-large image processing at the same time as working on RM ;-)

The only thing I can currently think it might be is access lag. The editor has the database files constantly open to speed up processing the database, but if anything slows down your harddrive at the same time or tries to access the same files it might cause something like you described.

What is the exact folderpath to where you stored your project?
Do you use any automated backups, cloudsyncs or anything that forces a lot of HDD operations?

EDIT:
I just read your last edit which wasn't there when I wrote the answer above.
Sounds like I was on the right path just not the right cause - even with large physical RAM Windows still needs virtual RAM, and that is created by files on the harddrive. And the longer Windows is in operation the more fragmented those virtual RAM files get on the HDD...
 
Last edited:

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
8,947
Reaction score
5,856
First Language
Dutch
Primarily Uses
RMXP

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

gotta love when a plugin you thought had nothing to do with why something else wasn't working winds up being the issue...
Doing RPG Maker News for 26th September 2021

Well... it's been a while since I was last here :kaoswt: I don't want to say I'm officially 'back' yet, but I've recently started working with RM again, so I might become active here again :kaohi:
Mmmm I love Coca Cola candy! :kaoluv:
aaaand my power is out. I sometimes think that I'm cursed.

Forum statistics

Threads
115,388
Messages
1,089,517
Members
150,123
Latest member
lauram22
Top