Status
Not open for further replies.

Victor Sant

Veteran
Veteran
Joined
Mar 17, 2012
Messages
1,694
Reaction score
1,457
First Language
Portuguese
Primarily Uses
There us a place where I can find full referece on the codes changed on the core scritps?

I know the event page has "change player's name" but doesn't have the custom name input, like please enter your name kinda thing.... wonder if it could be added next update or so thanks and great work on the Dark Theme, it helps my eyes.

You mean like the command 'Name Input Processing...' on the 3rd page of the event commands?
 
Last edited by a moderator:

silvermoon27

Member
Veteran
Joined
Sep 29, 2015
Messages
55
Reaction score
8
First Language
Dutch
Primarily Uses
RMMV
(I corrected grammer, sorry, it's a bad habit)

* grammar XD (Ok sorry I couldn't NOT do that. Now I feel guilty.)


Nice update! Though I'm getting some lag with one of my plugins with the flickering windowskin-ish thing (wait- was that a new feature...?) The dark theme is really awesome when you're making a dark dungeon!
 

Trickster

Villager
Member
Joined
Feb 11, 2013
Messages
10
Reaction score
0
First Language
English
Primarily Uses
Anyone who own MV on steam, did your game updated twice? I got the 1.2.0 update around 9:00am to 12:00pm. When I sign into steam at 8:51pm, the game updated itself once again. The second update was 2.5mb.
 

Kaliya

// Caffeine Overload
Developer
Joined
Nov 1, 2015
Messages
506
Reaction score
567
First Language
English
Primarily Uses
RMMV
We had to emergency update the JS core files (rpg_NAMEHERE.js) for a few reasons, that was probably the update.
 

Trickster

Villager
Member
Joined
Feb 11, 2013
Messages
10
Reaction score
0
First Language
English
Primarily Uses
Did that update do any changes to the exe? just making sure steam didn't screw up again
 

Kaliya

// Caffeine Overload
Developer
Joined
Nov 1, 2015
Messages
506
Reaction score
567
First Language
English
Primarily Uses
RMMV
Just to the JS files, just copy those to your project again. I apologize for the inconvenience it may have caused. 
 

Trickster

Villager
Member
Joined
Feb 11, 2013
Messages
10
Reaction score
0
First Language
English
Primarily Uses
No worry, the date on the exe was 21/04/2016 8:51pm, which kinda made me worry if steam screw up again.
 

Bastrophian

The Pixel Heartist!
Veteran
Joined
Oct 26, 2013
Messages
3,833
Reaction score
2,103
First Language
English
Primarily Uses
Other
I was just looking at the new gen parts that were added in the last update, particularly the "cowboy" hat that obscures the eyes a little. I was wondering is that was infact supposed to be a cowboy hat? Cuz looking at the version made for the map sprite, it looks to like a hat a noir (did i spell that right?) type detective might use...just curious. 
 

JoePie

of Art/Game
Veteran
Joined
Jun 9, 2014
Messages
170
Reaction score
226
First Language
Not English
Primarily Uses
Hey mate, my RMMV was updated through Steam, then copy/paste all JS in root folder except plugin.js into main project, and this message popup before Title showup. Rpg_core, rpg_manager and Pixi.js was mentioned in the conflict message. Tried to update Pixi to lastest JS but in no avail. Please advise? Cheers.


View attachment 36875
 
Last edited by a moderator:

nio kasgami

VampCat
Veteran
Joined
May 21, 2013
Messages
8,970
Reaction score
3,080
First Language
French
Primarily Uses
RMMV
Hey mate, my RMMV was updated through Steam, then copy/paste all JS in root folder except plugin.js into main project, and this message popup before Title showup. Rpg_core, rpg_manager and Pixi.js was mentioned in the conflict message. Tried to update Pixi to lastest JS but in no avail. Please advise? Cheers.


View attachment 36875

because PIXI didn't got updated ...why did you updated to his latest???


archeia already stated that's would be only in V.1.3 that's will get updated
 

Kaliya

// Caffeine Overload
Developer
Joined
Nov 1, 2015
Messages
506
Reaction score
567
First Language
English
Primarily Uses
RMMV
Hey mate, my RMMV was updated through Steam, then copy/paste all JS in root folder except plugin.js into main project, and this message popup before Title showup. Rpg_core, rpg_manager and Pixi.js was mentioned in the conflict message. Tried to update Pixi to lastest JS but in no avail. Please advise? Cheers.

Could you post your rpg_core.js file for me to look at, please post it on http://pastebin.com/ and post the link.

because PIXI didn't got updated ...why did you updated to his latest???


archeia already stated that's would be only in V.1.3 that's will get updated

If you read what he said, he said he tried to update Pixi after the error occurred, him updating pixi isn't the cause of this error potentially.
 

nio kasgami

VampCat
Veteran
Joined
May 21, 2013
Messages
8,970
Reaction score
3,080
First Language
French
Primarily Uses
RMMV
Could you post your rpg_core.js file for me to look at, please post it on http://pastebin.com/ and post the link.


If you read what he said, he said he tried to update Pixi after the error occurred, him updating pixi isn't the cause of this error potentially.

yeah I noticed later I'm sorry for that I was just unable to edit my post with my sh*tty internet I mean it's took almost 30 seconds just for open RMW '-'"..sooo
 

txtk

Veteran
Veteran
Joined
Jul 10, 2014
Messages
115
Reaction score
35
First Language
Vietnamese
Primarily Uses
This is great. Hopefully we'll have final stable version soon.
 

JoePie

of Art/Game
Veteran
Joined
Jun 9, 2014
Messages
170
Reaction score
226
First Language
Not English
Primarily Uses
Last edited by a moderator:

Kaliya

// Caffeine Overload
Developer
Joined
Nov 1, 2015
Messages
506
Reaction score
567
First Language
English
Primarily Uses
RMMV
Here you go RPG_CORE @Liquidize! Thanks for your time too! 


Nar no worry. I used to spent 30min to open RMMV, you know, Steam update  B)

Try recopying the files from the NewData folder, including the libs directory, overwriting your pixi.js. Let me know if that error still occurs.
 

JoePie

of Art/Game
Veteran
Joined
Jun 9, 2014
Messages
170
Reaction score
226
First Language
Not English
Primarily Uses
Try recopying the files from the NewData folder, including the libs directory, overwriting your pixi.js. Let me know if that error still occurs.



Whoops! For some reason it working now! I wonder how you figured the way out? Cheers!


Actually it's not... Didn't realized that I play the Backup project. No difference at all, with same Error message.


When you stated "NewData Folder" I wondered is it /Data?


I only copy/paste all file under JS folder including libs directory, but not plugin.js and plugin directory as instructed. Let me know if I did anything wrong. Cheers.
 
Last edited by a moderator:

Bogsy

Veteran
Veteran
Joined
Oct 25, 2015
Messages
42
Reaction score
14
First Language
English
Wow I just noticed this update now.


I'm loving the dark theme, easier on the eyes while I work on my project!
 

gRaViJa

Veteran
Veteran
Joined
Mar 16, 2012
Messages
971
Reaction score
621
First Language
Dutch
Primarily Uses
RMMV
I'm having the same problem as JoePie. It only seem to happen on new maps I create since after the update. Also, my pixi version is 2.2.9, updating pixi to v2.2.10 didn't solve it:


error.png



my rpg_core file: http://pastebin.com/q6MNySLv


And to prove YED_Tilemap is not the reason for this error, i disabled that plugin and same error:


error2.png



When i switch back to 1.1 everything works as it should again. This is a rather big bug in 1.2...


Another edit: So i tried some stuff switching back between 1.1 and 1.2 and now one map that threw the error before does work as it should. However, if i make another new map in 1.2 it fails again and shows the above error again. It really look like once it identifies the map was made with 1.2 it throws an error. maps made within 1.1 however are deemed okay. Weird.
 
Last edited by a moderator:

NeoPGX

~ King of Cuteness ~
Veteran
Joined
May 15, 2014
Messages
864
Reaction score
187
First Language
English (US)
Primarily Uses
N/A
I'd really love to see the dark theme get added in all of the older RPG makers if possible.
 
Last edited by a moderator:
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

I'm familiar with MZ thanks to jam now. I say it's a better working and looking MV. Lots of plugins too and FOSSIL helps alot. It's not bad.
Some more progress <3 and in most important news:
ALPACARAPTOR SPRITE! (not animated yet, though :( )
h4u90Sz.png
Caz
At the risk of giving myself even more work to do, I kinda wanna redraw the faces of the MV RTP to be a little less.. uhhhhh..

mv-redraw.png
Hmm...you'd think in this day and age, what with Japanese Schoolgirls frequenting anime, JRGs and whatever else...that someone might have made some gym clothes for the generator. You know, the ones with the short bloomers.
finished the draft of some of this dude's motions!

mc0xoB4.gif


gonna work on the drafts of the other 3 now before i put detail, need to position these rather tall sprites well on the field

waiting for the term to end so i can get more time w this :kaodes:

Forum statistics

Threads
113,640
Messages
1,076,374
Members
147,659
Latest member
Fountairpg
Top