Status
Not open for further replies.

HeroicJay

Veteran
Veteran
Joined
Jun 23, 2014
Messages
330
Reaction score
181
First Language
English
Primarily Uses
RMMV
I'll pick a track from my demo (you can download the demo yourself to get access to the track; it's in my signature). The one I am choosing is a short one: "Victoriousness.ogg".


File size: 310 KB


Length: 866,596 samples, about 19.65 seconds.


LOOPSTART: 158430


LOOPLENGTH: 587958


44100 Hz


16-bit PCM, not that I know what that means.


That a good start? Or, again, it's in my demo.


Oh, and I just confirmed that it happens to Battle1 in the normal MV files as well. I didn't hear it in Field1 because it turns out Loopstart there is "8", and 8 samples is so short I probably just didn't notice.


EDIT: I'm investigating as best I can. It looks like, in the function "WebAudio.prototype._onXhrLoad" in rpg_core, the length of "array" is never defined. This causes the loop comment reader to get skipped entirely. Not sure yet why it's not defined.
 
Last edited by a moderator:

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
525
First Language
English
Primarily Uses
N/A
  1. Did you try Intel XDK ?

  2. Didn't had this problem, some people had it and correct it by making correct update : main plugin file, lib folder and index.HTML file... Or what he said. XD

  3. Never had such crashes, before or after update version of MV...

  4. Don't have it either.

Well, based on your plugin (that you added), your version of MV (Steam or not) and your PC basic config, maybe someone could figures out why you have so much issues.



1) No, I did not try Intel XDK, I ported the Android Version using the steps found in the official RPG maker helper file. Is there a video or site with clear directions that I can follow to port the Android version using Intel XDK? Can you provide a link? Thanks.


2) I tried finding the text "Decrypter.REMAIN (8456)" in the rpg_core.js file. I could not find it, the numbers "8456" do not even appear. There were lines similar to that like "Decrypter.REMAIN = "0000000000";" but thats it. 


Its interesting to note that if I use encryption on my Mac it seems like it works just fine (it doesn't work at all on my pc)! However, upon closer inspection, it doesn't work. The Mac version simply includes all the original .OGG and .PNG files alongside the .RPGMVO files. Its still broken.


3) Perhaps its a script issue. I use mainly Yanfly plugins. I will test this theory out at work tomorrow. 


4) Perhaps also a script issue. I will conduct further testing.


SO besides the Intel XDK Android instructions, the encryption problem still remains. 
 

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
@HeroicJay : I'll check it this morning.


@KillerGin : I didn't see anyone making it functionning, and honestly, I didn't test it so far. Since your using YEPcoreEngin, could you set the "debug" option to true and then send what it said in the debugging consol ?


Beware, that's slows down the gamestart.
 
Last edited by a moderator:

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
525
First Language
English
Primarily Uses
N/A
@HeroicJay : I'll check it this morning.


@KillerGin : I didn't see anyone making it functionning, and honestly, I didn't test it so far. Since your using YEPcoreEngin, could you set the "debug" option to true and then send what it said in the debugging consol ?


Beware, that's slows down the gamestart.



How does turning on the debug console help with the encryption issue?
 

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
Well, I was thining about that particular issue, still, you might see warning message that could explain it. Or something else.


I already report an issue with the buffer size, though.
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
525
First Language
English
Primarily Uses
N/A
Its interesting to note that on start up the console does report this:


WebGL: Invalid_Value: bufferData: size == 0        pixi.js:2900
 

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
Its interesting to note that on start up the console does report this:


WebGL: Invalid_Value: bufferData: size == 0        pixi.js:2900

That's what I've already said to @Archeia... Anything else on your side ?
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
525
First Language
English
Primarily Uses
N/A
That's what I've already said to @Archeia... Anything else on your side ?



No, thats it.  So 2 things: 


1) The encryption is still broken, "I tried finding the text "Decrypter.REMAIN (8456)" in the rpg_core.js file. I could not find it, the numbers "8456" do not even appear. There were lines similar to that like "Decrypter.REMAIN = "0000000000";" but thats it."


The Mac encryption seems like it works but its also broken, it just includes all files (ogg, png, and rpgmvo, its weird that the PC deployment works differently). 


I am using the STEAM version, I don't know if that helps or changes anything. 


2) Did anyone get RPG Maker 1.3 to work with intel XDK? Anyone get RPG maker to work well on Android ever? Or am I the only crazy guy that is still trying/hoping that RPG maker will work on Android someday? 
 
Last edited by a moderator:

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
Since it take's time, I'll compile a new one later.


I can't help you with broken encryption, but on Geany, I easly find the line and the bunch of "0". Not sur what to do with it.


Differents OS have differents Core to work with, so the "exe" file doesn't work the same way on both. So the compiling isn't the same, and the same should apply for the encryption. I guess...


Steam version has been reported as more buggy. Still, I've got it too, with no issue sor far, with an strange exception, inside lunatic code.
 
Last edited by a moderator:

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
210
Reaction score
129
First Language
Gibberish
Primarily Uses
RMMZ
No, thats it.  So 2 things: 


1) The encryption is still broken, "I tried finding the text "Decrypter.REMAIN (8456)" in the rpg_core.js file. I could not find it, the numbers "8456" do not even appear. There were lines similar to that like "Decrypter.REMAIN = "0000000000";" but thats it."


The Mac encryption seems like it works but its also broken, it just includes all files (ogg, png, and rpgmvo, its weird that the PC deployment works differently). 


I am using the STEAM version, I don't know if that helps or changes anything. 


2) Did anyone get RPG Maker 1.3 to work with intel XDK? Anyone get RPG maker to work well on Android ever? Or am I the only crazy guy that is still trying/hoping that RPG maker will work on Android someday? 

Change "Decrypter.REMAIN = "0000000000"; to "Decrypter.REMAIN = "0000000020"; and try that. someone found that to be a tempfix for now on encryption. Can't say anything about the Mac side of things as I don't own a mac. to test on.

Since it take's time, here a sample XDK on the previous version of my main project. I'll compile a new one later one.


Doesn't really look like that anymore, XD


I can't help you with broken encryption, but on Geany, I easly find the line and the bunch of "0". Not sur what to do with it.


Differents OS have differents Core to work with, so the "exe" file doesn't work the same way on both. So the compiling isn't the same, and the same should apply for the encryption. I guess...


Steam version has been reported as more buggy. Still, I've got it too, with no issue sor far, with an strange exception, inside lunatic code.

Your link doesn't work, you will have to upload the zip file somewhere.
 

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
I'm remaking a new link, that was on old one.


But it'll take one houre or more...
 

XVoid

Conceptual Severance Mage
Veteran
Joined
Apr 22, 2016
Messages
49
Reaction score
25
First Language
English
Primarily Uses
RMMZ
I've come across a rather interesting and frustrating problem regarding this update. Basically, all plugins that allow elemental absorption functionality (both the two by Yanfly and the one by Hime) stopped working entirely starting the same day this update got installed by my Steam client. I haven't done extensive testing, but I do know that they were working fine the day before, and they just suddenly stopped at the same time that the update happened. There's nothing wrong with my note tags, I've checked that at least a dozen times by now.


It really sucks because elemental absorption was a key aspect of the main character of my current project. And I am not just going to accept that it won't work and move on, because that's basically giving a big middle finger to a character I've spent months developing. Does anyone here know of a way to downgrade RPG Maker MV to an older version if you got it through Steam and keep it from automatically updating again? At this point I'm even willing to buy the engine a second time through another source and then downgrade that if it's what I have to do.
 
Last edited by a moderator:

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
Well, if didn't update your game (folder) you should be fine...
 

XVoid

Conceptual Severance Mage
Veteran
Joined
Apr 22, 2016
Messages
49
Reaction score
25
First Language
English
Primarily Uses
RMMZ
Well, if didn't update your game (folder) you should be fine...



I would be inclined to believe that were true if it weren't for the fact that all the evidence I've gathered points against it.
 

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
What do you mean ? Normally, has said above (1st page), the update of an "previous" project have to be done manually.
 

XVoid

Conceptual Severance Mage
Veteran
Joined
Apr 22, 2016
Messages
49
Reaction score
25
First Language
English
Primarily Uses
RMMZ
What do you mean ? Normally, has said above (1st page), the update of an "previous" project have to be done manually.



To clarify, I haven't updated the game folder, but I have been deploying the project repeatedly to fix bugs that my beta players were finding. Which is what makes this so weird: the only thing that's changed is that the engine updated, which shouldn't affect older projects, yet suddenly, at the exact time that this factor changed (I noticed it within an hour or so of the update during a playtest), without any input from me, the plugins for elemental absorption stopped working entirely.
 

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
210
Reaction score
129
First Language
Gibberish
Primarily Uses
RMMZ
Can someone explain to me what the Additional Fantasy Sample database does?

It's just a small prefilled database similar to VX and older beginning databases. It's optional and you have to manual add the files from the folders NewData_FantasyEN or NewData_FantasyJP into a new project. I go over it in my video here 








 about 12 minutes in, WARNING: I recorded this far louder than I wanted to. XD Headphone users beware. ;-; i'm loud.
 

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
I confirme the element issue. Strange indeed.


Sadly, the plugin option doesn't work, but <Custom React Effect> with if (this.item().damage.elementId === elementID) {target.gainHp(value)} </Custom React Effect> still work perfectly...


Here a plugin you might want to try : http://himeworks.com/2015/12/elemental-negation/
 
Last edited by a moderator:

XVoid

Conceptual Severance Mage
Veteran
Joined
Apr 22, 2016
Messages
49
Reaction score
25
First Language
English
Primarily Uses
RMMZ
I confirme the element issue. Strange indeed.



Well, at least now that it's confirmed, I'll be taken seriously. So should I go report this to the developers of the relevant plugins so they can fix it, or...?


And in the meantime, until at least one of them comes up with a fix for whatever the new problem is, about downgrading a Steam-bought MV to an older version... is it even possible? And if so, how do I go about doing it?
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

About the Deer, I had to cut some piece of video due the *swearing* Youtube copyrights issues...
A caveman pokes his head in...
I was listening to songs by Chuck E Cheese's voice actor (Jaret Reddick from Bowling for Soup) when the meds I was taking for my stomach virus apparently stopped working. I can't take my next dose until morning, but it's no use anyway. I'm officially sick again. Of course, I'll definitely take the next dose either way, but it's useless now.
New profile picture! This time, it's representative of my current project.
I suddenly feel like making a game for little kids: a pointless sandbox of cute animals, silly collectibles, and random mini games.

Forum statistics

Threads
116,003
Messages
1,094,815
Members
151,306
Latest member
rpgLord69
Top