RPG Maker MV 1.3.0 Update!

Status
Not open for further replies.

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
On steam it might be hard...


For reporting to Yanfly. Yes, certainly.
 

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
207
Reaction score
116
First Language
Gibberish
Primarily Uses
Well, at least now that it's confirmed, I'll be taken seriously. So should I go report this to the developers of the relevant plugins so they can fix it, or...?


And in the meantime, until at least one of them comes up with a fix for whatever the new problem is, about downgrading a Steam-bought MV to an older version... is it even possible? And if so, how do I go about doing it?
A lot of plugins were broken from the update, give it some time, let the plugin devs catch up to the update.
 

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
I'll pick a track from my demo (you can download the demo yourself to get access to the track; it's in my signature). The one I am choosing is a short one: "Victoriousness.ogg".


File size: 310 KB


Length: 866,596 samples, about 19.65 seconds.


LOOPSTART: 158430


LOOPLENGTH: 587958


44100 Hz


16-bit PCM, not that I know what that means.


That a good start? Or, again, it's in my demo.


Oh, and I just confirmed that it happens to Battle1 in the normal MV files as well. I didn't hear it in Field1 because it turns out Loopstart there is "8", and 8 samples is so short I probably just didn't notice.


EDIT: I'm investigating as best I can. It looks like, in the function "WebAudio.prototype._onXhrLoad" in rpg_core, the length of "array" is never defined. This causes the loop comment reader to get skipped entirely. Not sure yet why it's not defined.
Yes, that was a good start.


I've tested  songs and the "innate" loop is made with a "the start look like the chorus".


Then, I've made a quick test with HIME_Easy Audio Looping.js, and it worked great (on a small test).


Perhaps should you look into is code to get why yours doesn't work any longer... No offense.
 
Last edited by a moderator:

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
I'm remaking a new link, that was on old one.


But it'll take one houre or more...
Here the link for the zip file.


If you want, there also separeted link for the ARM file or the x86.


Since I don't have a good enough phone, I can't test it. Sorry.
 

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
207
Reaction score
116
First Language
Gibberish
Primarily Uses
Here the link for the zip file.


If you want, there also separeted link for the ARM file or the x86.


Since I don't have a good enough phone, I can't test it. Sorry.
You will have to upload those into drop box or mediafire or something, we can't download them from wherever you have them right now. "Failed - No file" error when attempting to download it.


The builds through Intel XDK I believe are setup in a way ONLY the one who made them can download them. To share with us you will have to upload them somewhere after you download them.
 
Last edited by a moderator:

Nanaya

Veteran
Veteran
Joined
Jun 5, 2016
Messages
76
Reaction score
18
First Language
French
Primarily Uses
RMMV
Alright, I'll use Db. Weird though. I've just started to download it now... No problem. Maybe is it linked to my IP..?
 

Ralph

Retired Badass
Restaff Lead
Joined
Mar 8, 2013
Messages
329
Reaction score
230
First Language
Fantasy Heroics
I would be inclined to believe that were true if it weren't for the fact that all the evidence I've gathered points against it.
If you didn't update your game and used rpg maker mv 1.3.0 deployment it will not work.
 

Exus

JIYU
Member
Joined
Jun 23, 2016
Messages
3
Reaction score
1
First Language
English
Primarily Uses
Hm, is the WebGL: Invalid_Value: bufferData: size == 0        pixi.js:290 error causing this?


Been trying to look for a workaround for this all day. No dice.  :unsure:


1.png


It's the only bug that shows up in the console for now, was just wondering if anyone else is experiencing the same problem.


Three.png
 
Last edited by a moderator:

sb~

Villager
Member
Joined
Aug 2, 2016
Messages
17
Reaction score
6
First Language
English
Primarily Uses
Hm, is the WebGL: Invalid_Value: bufferData: size == 0        pixi.js:290 error causing this?


Been trying to look for a workaround for this all day. No dice.  :unsure:


It's the only bug that shows up in the console for now, was just wondering if anyone else is experiencing the same problem.


Came on here just to report the same problem with the black tiles.


Also when I enter battle I get horrible frames lag making the battle not so enjoyable.


The last problem I have is my BGMs now fade at the end of the song instead of seamlessly looping which they did before.


If anyone knows any fixes to these problems it would be much appreciated. The only plugins I'm running are Yanflys.


EDIT: after testing it seems like the new plugin "TDDP_PreloadManager" was the main culprit in causing the black boxes and battle frames lag. After turning this plug-in OFF the game runs smoothly just like in 1.2
 
Last edited by a moderator:

deadtuning

bloop
Veteran
Joined
May 20, 2016
Messages
35
Reaction score
32
First Language
English
Primarily Uses
So maybe I'm being completely stupid here, but Steam auto-updated, I didn't know anything about needing to back up my files etc so it was literally I tried to update and then tried to open my current WIP. It says it can't read the file. So I copied the .js files (apart from plugins), the stuff in the libs folder and the index.html into my project folder. Same problem. Other projects load and work 100% (without copying over the stuff) and I've no idea what to try to fix this. Really disheartened but get the feeling it's my bad for not backing up the project folder. :(  Any ideas? Cheers.
 

lawina

Veteran
Veteran
Joined
Sep 4, 2015
Messages
151
Reaction score
28
First Language
English
Primarily Uses
Hm, is the WebGL: Invalid_Value: bufferData: size == 0        pixi.js:290 error causing this?


Already posted this yesterday and Archeia said we can safely ignore the "notice".
 

biud436

Veteran
Veteran
Joined
Sep 28, 2014
Messages
163
Reaction score
161
First Language
Korean
Primarily Uses
RMMV
364.png



I found the issue that causes appearing the black line in between to test the game on android platform. that problem is this :


// libs/pixi-tilemap.js
glt.enableLinearScaling();


I was temporarily solved its issue by modifying some code of 'libs/pixi-tilemap.js' file as follows.

Code:
TileRenderer.prototype.initBounds = function() {
    var gl = this.renderer.gl;
    var tempCanvas = document.createElement('canvas');
    tempCanvas.width = 2048;
    tempCanvas.height = 2048;
    // tempCanvas.getContext('2d').clearRect(0, 0, 2048, 2048);
    for (var i=0;i<this.maxTextures; i++) {
        var glt = new glCore.GLTexture(gl, 2048, 2048);
        glt.premultiplyAlpha = true;
        glt.upload(tempCanvas);
        glt.enableWrapClamp();

        //glt.enableLinearScaling();
        glt.enableNearestScaling();

        this.glTextures.push(glt);
        var bs = [];
        for (var j=0;j<4;j++) {
            var spr = new PIXI.Sprite();
            spr.position.x = 1024 * (j & 1);
            spr.position.y = 1024 * (j >> 1);
            bs.push(spr);
        }
        this.boundSprites.push(bs);
    }
};
 

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
207
Reaction score
116
First Language
Gibberish
Primarily Uses
So maybe I'm being completely stupid here, but Steam auto-updated, I didn't know anything about needing to back up my files etc so it was literally I tried to update and then tried to open my current WIP. It says it can't read the file. So I copied the .js files (apart from plugins), the stuff in the libs folder and the index.html into my project folder. Same problem. Other projects load and work 100% (without copying over the stuff) and I've no idea what to try to fix this. Really disheartened but get the feeling it's my bad for not backing up the project folder. :(  Any ideas? Cheers.
The Index.html and the js files you copied over into the project to "update" it, if you still have any projects in 1.2 that you havent updated, you can copy the same files from there into the project again to go back to 1.2 in that project. in the libs folder, 1.3 has a couple new files, just get rid of them again as well. I'm not entirely sure what went wrong but doing this can undo what you did to update the project.

RPG Maker MV on steam really should have versions selection features or something, so that in situations like this the steam users can drop back to a previous version. 
 

SimProse

Veteran
Veteran
Joined
Jul 9, 2016
Messages
365
Reaction score
200
First Language
English
Primarily Uses
After reading the reports on here, i'll probably hold off on a bug fix patch for 1.3 before moving over. Too many weird quirks, things suddenly not working and bugs for my tastes. Especially disappointing given the 4+ month time period between 1.2 and 1.3.
 

lostdragon

Veteran
Veteran
Joined
Dec 23, 2014
Messages
39
Reaction score
6
First Language
English
Primarily Uses
After further testing my issue with micro-stuttering didn't really go away.  It just happens less now.


That's an improvement anyway.


Perhaps it is related to the 64x64 tile size I use.  Maybe that plugin is missing something.  Maybe it's a sync issue.  I can't get it to happen on command so I can't make a proper bug report.
 

Nightshade

Veteran
Veteran
Joined
Oct 26, 2015
Messages
591
Reaction score
120
First Language
English
Primarily Uses
RMMV
that is awesome! : D thank you ^^
 

liamx2000

Veteran
Veteran
Joined
Feb 13, 2016
Messages
81
Reaction score
5
First Language
English
Primarily Uses
Since I only just bought this , I'm scared of updating and mucking up my Rpg maker and projects. You would think an update would be simple just click and done But for an ultra noob like myself I find it hard. I have used RPG Maker 2003 for many many years still do but really wanted to learn to use MV now as well


Also never heard of Pixi4 until today and that's all I see people talking about now and it just goes way over my head right now , do I need to use pixi4 to make my game now ? is it essential ??


Because if people who know how to install this are having problems what kind of issues will I get lol.
 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

My old project is now a sitcom
How to do implementation the social politcal mechanics in rpg maker? Thank you for quick spark of ideas. Fear of going to the thread lol.
MerlinCross wrote on Switz's profile.
Not sure if you'll see this but I stumbled across your "Open Locker" sprite in a topic. Could I use those?
topic in question
Going to watch an episode of The Office and eat something after this little progress!

Forum statistics

Threads
100,780
Messages
979,428
Members
132,417
Latest member
U2M
Top