Status
Not open for further replies.

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
210
Reaction score
129
First Language
Gibberish
Primarily Uses
RMMZ
Okay, thanks! I understand what those are now. And I agree that it was shocking to see such little in the Database. Especially since I had looked at VX Ace and the Database was already filled with starting characters.

Yea it was kinda a thing, I usually use the default database stuff on my first project in an RM engine just to get used to the changes and everything, so it was a strange sight when I launched MV the first time.
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
524
First Language
English
Primarily Uses
N/A
Change "Decrypter.REMAIN = "0000000000"; to "Decrypter.REMAIN = "0000000020"; and try that. someone found that to be a tempfix for now on encryption. Can't say anything about the Mac side of things as I don't own a mac. to test on.


Your link doesn't work, you will have to upload the zip file somewhere.



Hello Isaac,


That actually does fix the encryption problem! So I guess some people will have to change Decrypter.REMAIN (8456), change the value to "0000000020" and some people have to change "Decrypter.REMAIN = "0000000000"; to "Decrypter.REMAIN = "0000000020".


For me it was the second one. Is it weird that there are two possible solutions? Shouldn't the code be identical for both? Was one updated after the other? 

Hm, is the WebGL: Invalid_Value: bufferData: size == 0        pixi.js:290 error causing this?


Been trying to look for a workaround for this all day. No dice.  :unsure:


It's the only bug that shows up in the console for now, was just wondering if anyone else is experiencing the same problem.



Hey, I am also having this issue (black boxes appearing on screen, please see his original post for pics)


I turned off all plugins and the problem disappeared. Which doesn't mean it fixed it. It just means these black boxes are appearing off the screen. I enabled 1 plugin. Yanfly's Screen resolution plugin, so I can see more of the screen. I increased the screen to 960 by 640 and BAM! The black boxes reappeared! AAHHH! This problem is easier to spot on bigger/more elaborate maps. 
 
Last edited by a moderator:

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,479
Reaction score
15,925
First Language
Filipino
Primarily Uses
RMMZ
Hello Isaac,


That actually does fix the encryption problem! So I guess some people will have to change Decrypter.REMAIN (8456), change the value to "0000000020" and some people have to change "Decrypter.REMAIN = "0000000000"; to "Decrypter.REMAIN = "0000000020".


For me it was the second one. Is it weird that there are two possible solutions? Shouldn't the code be identical for both? Was one updated after the other? 



It's a classic case of Steam breaking programs without you noticing.


KillerGin, please avoid double posting, as it is against the forum rules. You can review our forum rules here. Thank you.
 

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
210
Reaction score
129
First Language
Gibberish
Primarily Uses
RMMZ
Hello Isaac,


That actually does fix the encryption problem! So I guess some people will have to change Decrypter.REMAIN (8456), change the value to "0000000020" and some people have to change "Decrypter.REMAIN = "0000000000"; to "Decrypter.REMAIN = "0000000020".


For me it was the second one. Is it weird that there are two possible solutions? Shouldn't the code be identical for both? Was one updated after the other? 

the (8456) is just the line that Decrypter.REMAIN" is on. it's not part of the variable.
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
524
First Language
English
Primarily Uses
N/A
the (8456) is just the line that Decrypter.REMAIN" is on. it's not part of the variable.



lol Oh, silly me. Thanks.


Did you catch the second issue I am experiencing with 1.3? JiYu_Exus is have the same problem, the black box problem. JiYu_Exus, has screen shots above.
 

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
210
Reaction score
129
First Language
Gibberish
Primarily Uses
RMMZ
lol Oh, silly me. Thanks.


Did you catch the second issue I am experiencing with 1.3? JiYu_Exus is have the same problem, the black box problem. JiYu_Exus, has screen shots above.

I'm not entirely sure what's going on with the black tiles issue some people are having. I haven't been able to reproduce it myself, in a new project, and have not had the problem appear in older projects of mine that have been updated to the new version either. The only thing I can think to ask is, what plugins are you using, do any of them require pixi, if they do that could be a culprit since its still going to be a while until all the plugin devs get the time to update their stuff. If you can reproduce the problem in a completely fresh project then I'm really not sure what else to say.


As Archeia said with the encryption thing steam apparently is breaking that? Perhaps the black tiles are steams fault too? >.<
 

Kaliya

// Caffeine Overload
Developer
Joined
Nov 1, 2015
Messages
506
Reaction score
567
First Language
English
Primarily Uses
RMMV
As Archeia said with the encryption thing steam apparently is breaking that? Perhaps the black tiles are steams fault too? >.<

That would be a no. Steam isn't the fault there, but we are working on it so please look forward to a fix :).
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
524
First Language
English
Primarily Uses
N/A
I'm not entirely sure what's going on with the black tiles issue some people are having. I haven't been able to reproduce it myself, in a new project, and have not had the problem appear in older projects of mine that have been updated to the new version either. The only thing I can think to ask is, what plugins are you using, do any of them require pixi, if they do that could be a culprit since its still going to be a while until all the plugin devs get the time to update their stuff. If you can reproduce the problem in a completely fresh project then I'm really not sure what else to say.


As Archeia said with the encryption thing steam apparently is breaking that? Perhaps the black tiles are steams fault too? >.<



Well it was assumed the encryption problem was due to STEAM because of the two ways to fix the problem. This was due to miscommunication, we see now that there is just one way to fix the problem so that point is no good.


Here is a small project you can download that highlights the black box problem. Just walk around the screen and the black boxes will appear. I am using 1 plugin to highlight the problem. Even when this plugin is not used, the problem persists, its just harder to notice.


killergindotcom.files.wordpress.c..


Really quickly, did they move the 1.3 bug report problem out of this thread? I don't want to get in trouble for posting things there. lol
 

Kaliya

// Caffeine Overload
Developer
Joined
Nov 1, 2015
Messages
506
Reaction score
567
First Language
English
Primarily Uses
RMMV
Really quickly, did they move the 1.3 bug report problem out of this thread? I don't want to get in trouble for posting things there. lol

We would appreciate it if you could make bug reports their own thread, and follow the template found here: 




It makes keeping track of them and referencing them in our backlog easier.
 

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
210
Reaction score
129
First Language
Gibberish
Primarily Uses
RMMZ
That would be a no. Steam isn't the fault there, but we are working on it so please look forward to a fix :).

Well that answers that~ ^^

Well it was assumed the encryption problem was due to STEAM because of the two ways to fix the problem. This was due to miscommunication, we see now that there is just one way to fix the problem so that point is no good.


Here is a small project you can download that highlights the black box problem. Just walk around the screen and the black boxes will appear. I am using 1 plugin to highlight the problem. Even when this plugin is not used, the problem persists, its just harder to notice.


killergindotcom.files.wordpress.c..


Really quickly, did they move the 1.3 bug report problem out of this thread? I don't want to get in trouble for posting things there. lol

Yea, Archeia posted about it a page ago.
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
524
First Language
English
Primarily Uses
N/A
Well that answers that~ ^^


Yea, Archeia posted about it a page ago.



Sorry about that! This is my first time talking about bugs and issues in the forums. I found the place to post bugs and I posted the black box issue there, I hope I did that right.


Thanks guys for all your patience, understanding, and hard work! 
 

EuphemiaArtoria

Veteran
Veteran
Joined
Aug 6, 2013
Messages
63
Reaction score
75
First Language
English
Primarily Uses
RMMV
I'm still on RPG Maker MV 1.0. Do I need to upgrade to 1.1, then 1.2 before moving to 1.3, or can I go straight to 1.3? Likewise will I need to convert my project 1-->1.1-->1.2-->1.3 ?


I'm a little fuzzy on whether 1.3 is a stable release build or an unstable build. The improvements sound great and I'm pretty psyched, but I'd get 1.2 for now if it's stable vs unstable.
 

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,479
Reaction score
15,925
First Language
Filipino
Primarily Uses
RMMZ
I'm still on RPG Maker MV 1.0. Do I need to upgrade to 1.1, then 1.2 before moving to 1.3, or can I go straight to 1.3? Likewise will I need to convert my project 1-->1.1-->1.2-->1.3 ?


I'm a little fuzzy on whether 1.3 is a stable release build or an unstable build. The improvements sound great and I'm pretty psyched, but I'd get 1.2 for now if it's stable vs unstable.



Wait for 1.3.1 but otherwise for updating, just jump straight to the latest one.
 

gmestanley

An Ordinary Wizard
Veteran
Joined
Oct 30, 2015
Messages
66
Reaction score
21
First Language
Portuguese
Primarily Uses
Wait a minute...is this real life? OR IS THIS JUST FANTASY??


RPG Maker MV v1.3.0? YAY! (I actually got notificated of this thanks to Echo607, thankies Echo :D)


So, I can't download the update right now (my Internet runs at a speed of 1MB LOL), but when I get it, I will come back here and say what it looked like to me.


Hope my translation correction wishes were listened...


Oh, and it's nice that the program has now a SplashScreen ('cause they're gorgeous and Game Maker: Studio has it)
 

lawina

Veteran
Veteran
Joined
Sep 4, 2015
Messages
151
Reaction score
28
First Language
English
Primarily Uses
Wait a minute...is this real life? OR IS THIS JUST FANTASY??


RPG Maker MV v1.3.0? YAY! (I actually got notificated of this thanks to Echo607, thankies Echo :D)


So, I can't download the update right now (my Internet runs at a speed of 1MB LOL), but when I get it, I will come back here and say what it looked like to me.


Hope my translation correction wishes were listened...


Oh, and it's nice that the program has now a SplashScreen ('cause they're gorgeous and Game Maker: Studio has it)











Sorry, couldn't resist. Please don't ban me, mods.
 

KillerGin

Freddie
Veteran
Joined
Dec 18, 2015
Messages
568
Reaction score
524
First Language
English
Primarily Uses
N/A
Great work guys!


The benchmark for the improvements is the Android Version! ;0)~
 

hydro_sapien

Veteran
Veteran
Joined
May 26, 2014
Messages
59
Reaction score
9
First Language
English
Primarily Uses
Im getting this on my project on a "Cannot read property "Zlayer" of undefined"


domencia isle.jpg
 
Last edited by a moderator:
Status
Not open for further replies.

Latest Threads

Latest Profile Posts

gotta love when a plugin you thought had nothing to do with why something else wasn't working winds up being the issue...
Doing RPG Maker News for 26th September 2021

Well... it's been a while since I was last here :kaoswt: I don't want to say I'm officially 'back' yet, but I've recently started working with RM again, so I might become active here again :kaohi:
Mmmm I love Coca Cola candy! :kaoluv:
aaaand my power is out. I sometimes think that I'm cursed.

Forum statistics

Threads
115,394
Messages
1,089,543
Members
150,132
Latest member
pipgea
Top