RPG Maker MV Debugging

Discussion in 'RPG Maker MV' started by Archeia, Oct 26, 2015.

  1. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,652
    Likes Received:
    14,413
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Hi everyone, 

     

    I'm sorry for the consecutive updates but I just got news back from Kadokawa and we need your help again.

    Please do the following if your MV editor lags or if your MV is too fast (e.g. 1000 FPS). 

    • Do not report if you have only issues with the animated autotiles as that is a separate issue and we're fixing that one as well. 
    • Do not report about language errors or the traits, etc. We are now fixing those. 
     

    Thank you for the help and I once again apologize for all the troubles. 

     

    --------------------------------------------------------------------------------------------------------------- 

    Instructions

    --------------------------------------------------------------------------------------------------------------- 

     

    1.) Download this program: 

    http://www.cpuid.com/softwares/cpu-z.html

     

    2.) Install and Run the Program. Make sure MV is open.


    • If MV doesn't open, Tell in the email and send the specs.
    • If MV lags but the play test doesn't. Tell in the email and send the specs
    • If MV doesn't lag but the game playtest is lagging. Tell in the email and send the specs
    • If MV playtest is too fast. Tell in the email and send the specs.
    • If only audio lags in editor but not playtest. Tell in the email and send the specs
    • If audio lags only in playtest. Tell in the email and send specs
    • If audio lags on both, tell in the email and send specs

    3.) Go to Tools > Export as HTML 

     

    4.) Send us the HTML file either in this topic or at rmlunaengine@gmail.com

     

    5.) Tell us which of the errors is happening. Editor crashes, Editor lags, Testplaying crashes, Testplaying lags or both.

     

    Thank you for your cooperation. We hope to fix the issues ASAP!
     
    Last edited by a moderator: Oct 28, 2015
    #1
    djDarkX, Dalph, Point08 and 2 others like this.
  2. Seriel

    Seriel Veteran Member

    Messages:
    3,018
    Likes Received:
    508
    Location:
    Wales, UK
    First Language:
    English
    Primarily Uses:
    Other
    That link gives a 404 error.
     
    #2
  3. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,652
    Likes Received:
    14,413
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Ok try again. For some reason forum boards broke it lol
     
    #3
    Seriel likes this.
  4. KisaiTenshi

    KisaiTenshi Veteran Veteran

    Messages:
    310
    Likes Received:
    121
    I think you might want to have them run CPU-Z while the game is running in order to determine if it's a power setting.
     
    #4
    Acetonide and Archeia like this.
  5. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,652
    Likes Received:
    14,413
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Ok I'll run that in.
     
    #5
  6. Seven Rain

    Seven Rain Villager Member

    Messages:
    13
    Likes Received:
    1
    First Language:
    English
    Editor lag here. Tried to make sure I had nothing major running on my computer except MV when saving the report.

    Report.html
     

    Attached Files:

    #6
  7. Xedrik

    Xedrik Warper Member

    Messages:
    3
    Likes Received:
    0
    First Language:
    German
    Attention! English isn't my mother tongue, but I am sure you will understand.

    Hi, folks. I really like the new style of MV. But the performance is terrible. As example: I created a few Weapons in Database and forgot to change the weapon type. So, I started to change the types and clicked on the Weapon Type button . The pop up menu didn't scroll down instantly like in VX ACE. My Editor did freeze for long time, then the menu, to change weapon type,  surfaced. I created more than 30 Weapons yet and it's not funny to wait more than 30s to change weapon type for each weapon  :( ! My next problem is: I can't playtesting anymore. I created a new project to try playtesting in a clean project with standard settings and without plugins, but nothing happened. I noticed another bugs, but I found solutions.
     
    #7
  8. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,652
    Likes Received:
    14,413
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Hi there, please follow the instructions in this topic so we can find a solution to performance issues :)
     
    #8
  9. Xedrik

    Xedrik Warper Member

    Messages:
    3
    Likes Received:
    0
    First Language:
    German
    Sorry, I've forgotten the .html file.

    Report.html
     

    Attached Files:

    #9
  10. PaterJosch

    PaterJosch Warper Member

    Messages:
    1
    Likes Received:
    0
    First Language:
    German

    Attached Files:

    #10
  11. Grimoire LD

    Grimoire LD Veteran Veteran

    Messages:
    39
    Likes Received:
    8
    First Language:
    English
    I seem to only have a bit of trouble when I am going through the menus, the lag there is anywhere from instant-5 seconds for each change of menu.

    JOE-PC.html
     

    Attached Files:

    #11
  12. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,652
    Likes Received:
    14,413
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Thank you!
     
    #12
  13. djDarkX

    djDarkX Retro & Remastered Music Guru Veteran

    Messages:
    2,699
    Likes Received:
    1,887
    Location:
    Currently unsure...
    First Language:
    Music
    Primarily Uses:
    RMMV
    Well, I don't a lot of lag in the editor like others do, but I do notice it will freeze for about a second every now and then, so I'll throw this in to help with the fix.  Good luck to the Kadakowa Programming Team on getting this resolved!

    JESSE-GAMER.html
     

    Attached Files:

    #13
  14. Kane Hart

    Kane Hart Elmlor.com Veteran

    Messages:
    656
    Likes Received:
    166
    Location:
    Barrie, Ontario, Canada
    First Language:
    English
    http://stonelegion.com/kane/DESKTOP-0V0EJVM.html

    Editor Lag Issues:

    • When I click and let go fast the first time drawing something it never catches up or continues
    • browsing the database tabs are quite slow
    • overall painting the terrain is quite slow and not up to standards. 

    This is a slight video on my lag issues their really hard to explain in text but I try to do via the video though it skips so many frames you might not see it but might get a better understanding of what the issue is. There is a delay or a lag everytime you click. Once you have click and been held down say over 1 solid second it catches up fine.
     
    #14
    Marquise* likes this.
  15. KisaiTenshi

    KisaiTenshi Veteran Veteran

    Messages:
    310
    Likes Received:
    121
    Seven Rain(AMD 1055T CPU (2010),HD 6850(2010)), Xedrik(AMD FX-8350(2012),R9 270X (2013)), PaterJosch (FX-4100(2011), HD 7850(2012)):
    You're all running AMD CPU's with AMD GPU's. You need to be running the Cataylst driver 10.8 or later.
    Seven Rain is running 15.9 Beta, Xedrik is running 15.8, and  PaterJosch is running 15.7.1
    Latest Beta driver is 15.10 Beta, Latest stable is 15.7.1

    So far the only thing in common is the AMD's above are all running GPU's of the same performance grade (mid-tier) with the R9 270X being 20% faster than the 7850 and the 7850 being 20% faster than the 6850.

    Grimoire LD:
    Your system is running 4 year old graphic drivers(2011) and the onboard video might be too weak. So the lag might simply be that it's way too weak. Pentium P6200 (2010). You should still be running the most recent graphics drivers for the Intel HD Graphics onboard video.

    djDarkX:
    Intel Q6600 (old CPU, 2007) paired with Geforce 9800GTX (old GPU, 2008), both parts are 8 years old.
    So it's performance should be closer to a medium/low end current system. The GPU driver is 341.81

    So far... nothing in common with all of them.
     
    #15
    whitesphere, Touchfuzzy and Archeia like this.
  16. Seven Rain

    Seven Rain Villager Member

    Messages:
    13
    Likes Received:
    1
    First Language:
    English
    Bleh, 2010. I need some hardware upgrades soon, but the lag has still been worrying.

    Care to clarify this, though?

    Did you just mention 10.8 for the sake of record or is there something different about my driver version? We all seem to have later versions than 10.8, (albeit beta versions, except Pater,) so it threw me off that you mentioned it.
     
    Last edited by a moderator: Oct 27, 2015
    #16
  17. KisaiTenshi

    KisaiTenshi Veteran Veteran

    Messages:
    310
    Likes Received:
    121
    https://www.khronos.org/news/permalink/amd-released-catalyst-10.8-drivers-with-opengl-es-2.0

    That still requires the full Catalyst driver set, not the Windows Update minimum set. CPU-Z and GPU-Z don't really make a distinction between the driver sets, but Windows doesn't need the OpenGL/OpenGL ES drivers to operate (So it's possible that a computer that has only been applying Windows Update updates might not have them.) The quickest way to find out is to simply hit F2 in the game and see if it says WebGL or Canvas. If it says WebGL, then it's using a WebGL path (even if it uses ANGLE and uses D3D.) Without the OpenGL ES2 / WGL support in the driver, then it has to go through the additional translation layers.
     
    Last edited by a moderator: Oct 27, 2015
    #17
  18. Seven Rain

    Seven Rain Villager Member

    Messages:
    13
    Likes Received:
    1
    First Language:
    English
    I see. Thanks for elaborating!
     
    #18
  19. JAD94

    JAD94 The lunar knight Veteran

    Messages:
    664
    Likes Received:
    190
    Location:
    New York
    First Language:
    English
    Primarily Uses:
    RMMV
    Thank you for this I've been wanting to get to the bottom of this :)  , Editor lag and gameplay lag here:

    JAD-PC.html
     

    Attached Files:

    #19
  20. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    14,652
    Likes Received:
    14,413
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Thank you!
     
    #20

Share This Page