RPG Maker MV FAQ

dedausee

Warper
Member
Joined
Sep 26, 2018
Messages
2
Reaction score
0
First Language
Indonesia
Primarily Uses
RMMV
What are the minimum specifications for running a RPG maker game? Is it similar to minimum specifications for running a RPG maker? Thank
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,240
Reaction score
7,618
First Language
German
Primarily Uses
RMMV
@dedausee no, the minimum specs are not identical - and they depend on a specific game, they're not general.

A game that uses parallax mapping for example would need more memory to run smoothly than a game that uses regular mapping, and a lot also depends on what plugins are used in the game.

Some games will run good on ancient computers, while others tend to lag all but the most powerfull devices - there is no general answer for your question.
 

Tommy Gun

♩ ♪ ♫ ♬
Veteran
Joined
Jan 20, 2014
Messages
385
Reaction score
123
First Language
English
It's been a while, but I'm back and I updated the FAQ! I mostly fixed links and some formatting issues, but I also added a section for how to fix scaling on high res displays.
 

TheGreatEater

Coding is my dump stat.
Veteran
Joined
May 20, 2015
Messages
393
Reaction score
206
First Language
English
Primarily Uses
N/A
The RPG MV Tutorial link, no longer works. Just thought I'd give a heads up.
 

Aerosys

Veteran
Veteran
Joined
Apr 23, 2019
Messages
364
Reaction score
335
First Language
german
Primarily Uses
RMMZ
Link to "Full MV Database" is dead
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,240
Reaction score
7,618
First Language
German
Primarily Uses
RMMV
Link to "Full MV Database" is dead
that is because it is no longer needed, the full database has been part of the program installation for years (just copy it from the program folder into the project where you want to use it)
 

Aerosys

Veteran
Veteran
Joined
Apr 23, 2019
Messages
364
Reaction score
335
First Language
german
Primarily Uses
RMMZ
that is because it is no longer needed, the full database has been part of the program installation for years (just copy it from the program folder into the project where you want to use it)
Okay, so I did. I have exactly 4 items and 10 skills. Is this the "full" database? In XP I had like a hundred items.
 

Zarsla

Veteran
Veteran
Joined
Jan 23, 2015
Messages
710
Reaction score
228
First Language
English
Primarily Uses
@V_Aero
Look in the MV program folder, should be something called Fantasy English New Data.
 

Alexandr_7

Veteran
Veteran
Joined
Apr 22, 2016
Messages
106
Reaction score
29
First Language
Russian
Primarily Uses
I think that with RPG Maker MZ on RPG Maker MV and its owners scored.
It's a shame for this approach. Instead of improving MV, they release a new RPG Maker which is essentially an improvement on the old one. And demand a new portion of money for him. Hmm. Licensees for the "RPG Maker MV" are going to send to hell.
 

Zarsla

Veteran
Veteran
Joined
Jan 23, 2015
Messages
710
Reaction score
228
First Language
English
Primarily Uses
I think that with RPG Maker MZ on RPG Maker MV and its owners scored.
It's a shame for this approach. Instead of improving MV, they release a new RPG Maker which is essentially an improvement on the old one. And demand a new portion of money for him. Hmm. Licensees for the "RPG Maker MV" are going to send to hell.
I've said this multiple times, MV 1.6.0 had 2 updates.
1. was the code
2. The other was the engine

And sooooo many people had to roll it back(1.6.1/1.6.2 is the just code changes, no engine update).

If they can't even do a simple update without breaking the entire engine for people to use,
why do people think they can do an overhaul/revamp?
Not to mention the fact that it's requirements for MZ,makes where I've seen multiple users state that for them to get it, they need an computer upgrade.

If MV had an update, the likes of MZ, it wouldn't work. It would be an update where most people would have to scrap everything in they're own projects, except for Resources, or been unable to even upgrade because of the requirements.

Most people wouldn't update and/or refuse to.
 

Alexandr_7

Veteran
Veteran
Joined
Apr 22, 2016
Messages
106
Reaction score
29
First Language
Russian
Primarily Uses
Anyway, the shame of the company. You can solve any problems. The question is how long does it take. But the company decided to make a new RPG Maker instead of updates, and naturally it will be necessary to buy it separately. RPG Maker MZ is based on RPG Maker MV and demanding a new pay for it is arrogance. Let them change it a lot, but according to the screenshots, this is just a major update for RPG Maker MV. But one way or another, the company scored a bolt on MV and will now support MZ; if you want a stable RPG Maker, then pay a new portion of money.

I repeat. RPG Maker MV is far from stability. And he was simply abandoned to cash in on the new RPG Maker MZ.

And almost all the new features in RPG Maker MZ (for example layers), they were already in the RPG Maker series. Or have you forgotten about engines like RPG Maker 2003, RPG Maker XP.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

I was at another orientation yesterday and I realized I'll be working with an old friend! We met at the local water park a few years back and it was so nice to see her again! We had a chat, and next week when I officially start, I'll see if maybe we can trade our Zoom IDs so we can talk!
I made some sideview closets for MV!
You can find them in my MV resource thread.
People1.png & SF_People1.png added!!!!

Adventurer:
"Why your body looks like a bird?"

Stranger:
"Because I'm harpy"

Adventurer:
"Clap along if you feel like a room without a roof"

*Both dancing to Pharrell Williams song*

Forum statistics

Threads
105,508
Messages
1,014,292
Members
137,186
Latest member
steven2880
Top