RPG Maker MV Lag Solution

Status
Not open for further replies.

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,730
Reaction score
14,582
First Language
Filipino
Primarily Uses
VNM
OK everyone. This topic is to help you all to fix your lag issues and as such, please read the following!

However, if nothing works, I'm afraid that you might need to buy a new PC or parts especially if they're made before 2009. (Especially PCs/GPUs build before 2009, see below)

Of course, if the driver can still be updated and it was made before 2009, it could still work. But no guarantees.

 

UI/Editor Lagging

 

If I see it right, MV uses QT with QtQuick, so no native components. I am not sure which graphics system is used since QT supports multiple but it could be also related to OpenGL, so if the graphics card or driver doesn’t support OpenGL it could result in lagging.

 

Game/Test-Play Lagging

 

MV uses NW.js for offline PC/Mac games and also for test-play. It uses PIXI.js which is based HTML5 Canvas/WebGL. So the same problem with OpenGL, if its not supported everything will be slow. 

 

Except on some browsers like Firefox, Chrome, etc. since they are able to map the OpenGL calls to DirectX/Direct3D calls using ANGLE. That would explain if the web-demo works fast but the test-play not for some users. 

 

NW.js also supports that since it based on Chromium, but sometimes its not working, for example if the DirectX 9.0.c Redistributable is not there or if some DLLs are missing.

 

But there is an additional problem, because Canvas/WebGL doesn’t support some GPUs/Drivers because they are on the GPU black-list to avoid crashes, etc. You have to keep in mind that HTML5 is actually a Web-Technology, so stability & security is very important.

 

HOW TO SOLVE

 

You should try the following steps.

 

1. Check that your graphics card supports OpenGL.

2. Go the website of your graphics card manufacture (NVIDIA, AMD, etc.) and download & install the latest driver for your graphics card. Make that the driver supports OpenGL.

3. If the games are still not running fast after these two steps, you should try to edit the package.json and add the following line:

 

{

    "name": "KADOKAWA/RPGMV",

    "main": "www/index.html",

    "js-flags": "--expose-gc",

    "chromium-args": "--ignore-gpu-blacklist",

    "window": {

        "title": "",

        "toolbar": true,

        "width": 816,

        "height": 624,

        "icon": "www/icon/icon.png"

    }

}

 

The package.js can be found in the installation directory of MV:

 

On Mac its in:

 

/Users/<user>/Library/Application Support/Steam/steamapps/common/RPG Maker MV/RPG Maker MV.app/Contents/MacOS/nwjs-mac/package.json

 

On Windows:

 

<install-dir>/nwjs-win/package.json

 

4. If that is not working or if the game crashes, try install DirectX 9.0c Redistributable package:

 

http://www.microsoft.com/en-us/download/details.aspx?id=8109

 

5. Make sure your laptop is set to High Performance!

 

Remember to restart RPG Maker MV after! 

 

6. If all these steps are not working, please let us know and check this information from WebGL Wiki:

 

Windows:

 

 • On all versions of Windows, WebGL is disabled on all graphics drivers older than January 1, 2009.

 • Additionally, on Windows XP, WebGL is disabled on ATI/AMD drivers older than version 10.6, on NVIDIA drivers older than version 257.21, and on Intel drivers older than version 14.42.7.5294.

 • WebGL is disabled on NVIDIA driver 6.14.11.9621 on Windows XP.

 • WebGL is always disabled on ATI FireNV 2400.

 • WebGL is disabled on Parallels drivers older than 7.

 • WebGL is always disabled on S3 Trio cards.

 

Mac:

 

 • On Mac OS X, WebGL is disabled on:

 • ATI Radeon X1900

 • NVIDIA GeForce 7300 GT

 • Additionally, when an external monitor is plugged in to a Mac OS X laptop, multisampling is disabled because of rendering corruption bugs (http://crbug.com/237931).

 

Source: https://www.khronos.org/webgl/wiki/BlacklistsAndWhitelists
 
Last edited by a moderator:

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,730
Reaction score
14,582
First Language
Filipino
Primarily Uses
VNM
Please make sure to follow this guide thoroughly and tell us should you get any problems. IF this fixes your problem, please tell us.
 

DragonSlash

Warper
Member
Joined
Jul 26, 2013
Messages
1
Reaction score
0
First Language
English
Thank you so much for this solution (even though my lag problem seemed to fix itself somehow? or maybe my driver updated itself?) anyways I'm glad you've provided a solution to this lag problem and will help many people with their games. I understand because it was recently released there are bound to be problems, but i'm glad you were able to fix it.
 

Seriel

Veteran
Veteran
Joined
Aug 16, 2014
Messages
3,018
Reaction score
508
First Language
English
Primarily Uses
Other
Tried everything there.

Still the same issues as before (Small editor lag and insane playtesting lag to the point where it's unplayable) Ace still works fine so my computer hasn't killed itself :p
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,730
Reaction score
14,582
First Language
Filipino
Primarily Uses
VNM
Tried everything there.

Still the same issues as before (Small editor lag and insane playtesting lag to the point where it's unplayable) Ace still works fine so my computer hasn't killed itself :p
What are the issues again? I've been looking at questions the entire day I can't remember.
 

Seriel

Veteran
Veteran
Joined
Aug 16, 2014
Messages
3,018
Reaction score
508
First Language
English
Primarily Uses
Other
What are the issues again? I've been looking at questions the entire day I can't remember.
The editor takes a while to load windows (It's stil really good and I can use it no problem)

And Playtest (And index.html in Firefox) jumps around between 2 and 18 FPS and is so laggy and choppy that it's unplayable.
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,730
Reaction score
14,582
First Language
Filipino
Primarily Uses
VNM
Did you check your hardware and software specs based on the guidelines above? can you post it in the other topic?
 

Hiek

Creator
Veteran
Joined
Jul 14, 2012
Messages
231
Reaction score
57
First Language
English
So NVIDIA GTX 745 should be fine from the PC I ordered right?
(It's also an Intel since I took your word on the whole AMD thing.)
 
Last edited by a moderator:

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,730
Reaction score
14,582
First Language
Filipino
Primarily Uses
VNM
So NVIDIA GTX 745 should be fine from the PC I ordered right?

(It's also an Intel since I took your word on the whole AMD thing.)
Yes especially since it's now made after 2009. Just make sure that OpenGL works/activated.
 

Leo Epitav

Villager
Member
Joined
Sep 30, 2015
Messages
53
Reaction score
3
First Language
English
Primarily Uses
I had lag with RPGMAKER MV BUT When I had My Laptop Without the Charging Cable connecting into it.

So any one with laptop should make sure they either have their power options on balance or the charging cable is connecting to laptop.
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,730
Reaction score
14,582
First Language
Filipino
Primarily Uses
VNM
I had lag with RPGMAKER MV BUT When I had My Laptop Without the Charging Cable connecting into it.

So any one with laptop should make sure they either have their power options on balance or the charging cable is connecting to laptop.
That's related to your power options yeah. If your pc is unplugged it could be running in low performance which slows down your power to preserve power. So try checking that first.
 
Last edited by a moderator:

Mako

Veteran
Veteran
Joined
Mar 13, 2012
Messages
272
Reaction score
47
First Language
English
Primarily Uses
Yeah I can't explain it ether. My PC was built after 2009, and I was getting lag - then halfway through messing around with it last night it just went away... heh 

Good news is problem is fixed! Bad is I have no idea how..
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
21,791
Reaction score
11,006
First Language
English
Primarily Uses
RMVXA
I'm not sure if this is the correct thread or not.

I have no problems with lag in the ordinary play test, at least so far, except for the music which has a second or two delay before starting and wrecks my cut scenes.  Is this related to hardware issues such as those described above, or is it something quite separate?

thanks.
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,730
Reaction score
14,582
First Language
Filipino
Primarily Uses
VNM
Try removing m4a files from the game project momentarily and see if that fixes your problem.
 

Hiek

Creator
Veteran
Joined
Jul 14, 2012
Messages
231
Reaction score
57
First Language
English
I still think the whole HTML5 thing for this version of RPG Maker was a really bad idea.
Especially after all the bad things I heard about HTML5 not being supported enough due to these exact reasons.

Heck, even people have problems with YouTube now that they switched from Adobe to HTML5.

A lot of people, including me use SMPlayer because of the HTML5 YouTube Player being laggy and terrible.

I also feel like MV should bring back the RTP style with optional
downloads for Windows RTP, Mac RTP, and iOS RTP or something
so everything isn't all bundled up in one big folder making everything look
so confusing compared to the previous makers.

P.S: Does Enterbrain not develop RPG Maker anymore?
They did a better job on the programs it seems.
 
Last edited by a moderator:

Seriel

Veteran
Veteran
Joined
Aug 16, 2014
Messages
3,018
Reaction score
508
First Language
English
Primarily Uses
Other
Oooookayyyyy...

My playtest issue just got better.

It now hovers at 20-40 FPS making it annoying but playable.

Considering my computer isn't exactly the best, i'm going to assume this is the best it can do and just roll with it.
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,730
Reaction score
14,582
First Language
Filipino
Primarily Uses
VNM
I still think the whole HTML5 thing for this version of RPG Maker was a really bad idea.

Especially after all the bad things I heard about HTML5 not being supported enough due to these exact reasons.

Heck, even people have problems with YouTube now that they switched from Adobe to HTML5.

A lot of people, including me use SMPlayer because of the HTML5 YouTube Player being laggy and terrible.

I also feel like MV should bring back the RTP style with optional

downloads for Windows RTP, Mac RTP, and iOS RTP or something

so everything isn't all bundled up in one big folder making everything look

so confusing compared to the previous makers.
This entire topic is for debugging, please make a new topic for opinions like this. I'm not being dismissive but as much as possible, I want to do support as easily as I can ;v;
 

Leo Epitav

Villager
Member
Joined
Sep 30, 2015
Messages
53
Reaction score
3
First Language
English
Primarily Uses
That's related to your power options yeah. If your pc is unplugged it could be running in low performance which slows down your power to preserve power. So try checking that first.
That what I did ofcourse at first sight of the lag and then I had no lag.

So I thought I would tell people running MV on laptops.

it might solve some cases in the very last related to lag.
 
Last edited by a moderator:
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Testing out applying a stroke effect to things at player level to increase visibility. Thoughts?

I wonder what cat meat tastes like.
Some call him... the wacky one.

Forum statistics

Threads
95,648
Messages
930,734
Members
125,982
Latest member
MrPhantom
Top