Annwfn

Veteran
Veteran
Joined
Nov 6, 2019
Messages
85
Reaction score
31
First Language
Romanian
Primarily Uses
RMMV
1658843512541.png

Hello there everyone, me again, I rarely post here, but when I do it's always cause I reached a skill limit and I need the help of others. I am trying to add little animations I did thanks to Manga Maker ComiPo!, Picrew and Windows Photos together to show player what Phase the current enemy is in. This is a dummy event I made, and it really gave me a headache.
So I get bumped into the error below:
1658843666069.png


This error is so... inconsistent. Let me explain.
So, before I add anything more different than what I've done till then I create dummy events so that I check whether the code would work. For this movie it did. Initially. Press the event, see movie, easy tutorial.
Since I don't test just once and usually go 6 - 10+ times, I got bumped with that error.
Initially it triggered once, I read a bit about it, didn't appear any more (didn't do any change).
So I put all 4 videos I wanted to put in the game (one for each phase) in a choice (1 branch for each). This error always popped.
Removed the Choice, reduced the event to just this (1st pic) and it worked well 1st time, 2nd time it did not, 3rd time it did.
For a while (10 tests or so), if I clicked on the event and the character went there this error always popped up.
If I went by the event and pressed enter the error would not trigger. Mindblown.
And now, same event but different day, error constantly shows up, no exception. Bruh . . .

P.S. I know there was a previous post, went through it all, did those things, added Wait times before, even after, added wait timers for even the entire duration of the video (11s) - still same error. No exception. Event initially worked well when it was just like this. Tested 10 times or so in a row (cause I know this program is messy, and happened before that things work, and after months of not touching them OR any correlated plugins those events won't work, as if they suddenly decided they would not. I heard necroposting is not welcome.

If there is no solution to this, is there a way around? I mean I could just put the pictures in the same order and use the same frames in between (that's how I made the clips in the first place), but may look awkward on slower computers.

Thank you in advance!
Your faithfully,
Annwfn
 

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
765
Reaction score
641
First Language
English
Primarily Uses
RMMV
From what I understand, movies is a feature in MV that was implanted but never meant to work. It's extremely frustrating as I wanted to use movie files at one point as well.

The movie option is in MV, but the feature is flawed and mainly does not work. MV is probably considered dated and no one really talks about the issue as many people don't seem to even use the event command.

I've brought up the issue in the past but this is something the creators will or will not fix. I'm sure there are plugins. (But why have an event command at all if a plugin is needed to make it work???)

All I know is you need two types of movie files with one of them by .ogg and probably the other .mp4.

Edit: Other than that, MV is great and odds are I could be wrong. (Probably am) I don't really understand your problem, I just know I couldn't get movies to work for me in the end and never had a real answer that I remember.

Edit 2: My issues was each time I used the play movie event command, the game would freeze and it didn't matter how long or short the video was. There was no consistency, it would just randomly freeze.
 
Last edited:

Annwfn

Veteran
Veteran
Joined
Nov 6, 2019
Messages
85
Reaction score
31
First Language
Romanian
Primarily Uses
RMMV
Yep, same as with me, it always freezes at the first video frame when the error kicks in.
Extensions that work are .webm and .avi as far as I tested.
Thank you for the kind reply! Huggies and take care, good luck with your projects, you are appreciated! >:D<
 

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
765
Reaction score
641
First Language
English
Primarily Uses
RMMV
Yep, same as with me, it always freezes at the first video frame when the error kicks in.
Extensions that work are .webm and .avi as far as I tested.
Thank you for the kind reply! Huggies and take care, good luck with your projects, you are appreciated! >:D<

Wish you luck too. If your videos aren't long or have many frames, maybe you could use Show Picture event command as a workaround? There are commands to move pictures around, fade them in or out, change size, zoom, etc.
 

Annwfn

Veteran
Veteran
Joined
Nov 6, 2019
Messages
85
Reaction score
31
First Language
Romanian
Primarily Uses
RMMV
I know, I know, but it looks awkward at times. Am good with handling frame wait times for the better results, but a movie is a movie. Putting pictures one after the other is something I've been doing and wanted to become flashier :D Gl ahead and thanks for the quick and also kind replies! Huggies! >:D<

Yours faithfully,
Annwfn
 

Zozma

Veteran
Veteran
Joined
Dec 20, 2012
Messages
231
Reaction score
4
First Language
English
Primarily Uses
When I checked for the viability of movies in my own project, I tested the feature by going on YouTube, downloading the first video on my recommend list, and using it in the event.


Iirc, it played all the way through without issue. I know that's not helpful in terms of fixing your issue, just wanted to put out there that you may not have to give up on it just yet.
 

Annwfn

Veteran
Veteran
Joined
Nov 6, 2019
Messages
85
Reaction score
31
First Language
Romanian
Primarily Uses
RMMV
When I checked for the viability of movies in my own project, I tested the feature by going on YouTube, downloading the first video on my recommend list, and using it in the event.


Iirc, it played all the way through without issue. I know that's not helpful in terms of fixing your issue, just wanted to put out there that you may not have to give up on it just yet.
Hello, am not giving up on this. Worst case scenario I'll make the movie out of the images with waiting frames in between. I'll figure the right amount of frames since I've been doing this for a long time. The randomness of whether it works or not is what baffles me. I've had movies before work no problem, this is the first time I bump into this. Huggies! >:D< Stay awesome, you are appreciated!
 

TheAM-Dol

Randomly Generated User Name
Veteran
Joined
Feb 26, 2022
Messages
341
Reaction score
384
First Language
English
Primarily Uses
RMMV
I've been watching this thread to see if the smart folk are able to answer, but none yet.
This is outside my pay grade, but maybe there's a solution here, but first, can you explain like I'm 5 what and how exactly you are using the video, and some screenshots might help to better illustrate their use. Well, maybe mock-up screenshots, not actual in game ones since you are crashing.
 

Annwfn

Veteran
Veteran
Joined
Nov 6, 2019
Messages
85
Reaction score
31
First Language
Romanian
Primarily Uses
RMMV
Hello, I actually posted the pic of the event. Just a dummy event which would trigger the movie, for testing purposes. Haven't tested how it would behave with a full event yet, however, I think I will use image-by-image as a work-around till a new path will become clear.
The game is not crashing, just freezing at the first frame of the movie.
Video is used in a dummy Action Button event to just trigger it, and that's it. Video is used just for display, no change to graphics or parallel processes in the background. Don't know what more I can say. The fact that at times it works but oftentimes it doesn't is m ind-boggling... Don't know why I end up with such weird situations... To many I find workarounds through event commands or scripts, or plugins at most, but I have my limitations. Hence why I asked for help, if possible.
 

Poupouille

Veteran
Veteran
Joined
Mar 1, 2017
Messages
179
Reaction score
32
First Language
French
Primarily Uses
RMMV
I have the same problem :/
Some or my video are playing, but I have a window freeze with another one
Is there a plugin to get around the problem?
 

Annwfn

Veteran
Veteran
Joined
Nov 6, 2019
Messages
85
Reaction score
31
First Language
Romanian
Primarily Uses
RMMV
Well, been waiting for this much time and no help popped up. Guess it's time to look that up on Google cause I doubt any help will come. I solved my problem temporarily by just using an image from the clips instead, for the message. If I use image-by-image with the same wait frames as the clip it won't work because it's JavaScript and the pictures will be delayed since there are other processes with greater priority. And I rarely have just a few processes running in the background. Cause why not, making "AAA"s in RPG Maker is fun! xD

Not a priority for me any more, since I can wait on that. It's just some extra which I can leave without.
 

Latest Threads

Latest Posts

Latest Profile Posts

WhitePaper.jpg

From China, with...white paper. :kaojoy:
This is a really good video
Testing Parry/Counter system straight from Action Sequence instead of utilizing the default counter.
Quite happy with the result so far.
Bex
This just blew my mind.
RMMZ can choose Tilesize.
No complicated Plugin needed, it is a simple inbuild Option.
This means you could literally use all your rm2k3 or vx-ace Tilesets and Characktersets in RMMZ.
This also makes me curious about experimenting with smaler Tiles and higher Screen Resolutions for non RPG Games.
mztilesize1414564.png
Did you know about this?

Forum statistics

Threads
126,984
Messages
1,182,886
Members
166,839
Latest member
Venjix
Top