RPG maker MV unknown movement error

Discussion in 'RPG Maker MV' started by Rhen90x, Apr 12, 2018.

  1. Rhen90x

    Rhen90x Warper Member

    Messages:
    2
    Likes Received:
    0
    First Language:
    Lithuanian
    Primarily Uses:
    RMMV
    Hello,

    I've searched the entire forum for a similar issue, but could not find one, please help!

    Okay, so here's the deal. My player character seems to move around just fine in an outdoors map, however, when it goes into an indoors map it can no longer move.

    My indoors maps are custom, I followed the set up of an already existing indoors map in RPG maker MV, so it should work, but even when I delete all existant events in the map and make my player start there, it still can't move to any direction.

    I'm lost and on't know what to do, everything seems to be fine, but I have this error in all of my indoor maps regardless if they have any events in them or not.
     
    #1
  2. Shaz

    Shaz Veteran Veteran

    Messages:
    37,312
    Likes Received:
    11,123
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Can you access the menu? Can you press the arrow keys and turn in different directions? If so, you have an incorrect setting on the top left B tile of your tileset. The passage setting should be a star, and you might have it set to X.

    If you can't access the menu or turn in different directions, it means you have an autorun event that's turned on. This could be a map event or a common event. It could be an event that has no commands.

    Or you could have executed a move with a Wait for Completion, but the player can't move onto the tile you're telling them to move to, so everything freezes.


    Based on what you've said, especially if all your indoor maps use the same tileset, my guess is the top left B tile's passage setting. In that case, I'd be interested to know what version of MV you have (you can see that from the menu), as well as what version of core files you have (you will need to go into your js folder and open the rpg_core.js file to see that - it should be on the first couple of lines, and if it's not there, it means you probably have 1.0.0 core files).

    Did you get your MV from RPGMakerWeb or from Steam (or somewhere else), and how long ago? If from Steam, is it set to do automatic updates? If from here or somewhere else, have you ever done any manual updates?
     
    #2
    Plueschkatze and Artificer like this.
  3. Rhen90x

    Rhen90x Warper Member

    Messages:
    2
    Likes Received:
    0
    First Language:
    Lithuanian
    Primarily Uses:
    RMMV
    Hi! I don't remember here I got my version from but it wasn't updated, however, I took your advice and set the top left B to a star and it helped. Thank you!
     
    #3
  4. Shaz

    Shaz Veteran Veteran

    Messages:
    37,312
    Likes Received:
    11,123
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    I suggest you update. Early versions have a LOT of issues. Make sure when you do, that you also update your project, which has to be done manually. Any of the update threads have the steps you need to follow.
     
    #4

Share This Page