RPG Maker MV v1.3.1: Fixes

Status
Not open for further replies.

consolcwby

(2015: afk...) 2018: BAK! :P
Veteran
Joined
Aug 25, 2016
Messages
204
Reaction score
334
First Language
English
Primarily Uses
RMMV
I couldn't migrate my current project. That's what I get for being too gung-ho. I guess now I can work on another project! :D
 

Adam1013

Veteran
Veteran
Joined
Feb 25, 2015
Messages
101
Reaction score
35
First Language
English
Primarily Uses
I just updated and I get "Cannot read WEBGL of Undefined" When I try to playtest..
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,837
Reaction score
7,895
First Language
German
Primarily Uses
RMMV
@Adam1013 either you didn't update the project correctly (a lot of people forget to update the files in the library folder, or update a file they should not override), or you're using a plugin that is not yet compatible to 1.3.1 - please check if there are any updates to the plugins you're using.
 

CarmenMCS

Warper
Member
Joined
Sep 7, 2016
Messages
4
Reaction score
0
First Language
spanish
Primarily Uses
I'm sorry that I am such a noob... so I downloaded the file, the installer said "rpg maker is ready to update" or something so I just said yes. I know that in other programs I can check the "version" so I was wondering how to do it with RPG Maker to be sure I updated it correctly (since nothing really seems to have changed, I mean I can't tell by simply looking at my project and stuff).


I didn't make any progress with my project, just some playing around with tilesets and the new features and stuff... I had a couple maps I liked so I did backup this project, but I guess you advised to do this just in case we messed up. It doesn't seem like the update did anything to my current project (expect, upgrading stuff and debugging and such I mean XD) I mean the maps are the same and everything seems to work. Or did I just not update this at all? Ha ha ha I can't tell. I wish I had the time to play around with the program nowadays, like I used to with the previous versions (so I didn't need to be such a noob and ask everything ha hah a OTL)


I was expecting to have to do something else, like replacing files or something, like when we didn't want the "translated versions" and wanted to switch to English (which was also very confusing...). I don't know, maybe you could consider explain more in detail what to do, show more screenshots and stuff? I just seem out of context, like, I am reading the instructions but where is the stuff you are talking about? Where do I get it -supposedly from the "download" link but what I find in there doesn't match your instructions-? Everytime there is an update, I end reading all the threads searching for someone that explains it step by step (but a lot of the time it's focused on the Steam users anyway). And then ther eis people saying I have to update the japanese data before the english data but I have the spanish version and like, what is going on. I am generally super happy with everything RPG Maker (the help form the forums and the people creating resources and everything) just saying because I don't want to sound all that bothered! The one thing that I don't seem to get in when we have to update or change data... I do believe that you could consider explain a bit more in detail, because I see a lot of people being just as confused -if not more- because after all, a lot of us RPG Maker users are average pc users (otherwise we wouldn't be using RPG Maker and the likes XD)
 

Zalerinian

Jack of all Errors
Veteran
Joined
Dec 17, 2012
Messages
4,698
Reaction score
937
First Language
English
Primarily Uses
N/A
Sounds like you updated the editor, to update the project you do need to copy the files from a new project into your old project. Copy everything from the js/libs folder, as well as the rpg_* files in the js folder into the same places in your project.
 

Isaac The Red

RedMage
Veteran
Joined
Jan 3, 2016
Messages
210
Reaction score
128
First Language
Gibberish
Primarily Uses
RMMZ
Sounds like you updated the editor, to update the project you do need to copy the files from a new project into your old project. Copy everything from the js/libs folder, as well as the rpg_* files in the js folder into the same places in your project.

Don't forget, older projects from 2.0 need to copy the index.html file over as well. 


And as always, Make a backup of your project before you do any of this. Safety first!
 

Nomi

Veteran
Veteran
Joined
Dec 16, 2014
Messages
156
Reaction score
48
First Language
German
As far as I understood steam updates mv automatically and my version is shown as 1.3.1
Still I miss the new assets and everything - (and sadly have complications with a plugin that should be solved in 1.3.1)


Do I need to update manually even with steam? Or did I miss anything else? Oo


I allready tried a brand new project...but there is no new database and such.
 

lawina

Veteran
Veteran
Joined
Sep 4, 2015
Messages
151
Reaction score
28
First Language
English
Primarily Uses
As far as I understood steam updates mv automatically and my version is shown as 1.3.1
Still I miss the new assets and everything - (and sadly have complications with a plugin that should be solved in 1.3.1)


Do I need to update manually even with steam? Or did I miss anything else? Oo


I allready tried a brand new project...but there is no new database and such.



Steam only updates the editor, not your current projects. Just follow the steps in the first post of this topic.
 

tabrls

Villager
Member
Joined
Aug 14, 2014
Messages
6
Reaction score
4
First Language
korea
Primarily Uses
I heard about language patch is done with steam RPG MV. How about non steam patch? 
 
Last edited by a moderator:
Joined
Sep 10, 2016
Messages
1
Reaction score
0
First Language
English
Primarily Uses
Thanks for the updates guys. The fact that you guys are always hard at work making the engine better is why I chose RM for my projects.
 

Cvrtis

Veteran
Veteran
Joined
Sep 9, 2013
Messages
239
Reaction score
124
First Language
Russian
Primarily Uses
What about translation fixes? Did I miss something?
 
Last edited by a moderator:
Joined
Sep 25, 2016
Messages
1
Reaction score
0
First Language
English
Primarily Uses
i tried downloading it,that process was okay, i pressed run and i put in english, and it says that it hasnt had its proper updating. I dunno how this is suppose to work tbh. I have a PC A windows gateway to be specific! If my computer is to outdated, i'll find another program to make rpg games from! Thank you -Lily
 

astracat111

Astra Cat
Veteran
Joined
Jun 16, 2015
Messages
207
Reaction score
119
First Language
English
Primarily Uses
The 'activated pixi garbage collector' part sounds good. Don't know what it is, but I figure it'll speed games up?
 

Chaos17

Dreamer
Veteran
Joined
Mar 13, 2012
Messages
1,311
Reaction score
485
First Language
French
My program updated correctly, I didn't updated my on going project since I fear that my paid plugins may conflict.
 

Lakaroth

Veteran
Veteran
Joined
Dec 9, 2014
Messages
274
Reaction score
133
First Language
English
Primarily Uses
Guys i have a problem after update from 1.3.0 to 1.3.1 Rpg maker wont start, if press start application from steam, RMMV logo appear for a second then crash...
How can i fix it?
1.3.0 it works, but no 1.3.1


I'm on MAC steam version
 
Last edited by a moderator:

Quite.Toxick

Veteran
Veteran
Joined
May 29, 2016
Messages
90
Reaction score
91
First Language
German, English
Primarily Uses
Guys i have a problem after update from 1.3.0 to 1.3.1 Rpg maker wont start, if press start application from steam, RMMV logo appear for a second then crash...
How can i fix it?
1.3.0 it works, but no 1.3.1


I'm on MAC steam version



Same problem here. Steam downloaded a "Korean translation fix", now nothing works anymore. The editor crashes as soon as it starts. No error message or log to give insight into the issue. Also running Mac (OSX 10.8.5)
 

Lakaroth

Veteran
Veteran
Joined
Dec 9, 2014
Messages
274
Reaction score
133
First Language
English
Primarily Uses
So i'm not alone....


Korean translation...i see... waiting for solution, i try to remove manually that translation or anything i find in korean and i'll update this post.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

>Testing with fonts change.
>Tries installing a plugin. Doesn't work.
>Tries changing the plugin commands. Doesn't work.
>Tries installing another plugin. Doesn't work.
>Changes a few more plugin commands. Doesn't work.
>Goes directly to the gamefont file and changes the src. Works.

YYEEEAAAAHHHAAAA

Perseverance is key, bois and girls.
What Reviews say on RPG Maker MZ?
Looking back at some sketches, and game design documents on my PC dated summer of 2015. I started development with the release of MZ, but in 2015, I felt a strong desire to make a game out of the blue. I remember feeling sad for no apparent reason, and all these ideas rushed into my head. Now that I think about it, since that day, everything has become easier to do on my PC . . . it’s very creepy.
Everything's going to be alright! We're all in this together. <3
Aaaaannd published my game's tech demo. :D

Feel free to download and play it. And give feedback!

Forum statistics

Threads
107,801
Messages
1,032,312
Members
139,946
Latest member
Yatsekonn
Top