RPG Maker MV - v1.6.1 Beta

Discussion in 'RPG Maker MV Improvement Boards' started by Archeia, Apr 13, 2018.

  1. SimProse

    SimProse Veteran Veteran

    Messages:
    343
    Likes Received:
    174
    Location:
    United States
    First Language:
    English
    Has anyone run into issues with: Failed to load extension from c:/[gamefolder here]. Manifest file is missing or unreadable.

    I updated 1.6.1, using Yanfly's newest desktop optimization module. Otherwise followed instructions. Game ran fine before.

    How odd! Suddenly, NO RPG Maker game will run. I get the same error.

    I should say Playtesting doesn't work. Running a compiled game seems to work ok.

    Hmm, moving back to 1.5.2 fixes the issue. Odd indeed.
     
    Last edited by a moderator: Apr 17, 2018
    #41
  2. RayKamiya

    RayKamiya Villager Member

    Messages:
    11
    Likes Received:
    7
    First Language:
    English
    Primarily Uses:
    N/A
    Hey guys after updating to version 1.6.1 i'm trying to test my game but I keep getting an Error Loading extension message

    upload_2018-4-16_17-51-52.png

    This happens when I try and do a test Battle or a play test of game projects.

    does anyone have any idea on how to fix this? or do I have to revert back to 1.5.2?
     

    Attached Files:

    #42
  3. Jonforum

    Jonforum Veteran Veteran

    Messages:
    1,474
    Likes Received:
    1,191
    Location:
    Canada / Québec
    First Language:
    French
    Primarily Uses:
    RMMV
    @SimProse @RayKamiya
    Manifest file is missing or unreadable was your package.json
    Create or copy one in your root project directory
    Its not a bug
     
    #43
  4. RayKamiya

    RayKamiya Villager Member

    Messages:
    11
    Likes Received:
    7
    First Language:
    English
    Primarily Uses:
    N/A

    Okay, Thank you I replaced the Package.json File and I can play test the game, however when I try and do a Battle test now from the Database it boots up my Game from the beginning Rather than booting up my test fight

    upload_2018-4-16_18-8-41.png

    upload_2018-4-16_18-9-43.png
     

    Attached Files:

    #44
  5. KaYsEr

    KaYsEr Koruldia Veteran

    Messages:
    193
    Likes Received:
    401
    Location:
    London
    First Language:
    French
    Primarily Uses:
    RMMV
    Wow, this is great! I just tried the beta and everything is OK (no plugin incompatibility so far), sure I've done the updates from @Yanfly at the same time but I also have some other plugins as well and they’re all fine.

    But of course, the best part >> better performances!! Can't wait to try a build on some sluggish machine to really check the difference but I can already tell it’s better even on a powerful desktop.

    Good job!
    Any idea why PIXI is still 4.5.4 instead of the new one, I tried to add the new one (4.7.3) and my game “feels” similar so… Maybe that’s why you don’t bother updating yet.
     
    #45
  6. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    13,988
    Likes Received:
    12,941
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    Because there is no reason to upgrade PIXI. It might just introduce new issues.
     
    #46
    KaYsEr and Robpoke like this.
  7. Jonforum

    Jonforum Veteran Veteran

    Messages:
    1,474
    Likes Received:
    1,191
    Location:
    Canada / Québec
    First Language:
    French
    Primarily Uses:
    RMMV
    ...
    do not say that, kind of thing you risk misleading beginners.
    It has everything to gain by keeping the engine up to date.
    I think you want to say that it's too tiring to follow all fast updates from pixi.js
    ,as well as modules that you or the others have to implement.

    @KaYsEr you can keep update the engine ,guys from PIXI code always with surcharge.
    so if you use something obsolete, it will work but with have alert only.

    note: this will not append from pixi 5.0
    because most of the engine has been re-writhed.
     
    Last edited: Apr 17, 2018
    #47
    KaYsEr and elpeleq42 like this.
  8. Archeia

    Archeia Level 99 Demi-fiend Staff Member Developer

    Messages:
    13,988
    Likes Received:
    12,941
    Location:
    Game Dev Salt Mines
    First Language:
    Filipino
    Primarily Uses:
    VNM
    It is what it is. There's no reason to update the PIXI engine to a new version. It might (keyword, MIGHT) introduce new issues because of changes and the current plugin ecosystem may or may not be affected. That's minus whatever game player engine issues we might have. I don't understand what I said would be misleading. The risks are already implied. Do I have to spell out everything?
     
    Last edited: Apr 17, 2018
    #48
    djDarkX, SimProse and Robpoke like this.
  9. SimProse

    SimProse Veteran Veteran

    Messages:
    343
    Likes Received:
    174
    Location:
    United States
    First Language:
    English
    Well put. Anytime you change something in the ecosystem (new PIXI for example), the rest of the infrastructure may change or become unstable. That's one of the laws of any system, including programming or computer applications.

    I did solve my issue (actually forgot the package.json) but found out that SRD's Super Tools won't work with 1.6.1 -- I get a "'window_TitleCommand' is undefined" type error that goes away when I disable the plugin. Who knows if it'll get updated.
     
    #49
  10. ArtikDart

    ArtikDart Villager Member

    Messages:
    23
    Likes Received:
    7
    First Language:
    Italiano
    Primarily Uses:
    RMMV
    Hi ^^ I had the same problem. I solved by moving Super Tools under "YEP_CoreEngine & YEP_X_CoreUpdatesOpt". Test.
    (sorry for my bad English) ...
     
    #50
  11. elpeleq42

    elpeleq42 Veteran Veteran

    Messages:
    355
    Likes Received:
    147
    Location:
    Brazil
    First Language:
    Portuguese(BR)
    Primarily Uses:
    RMMV
    Honestly: that fear of updating the engine (both Nwjs, pixi, and some key parts of MV core) was what made this engine be, for so long, slow and full of bugs. And that, mainly in the first year, allowed many bad reviews of MV to appear, impacting the amount of people buying.

    Both NwJS and Pixi are always retrocompatible, as much as possible(if something is removed, it's because that thing was slow/poorly made or had security risks), so nearly no plugin is going to break(and those that break can be easilly fixed, or were old plugins that are not updated anymore and honestly should be forgotten/not used for that)
     
    #51
    trapless, Poryg and Oscar92player like this.
  12. RayKamiya

    RayKamiya Villager Member

    Messages:
    11
    Likes Received:
    7
    First Language:
    English
    Primarily Uses:
    N/A
    So to repeat my last issue since it got ignored...

    I had an issue with my Game not loading when I test play it, I resolved it but now when I try and do a battle test to test skills and enemy party's rather than boot up the battle screen and having me fight the monsters I get my game booting up from the title screen.
     
    #52
  13. PlayerLin

    PlayerLin Warper Member

    Messages:
    1
    Likes Received:
    0
    First Language:
    Chinese
    Primarily Uses:
    RMMV

    I have this problem, fixed by copy 1.6.1's all rpg_*.js and main.js(NOT plugins.js) to my project directory then go battle test again and it works now.
    (Looks like for some reasons, my YEP_X_CoreUpdatesOpt 1.6.1 do not working and I have to manual update those base core files but whatever, it working now.)
     
    #53
  14. Krimer

    Krimer Veteran Veteran

    Messages:
    122
    Likes Received:
    82
    Location:
    Kiev, Ukraine
    First Language:
    Ukrainian
    @RayKamiya There are no such problem in new project, at least on my end, so it's your local problem with plugins or you're not properly update your project or something else. I can't say more because i don't know how to reproduce your problem, in my project test battle from database runs fine with no issues.

    So check your plugins by yourself or provide more information.
    Try to disable all your plugins and if problem disappears try to find what plugin interference with battle test.
     
    #54
  15. RayKamiya

    RayKamiya Villager Member

    Messages:
    11
    Likes Received:
    7
    First Language:
    English
    Primarily Uses:
    N/A

    I have tried removing the Plugin's and disableing them and it doesn't fix the issue, but I'm gonna try and move my data over to a new folder and see if that helps.

    Tried to open a new project and it worked, so I moved my current project files to the new folder and I got the same issue...
     
    Last edited: Apr 18, 2018
    #55
  16. Milennin

    Milennin "With a bang and a boom!" Veteran

    Messages:
    1,935
    Likes Received:
    947
    Location:
    Fiore
    First Language:
    English
    Primarily Uses:
    RMMV
    Does this update fix the bug within the editor that messes with the scrollbar when opening a list of entries or editing a common event?
     
    #56
  17. Dungeonmind

    Dungeonmind Lvl 4000 Humanoid Veteran

    Messages:
    399
    Likes Received:
    203
    Location:
    Canada,Ontario
    First Language:
    English
    Primarily Uses:
    RMMV
    @Milennin i can confirm that it doesn’t fix that bug because I experienced it as well when deleting a bunch of event command it acts all wonky.
     
    #57
  18. Yulia

    Yulia Veteran Veteran

    Messages:
    63
    Likes Received:
    87
    Location:
    Russia, Saint-Petersburg
    First Language:
    Russian
    Primarily Uses:
    RMMV
    Just tried it, it works much faster now, but picture is blurry for some reason...
     
    #58
  19. Milennin

    Milennin "With a bang and a boom!" Veteran

    Messages:
    1,935
    Likes Received:
    947
    Location:
    Fiore
    First Language:
    English
    Primarily Uses:
    RMMV
    Thanks. So has there been any official acknowledgement of this bug and if so, any plans on fixing it soon?
     
    #59
  20. clitvin

    clitvin Veteran Veteran

    Messages:
    91
    Likes Received:
    10
    After upgrade to 1.6.1 running from the editor playtest is false.
    upload_2018-4-18_21-22-56.png
     
    #60

Share This Page