Announcement RPG Maker MV - v1.6.1 Stable Release!

AdamSakuru

[Null_Value]
Veteran
Joined
Mar 14, 2014
Messages
314
Reaction score
170
First Language
English
Primarily Uses
N/A
I made backups of my project and tried to update a copy of it to V 1.6.2.

There were certain things that didn't work, but my game would slow down quite a bit when I opened the console for any reason. This never happened on V 1.5.2. I'm pretty sure I followed the instructions properly. Is the console lagging the game normal in this version or something?
 

TenTranVN

Veteran
Veteran
Joined
Apr 13, 2017
Messages
162
Reaction score
17
First Language
Vietnam
Primarily Uses
RMMV
I hope in the 1.6.2 version or in the future this engine will better support mobile. Especially multi-touch. Because the VXA engine has done well for PC, I think the MV should have a different focus on mobile spending
 

Alexandr_7

Veteran
Veteran
Joined
Apr 22, 2016
Messages
46
Reaction score
8
First Language
Russian
Primarily Uses
Interesting, and there will be more updates?
 

Alexandr_7

Veteran
Veteran
Joined
Apr 22, 2016
Messages
46
Reaction score
8
First Language
Russian
Primarily Uses
Obviously there will be no more updates.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,207
Reaction score
6,762
First Language
German
Primarily Uses
RMMV
Obviously there will be no more updates.
if you had read the rest of the forum then you would have known that the next update has already had its content and the reason for the delay named: appearently they're waiting for the next pixi update to include that....
 

Aloe Guvner

Walrus
Veteran
Joined
Sep 28, 2017
Messages
1,627
Reaction score
1,066
First Language
English
Primarily Uses
RMMV
appearently they're waiting for the next pixi update to include that....
Curious, where was that mentioned? I missed that as well.

PIXI v5 was released in April, but I understand the MV devs would have to adjust the rpg_core.js to use it. However, Archeia said here there were no plans to upgrade the PIXI version (but maybe that changed).
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,207
Reaction score
6,762
First Language
German
Primarily Uses
RMMV
@Aloe Guvner there was a topic a few weeks ago where someone asked if there were any updates coming or if MV has stopped updating (a new topic with a title about that, not something here) and several of the answers pointed to an update about pixi that should be available in a few months. But I don't remember who said what there.
 

KaYsEr

Koruldia
Veteran
Joined
Mar 14, 2014
Messages
220
Reaction score
449
First Language
French
Primarily Uses
RMMV
@Aloe Guvner there was a topic a few weeks ago where someone asked if there were any updates coming or if MV has stopped updating (a new topic with a title about that, not something here) and several of the answers pointed to an update about pixi that should be available in a few months. But I don't remember who said what there.
This is good news, if you find the original conversation feel free to link it here. Can't wait to learn more about that matter.
PIXI5 seems to be backward compatible with 4 so it's probably a wise move.
 

ShellyValeras

Beginner Game Maker
Veteran
Joined
Aug 13, 2018
Messages
52
Reaction score
40
First Language
English
Primarily Uses
RMMV
When did 1.6.2 come out? also how do i update from 1.6.1 safely without loosing my game data? Last time i updated i lost an entire demo's worth of a game.
 

Restart

Veteran
Veteran
Joined
Mar 15, 2019
Messages
315
Reaction score
205
First Language
English
Primarily Uses
RMMV

pka4916

Veteran
Veteran
Joined
Dec 24, 2017
Messages
69
Reaction score
20
First Language
Engish
Primarily Uses
RMMV
Is there a 1.6.2 ? I only see 1.6.1
 

Alexandr_7

Veteran
Veteran
Joined
Apr 22, 2016
Messages
46
Reaction score
8
First Language
Russian
Primarily Uses
Maybe someone knows for sure whether there will be updates or decided to forget about RPG Maker MV?
It seems like they are now busy with Pixel Game Maker MV.
Может кто знает точно будет ли обновления или решили забыть про RPG Maker MV?
Вроде как они теперь заняты над Pixel Game Maker MV.
 

Eliaquim

Raze: The Rakuen Zero's Guardian!
Veteran
Joined
May 22, 2018
Messages
943
Reaction score
382
First Language
Portuguese - Br
Primarily Uses
RMMV
Well just here because I'm anxious to a new update on the code ^^''
I have used 1.6.1 community version, and I really like the small improvements. Also I' m not always sure that plugins that made bugfixes like Yanfly, Triacontanne, and Mpp still working for the purpose of it.
 

Skurge

" (GASP) What's going on!? "
Veteran
Joined
Jul 12, 2015
Messages
1,075
Reaction score
223
First Language
English
Primarily Uses
N/A
Uh wierd, I don't recall MV making tilesets ABCDER Larger? When did this occur? I must of missed this somehow.
 

evmaster

Think Outside the Box
Veteran
Joined
Sep 1, 2015
Messages
479
Reaction score
728
First Language
English
Primarily Uses
RMMV
I just updated my game and F8 and F9 seems to be working now. But I have a question.

This step: Copy the files libs folder, "rpg_*.js" (example: rpg_core) files from NewData/js to your project js folder
I could not make work.

So I just copied the whole "js" file from the new project, delete the old one and pasted it.

So my question is, will I have any future problems doing it this way?
 

MushroomCake28

KAMO Studio
Moderator
Joined
Nov 18, 2015
Messages
2,216
Reaction score
3,580
First Language
English
Primarily Uses
RMMV
I just updated my game and F8 and F9 seems to be working now. But I have a question.

This step: Copy the files libs folder, "rpg_*.js" (example: rpg_core) files from NewData/js to your project js folder
I could not make work.

So I just copied the whole "js" file from the new project, delete the old one and pasted it.

So my question is, will I have any future problems doing it this way?
The js folder contains 3 types of things: javascript libraries, the rpg maker default core plugins, and third party plugins (in js/plugins). What needs to be updated when the engine is updated is the javascript libraries and the rpg maker default core plugins.

If you replaced the whole folder, make sure to transfer your third party plugins from the old version to the new version. Also, the reason we ask people to backup their project before updating their project is because someone of the third party plugins might not be compatible with the rpg maker core plugins' update.
 

evmaster

Think Outside the Box
Veteran
Joined
Sep 1, 2015
Messages
479
Reaction score
728
First Language
English
Primarily Uses
RMMV
I don't use or have plugins, so will I be fine?
 

erestorpat

Villager
Member
Joined
Jan 16, 2016
Messages
17
Reaction score
1
First Language
french
Issue when I try to update my game... and before you ask, YES I DID update all the specified files and YES I DID try with all plugins deactivated.
1581094791238.png
 

Users Who Are Viewing This Thread (Users: 0, Guests: 3)

Latest Threads

Latest Posts

Latest Profile Posts

I am feeling better about my update schedule, I feel like I am actually getting consistent work done even if it isn’t big updates.
It's a joy to work on a well-made map. I am not regretting this commission in the least!
I'm currently being attacked by the RPG Maker Hydra: fixing one problem only to have two more rise to take its place.
Hey you! Yeah YOU! Whatcha doin' not backing up your projects? You a masochist or sumthin'? GO BACK UP YOUR PROJECTS! Sheeesh... Didn't think I'd hafta spell it out for yas.

Forum statistics

Threads
94,290
Messages
919,711
Members
124,031
Latest member
Lavdiasmylove
Top