RMMV Rpg Maker MV YEP_Victoryaftermath Plugin Issue

Shinoodle

Villager
Member
Joined
May 10, 2021
Messages
6
Reaction score
1
First Language
German
Primarily Uses
RMMV
Hello Friends im new to this forum and the Rpg Maker community so i hope i post this at the right place.

I recently installed the Plugin Victory Aftermath from Yanfly with all the necessary Base Plugins in the correct Order.
But it seems that the Plugin isnt working correctly for me and all i know so far is that it could be because my monitor runs above 60 hz. I also tried Installing the YEP_FpsSynchOption Plugin from Yanfly to force the game to run at 60 fps even if its above but it didnt change anything. So basically what happens is that i win the encounter, then the victory screen opens up with the character sprite, then it starts lagging and the exp bar that should start filling up takes a dumb amount of time to fill up in a very unevenly responsive way. I also tried playing around with the Tickrate of the gauge filling rate but nothing seems to solve the issue. The Battle Spoils screen where you get the items seems to be fine tho and works correctly. I really dont know anymore what i could do and hope anyone of you may know the answer to my problem.

Base Information:
Rpg Maker version - 1.6.2 (Steam Version)
Monitor which i play on: Dell AW2518H (240hz)
Plugins installed in order: YEP_BattleEngineCore/YEP_X_ActSeqPack1-3/YEP_X_AnimatedSVEnemies/YEP_VictoryAftermath
Greetings Shinoodle
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
1,118
Reaction score
609
First Language
English
Primarily Uses
RMMV
The refresh rate of your monitor wouldn't make a program running on your computer be slower or faster - it could cause display artifacts, but it wouldn't change what your computer is doing.

What are the specs of your hardware? It sounds like your computer itself is chugging to process the operations being performed rapidly and draw the updated screen. Do you have a dedicated graphics card?

Are there any other events running in parallel in your game project that could be contributing to the lag?
 

Shinoodle

Villager
Member
Joined
May 10, 2021
Messages
6
Reaction score
1
First Language
German
Primarily Uses
RMMV
Hey @ATT_Turan

Specs are:

Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz 3.40 GHz
RAM 16.0 GB
GPU GTX 980 TI
and also W10 on 64-bit

I also tried installing the plugin on a new project and i still had the same issues so i doubt it could be the events that cause the issue.

.
 

Shinoodle

Villager
Member
Joined
May 10, 2021
Messages
6
Reaction score
1
First Language
German
Primarily Uses
RMMV
I solved the problem i had.
The FpsSync Plugin didnt help but i had to add this line "chromium-args": "--limit-fps=60"
in the Project\package.json file.
Basically it has to look like this in the end.

{
"name": "",
"main": "index.html",
"js-flags": "--expose-gc",
"window": {
"title": "",
"toolbar": false,
"width": 816,
"height": 624,
"icon": "icon/icon.png"
},
"chromium-args": "--limit-fps=60"
}

Maybe this helps someone else aswell.
Can be closed ty.
 

Latest Threads

Latest Profile Posts

BCj
Made a logo for Mana Star :D
330bb1fde7bb06b13e23fefd83501163.png
it's e3 season again..!
Today is a day of optimizations.

Forum statistics

Threads
112,174
Messages
1,066,338
Members
145,765
Latest member
Bubix
Top