RMMZ RPG Maker MZ not displaying ported over MV animations from spritesheets

OverTheTop123

Villager
Member
Joined
Nov 22, 2020
Messages
19
Reaction score
7
First Language
English
Primarily Uses
RMMZ
Screenshot_10.png

Hi,

I went to update but none of my ported over MV animations work now after updating the battlecore for VisuStella (and corescript for RPG Maker MZ), should I just re-do them/revert to an older version or is there another solution I'm missing?
 
Last edited:

Aerosys

Veteran
Veteran
Joined
Apr 23, 2019
Messages
696
Reaction score
671
First Language
german
Primarily Uses
RMMZ
Have you updated the Core scripts of your game? Updating the Maker and updating the game is not the same. There's a menu button on top of the maker "update core scripts"
 

OverTheTop123

Villager
Member
Joined
Nov 22, 2020
Messages
19
Reaction score
7
First Language
English
Primarily Uses
RMMZ
Have you updated the Core scripts of your game? Updating the Maker and updating the game is not the same. There's a menu button on top of the maker "update core scripts"
This happens even on the latest core script I'm afraid.
 

OverTheTop123

Villager
Member
Joined
Nov 22, 2020
Messages
19
Reaction score
7
First Language
English
Primarily Uses
RMMZ
I have a slight development. When I make a stock project with just the base features (and the Visutella) additions, the sprites are able to be read again, but seem to just not work at all on my current project even though everything is updated properly to my knowledge. I'm just beyond confused to be honest because it worked fine just last week.
 

Arthran

Veteran
Veteran
Joined
Jun 25, 2021
Messages
194
Reaction score
173
First Language
English
Primarily Uses
RMMZ
From the looks up it, VisuStella Core Engine is causing the error, while it's attempting to set the frame rate of the animation. They likely added that feature in a recent update, since some MV animations need to be run faster than the default setting in order to look right.

If I were to venture a guess, it's probably expecting you to have set some type of parameter in the plugin settings, in order to tell the plugin what speed to default to for MV animations. Since you're upgrading from an older version, where that parameter didn't exist, it might be blank, and that might be causing your error.

I'd recommend that you comb through the Core Engine plugin settings, find the parameter that deals with animation rate (I suspect they'd have stuck in in Quality of Life -> Misc, and make sure it is set to something (default should likely be 4).
 

OverTheTop123

Villager
Member
Joined
Nov 22, 2020
Messages
19
Reaction score
7
First Language
English
Primarily Uses
RMMZ
From the looks up it, VisuStella Core Engine is causing the error, while it's attempting to set the frame rate of the animation. They likely added that feature in a recent update, since some MV animations need to be run faster than the default setting in order to look right.

If I were to venture a guess, it's probably expecting you to have set some type of parameter in the plugin settings, in order to tell the plugin what speed to default to for MV animations. Since you're upgrading from an older version, where that parameter didn't exist, it might be blank, and that might be causing your error.

I'd recommend that you comb through the Core Engine plugin settings, find the parameter that deals with animation rate (I suspect they'd have stuck in in Quality of Life -> Misc, and make sure it is set to something (default should likely be 4).
I can definitely see that making sense. Alright, after giving this a try on both higher and lower settings with the default as 4, the error keeps occurring. however, so I wonder if it's something I have to somehow tie to the specific animations maybe?
 

Arthran

Veteran
Veteran
Joined
Jun 25, 2021
Messages
194
Reaction score
173
First Language
English
Primarily Uses
RMMZ
I can definitely see that making sense. Alright, after giving this a try on both higher and lower settings with the default as 4, the error keeps occurring. however, so I wonder if it's something I have to somehow tie to the specific animations maybe?
Unfortunately, I don't know. I haven't updated my Core Engine in a while, and since I've already got a different solution in place for animation rates, I'm a little reluctant to do so now.

If you're comfortable uploading your project file to Google Drive or something, and PMing me a link, I'd be happy to take a look and see if I can figure out what the problem is. I can't guarantee anything, but I am at least 90% confident that I can figure it out for you.

But if you'd rather not have somebody else see your project at this time, I fully understand and won't be offended or anything like that.
 

OverTheTop123

Villager
Member
Joined
Nov 22, 2020
Messages
19
Reaction score
7
First Language
English
Primarily Uses
RMMZ
Unfortunately, I don't know. I haven't updated my Core Engine in a while, and since I've already got a different solution in place for animation rates, I'm a little reluctant to do so now.

If you're comfortable uploading your project file to Google Drive or something, and PMing me a link, I'd be happy to take a look and see if I can figure out what the problem is. I can't guarantee anything, but I am at least 90% confident that I can figure it out for you.

But if you'd rather not have somebody else see your project at this time, I fully understand and won't be offended or anything like that.
Actually dude, you saved me! I completely forgot to apply the change prior to re-testing, and it worked perfectly. Thank you so much!
 

Arthran

Veteran
Veteran
Joined
Jun 25, 2021
Messages
194
Reaction score
173
First Language
English
Primarily Uses
RMMZ
No problem. Glad you got it figured out.
 

Latest Threads

Latest Profile Posts

its_a_random_world.jpg
Well after half a year of health problems (that aren't as bad as before), and playing with UE4 & 5... I realized I should finish this project before working on something else. So I decided to upgrade my randomizer. And really just focus on compromising wherever I can to finish the project sooner rather than later. :kaoswt:
hmmm. an art of mine was removed from reddit, for a reason not even listed.

Forum statistics

Threads
121,889
Messages
1,144,947
Members
160,143
Latest member
Krockhunter
Top