Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,284
Reaction score
15,733
First Language
Filipino
Primarily Uses
RMMZ
What do you require? What type of information do you need to see? A video? Logs? Though that last one might be problematic, Windows doesn't allow me to see the proper log, but it is logged. If I can help with anything let me know. It really is a very bothersome bug.

It should be something we'd be able to emulate. Like if we open the project would we get the same issue? What's your computer specs? etc. etc. It has to be a full in-depth report.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,769
Reaction score
14,530
First Language
English
Primarily Uses
RMVXA
One thing to always check: Restart your computer. And I mean with the restart button on windows. Do NOT use shutdown for this test, it will not help.

Reason I say is I hit this issue in ACE and it was because the RGSSx player got garbaged in windows. A restart fixed it. So I'd see if that helps with MV/MZ.
 

Winshifter

Veteran
Veteran
Joined
Feb 24, 2017
Messages
65
Reaction score
51
First Language
Spanish
Primarily Uses
RMMV
It should be something we'd be able to emulate. Like if we open the project would we get the same issue? What's your computer specs? etc. etc. It has to be a full in-depth report.
I actually provided that information literally days after version 1.0 was released, it seems several others provided their information. My guess is that it got confused with the audacity apparent issue with MZ .ogg files that for some reason made the file explorer in Windows to crash.

This is what I posted back then

I have a similar problem. Everytime I have to open a folder fom the MZ program it crashes. I uninstalled Audacity and solved it partially, but I still have the same issue.

My computer specs are:
Windows 10
Core i7 5500 CPU 2.4 GHz
8GB RAM
1TB HDD
Version: PC (not Steam)
If anything, what I didn't add is that is a laptop and also has an NVIDIA GeForce 920M graphics card. I also have a procmon file if it helps.

Also, restarting my computer doesn't work. And the audacity thing affected my computer even in MV but not as notorious as with MZ .ogg files. Since I currently don't have installed audacity that is a non issue for the moment.

This are the threads in which I posted that information and even mentioned steps and everything. Like I said, maybe it got lost in all the issues you might get, that is understandable.


So far the software is usable, but for example, it prevents me from saving anything I have created in the Character generator, importing anything using the editor or select any forlder from the editor. So for example, if I want to create a new project and need to change the folder in which it will be saved, I need to copy the full path into the text field, If I ever dare to use the choose button, the software crashes after about 15 seconds, the same happens if I ever use the open project option. This only happens in MZ, MV doesn't have that problem. So my best guess is that something changed in the editor software handling the opening of the file system and that is what is causing this issue or some execption that in MV was caught is no longer being catch in MZ or that MZ expects something in a certain way but not everyone will have their settings in that particular way or a framework issue that is beyond your support.

Sorry for the long post, but since this update solved a crashing issue in Macs, I figured that maybe you might have the Windows issue in your backlog.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,769
Reaction score
14,530
First Language
English
Primarily Uses
RMVXA
The audacity issue is the .ogg file extension is messed up. But that is a your computer issue and I don't think the MZ team can fix it. The best fix I've seen is this:

1: Remove audacity.
2: Select an .ogg file to fix the association back to windows default.
3: Reinstall audacity.

It has worked so far for most people that I've seen.

Also @Archeia I reported this too with version 1.0 too, when trying to open a directory with sound files crashing the computer. I couldn't even open the default SE directory from MZ without a crash until I removed audacity.
 

Winshifter

Veteran
Veteran
Joined
Feb 24, 2017
Messages
65
Reaction score
51
First Language
Spanish
Primarily Uses
RMMV
The audacity issue is the .ogg file extension is messed up. But that is a your computer issue and I don't think the MZ team can fix it. The best fix I've seen is this:

1: Remove audacity.
2: Select an .ogg file to fix the association back to windows default.
3: Reinstall audacity.

It has worked so far for most people that I've seen.

Also @Archeia I reported this too with version 1.0 too, when trying to open a directory with sound files crashing the computer. I couldn't even open the default SE directory from MZ without a crash until I removed audacity.
Yes, I know, I removed Audacity so, that for me currently is not an issue really. The crashing just by trying to choose a folder from MZ editor is what is really bugging.
 

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,284
Reaction score
15,733
First Language
Filipino
Primarily Uses
RMMZ
Nice, performance is always good news.
But i want to ask, is there a hope this issue reported earlier will be fixed in future? Because right now effekseer is pretty useless in MZ for me and i think for many others.

Give me a sample project that emulate this and we'll try to fix.
 

Mr. Detective

NATO Special Operative
Veteran
Joined
Sep 9, 2012
Messages
866
Reaction score
338
First Language
English
Primarily Uses
N/A
I updated the program via Steam. Got new problems:

- I am not able to run the program without Steam anymore. Before, I can just go into the folder, and open the application. Now, it forces me to go through Steam, asks for my confirmation "RPG Maker MZ is attempting to run with optional parameters below", and I have to confirm this every time I open the application. I didn't make any changes in Steam, either. This never happened before.
- Now, the FPS counter shows up in various places: drop down menu, bottom UI, and in the game. Again, never happened before this update.

02.jpg03.jpg

This is very frustrating. It's an update, not a downdate. I'm afraid to update many programs because of this sort of thing. Hope you guys can find a fix soon.

Edit: Disable the option to allow Steam overlay seems to fix the problem with the FPS counter. But why the hell was it automatically enable to begin with...? Still can't launch the program without Steam, though. Now I found another problem:

022.jpg

I swear this wasn't like this.

Another minor thing that bugs me is the screen becomes like this when I playtest the project, although briefly:

022.jpg

Sometimes, there'd be a cutoff of a picture of something, perhaps some other program, in the middle of the screen. It's not severe, but still annoying and bizarre.

Update:

The screen tearing happens even in a vanilla project with no plugins whatsoever. I created a new one, opened the menu and saw the same thing:

2.jpg

Corescript 1.2.0 seems to be the culprit. Again, just downgrading it back to 1.1.1. "fixes" the problem.

My specs:

B550 MSI Edge
CPU Ryzen 3600
GPU 1660 Super MSI Gaming X
16 GB Ram G Skill Trident
1920x1080 Asus 24-inch monitor
 
Last edited:

howaboutno

Veteran
Veteran
Joined
Nov 21, 2014
Messages
61
Reaction score
72
First Language
English
Primarily Uses
N/A
I updated the program via Steam. Got new problems:

- I am not able to run the program without Steam anymore. Before, I can just go into the folder, and open the application. Now, it forces me to go through Steam, asks for my confirmation "RPG Maker MZ is attempting to run with optional parameters below", and I have to confirm this every time I open the application. I didn't make any changes in Steam, either. This never happened before.

I'm also having this problem now too after the update. I get the confirmation message every single time as well. On top of that I can no longer open multiple projects as Steam just refuses to do it. This is another huge problem for me because I like to copy and paste things (like Javascript, among many other things) between my projects.

I hope this will be fixed.... :kaosigh:
 

Mr. Detective

NATO Special Operative
Veteran
Joined
Sep 9, 2012
Messages
866
Reaction score
338
First Language
English
Primarily Uses
N/A
Update: I downgraded the corescript back to 1.1 again and the problem with the lines in the menu is gone. So this update can potentially break other plugins. Terrifying.

Pretty sure MV had similar issues a few years back, no?
 

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,284
Reaction score
15,733
First Language
Filipino
Primarily Uses
RMMZ
Hi everyone,
First we're sorry for the issue with Steam. We have fixed the issue in regards to that.

As for the other reports, please first try to make sure that when you are reporting issues:

1. The screen tearing with play test, does that happen in vanilla project? This should be your baseline before you report anything. If you can emulate it in a New Project with the new version of RPG Maker MZ, then it's an RPG Maker MZ bug. If it's caused by a plugin, that means the plugin developer has to change something to make it compatible with the new nwjs framework.

2. If you want to report editor bugs, we would need to know everything. Remember, this is a PC-specific issue. IF we don't have the exact same environment as you do, your DPI settings, pc specs and so on, we cannot help at all.

3. We need every info. If you report something or find other people reporting it and we haven't been able to fix for the update, it would help us a lot to have it in a single post that doesn't require me to click 8 other topics and read through slews of reply. Please make it sweet, succinct and something we can emulate. Otherwise we won't be able to fix it!
 

Krimer

Veteran
Veteran
Joined
May 10, 2013
Messages
153
Reaction score
117
First Language
Ukrainian
Give me a sample project that emulate this and we'll try to fix.
I deleted effekseer long ago so for now i dont have good examples. I think @JosephSeraph do more deep research so better ask him, but i can create simple test if needed, you can see problem with pretty much anything, i think its scale problem in MZ too.
Here test project - link
effekseer
c133187473482f0bafb9754ae0c7700e.png


MZ
dbd048659905c08a67b123cdf709d878.png
With bigger animation its a lot worse to look at it. But in effekseer all looks good.
 

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,284
Reaction score
15,733
First Language
Filipino
Primarily Uses
RMMZ
I deleted effekseer long ago so for now i dont have good examples. I think @JosephSeraph do more deep research so better ask him, but i can create simple test if needed, you can see problem with pretty much anything, i think its scale problem in MZ too.
Here test project - link
effekseer
c133187473482f0bafb9754ae0c7700e.png


MZ
dbd048659905c08a67b123cdf709d878.png
With bigger animation its a lot worse to look at it. But in effekseer all looks good.

OK, thanks.
 

Mr. Detective

NATO Special Operative
Veteran
Joined
Sep 9, 2012
Messages
866
Reaction score
338
First Language
English
Primarily Uses
N/A
@Archeia
1. The screen tearing with play test, does that happen in vanilla project? This should be your baseline before you report anything. If you can emulate it in a New Project with the new version of RPG Maker MZ, then it's an RPG Maker MZ bug. If it's caused by a plugin, that means the plugin developer has to change something to make it compatible with the new nwjs framework.

2. If you want to report editor bugs, we would need to know everything. Remember, this is a PC-specific issue. IF we don't have the exact same environment as you do, your DPI settings, pc specs and so on, we cannot help at all.

The screen tearing happens even in a vanilla project with no plugins whatsoever. I created a new one, opened the menu and saw the same thing:

2.jpg

Corescript 1.2.0 seems to be the culprit. Again, just downgrading it back to 1.1.1. "fixes" the problem.

And no. The Steam issue has not been fixed at all! I still have to give Steam permission to run the program every time I try to run the application. Seriously, did the people who made the update even playtest the engine at all!? I refuse to believe this is something hard to emulate or notice! I'll keep playtesting to see if anything else is messed up.
But at the moment, staying with 1.1.1. is the safest option and I'd advise everyone else to refrain from updating anything until this is sorted out.

My specs:

B550 MSI Edge
CPU Ryzen 3600
GPU 1660 Super MSI Gaming X
16 GB Ram G Skill Trident
1920x1080 Asus 24-inch monitor

Let me update this to my original post as well.
 
Last edited:

howaboutno

Veteran
Veteran
Joined
Nov 21, 2014
Messages
61
Reaction score
72
First Language
English
Primarily Uses
N/A
I can also confirm that the Steam issue has not been fixed for me as well. Every time I try to launch RPG Maker MZ from my projects folder in Documents Steam pops up and gives a message saying: "RPG Maker MZ is attempting to launch with the optional parameters shown below"

" "C:\Users\Username\Documents\RMMZ\Project\game.rmmzproject" "

If you did not request this launch or do not understand these options, select Cancel.

This message pops up every time I try to open my project to work on it. Also, this causes the issue of Steam refusing to allow me to open up more than one instance of RPG Maker MZ (such as multiple projects).

I've also noticed little updates to RPG Maker MZ on the Steam client and have been actively updating in hopes that one of them will fix the issue. So far, as of this post, it's still not working. Hope this helps! And fingers crossed this can be fixed. :kaoswt2:
 
Last edited:

Aesica

undefined
Veteran
Joined
May 12, 2018
Messages
1,735
Reaction score
1,663
First Language
English
Primarily Uses
RMMV
- I am not able to run the program without Steam anymore. Before, I can just go into the folder, and open the application. Now, it forces me to go through Steam, asks for my confirmation "RPG Maker MZ is attempting to run with optional parameters below", and I have to confirm this every time I open the application. I didn't make any changes in Steam, either. This never happened before.
I'm having this same problem too and it's really annoying. I hope this wasn't done intentionally for whatever reason. I wish I'd known ahead of time because nothing in the update is worth this added inconvenience.
 

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,284
Reaction score
15,733
First Language
Filipino
Primarily Uses
RMMZ
@Archeia


The screen tearing happens even in a vanilla project with no plugins whatsoever. I created a new one, opened the menu and saw the same thing:

View attachment 181816

Corescript 1.2.0 seems to be the culprit. Again, just downgrading it back to 1.1.1. "fixes" the problem.

And no. The Steam issue has not been fixed at all! I still have to give Steam permission to run the program every time I try to run the application. Seriously, did the people who made the update even playtest the engine at all!? I refuse to believe this is something hard to emulate or notice! I'll keep playtesting to see if anything else is messed up.
But at the moment, staying with 1.1.1. is the safest option and I'd advise everyone else to refrain from updating anything until this is sorted out.

My specs:

B550 MSI Edge
CPU Ryzen 3600
GPU 1660 Super MSI Gaming X
16 GB Ram G Skill Trident
1920x1080 Asus 24-inch monitor

Let me update this to my original post as well.

I tested it in several computers and do not have this problem. And yes people do test it. But you know, sometimes deploying to a final branch can cause issues and Steam is their own entity and can do updates that the dev doesn't know about when the branch finally goes live.

Thanks for the PC Specs. It'll help. I also tried making a new game in 1.2.0 and I don't get the same issue as you:
1614984944975.png

- I am not able to run the program without Steam anymore. Before, I can just go into the folder, and open the application. Now, it forces me to go through Steam, asks for my confirmation "RPG Maker MZ is attempting to run with optional parameters below", and I have to confirm this every time I open the application. I didn't make any changes in Steam, either. This never happened before.
I'm having this same problem too and it's really annoying. I hope this wasn't done intentionally for whatever reason. I wish I'd known ahead of time because nothing in the update is worth this added inconvenience.

This is how Steam and RPGMaker has always worked. If it suddenly didn't do that then it would be working correctly. That's why the Standalone version exists. I'm pretty sure most Games and Software in Steam does the same thing. It will always open Steam.

If it's specifically just optional parameters, I opened 5 instances of MZ and there's no problem. Even with a project open. It doesn't ask for the optional parameters. I'd recommend reinstalling if it's causing that issue for you or Verify the Integrity of your cache.
1614984712173.png
 
Last edited:

howaboutno

Veteran
Veteran
Joined
Nov 21, 2014
Messages
61
Reaction score
72
First Language
English
Primarily Uses
N/A
This is how Steam and RPGMaker has always worked. If it suddenly didn't do that then it would be working correctly. That's why the Standalone version exists. I'm pretty sure most Games and Software in Steam does the same thing. It will always open Steam.

If it's specifically just optional parameters, I opened 5 instances of MZ and there's no problem. Even with a project open. It doesn't ask for the optional parameters. I'd recommend reinstalling if it's causing that issue for you or Verify the Integrity of your cache.

Prior to the 1.2.0 update Steam did not pop up with optional parameters. Now Stream requires a login for any location I open and now also has this optional parameter message every single time I try to open a project. And thirdly it also now will not allow me to have multiple instances open at the same time. I've never had any of these issues present until after I updated to 1.2.0.

I have done as suggested and have verified my files and it has not fixed the problem. Next I will try to completely re-install the program to see if that fixes the problem.

Edit: I've re-installed the program and it has not fixed the problem.
 
Last edited:

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,284
Reaction score
15,733
First Language
Filipino
Primarily Uses
RMMZ
Prior to the 1.2.0 update Steam did not pop up with optional parameters. Now Stream requires a login for any location I open and now also has this optional parameter message every single time I try to open a project. And thirdly it also now will not allow me to have multiple instances open at the same time. I've never had any of these issues present until after I updated to 1.2.0.

I have done as suggested and have verified my files and it has not fixed the problem. Next I will try to completely re-install the program to see if that fixes the problem.

Edit: I've re-installed the program and it has not fixed the problem.

Can you try closing your project. Close RPG Maker MZ. Open your project and do a re-instance.
1614990289203.png
 

HuLijin

Villager
Member
Joined
Oct 26, 2015
Messages
9
Reaction score
4
First Language
French
Primarily Uses
RMMZ
I can launch two instances of MZ, but I have to do the following:
- go to my steamapps folder and find the RPGMZ.exe, double click it
- it opens the last project i openned closed
- redo first and second steps for another instance of the editor
- go to the menu > File > Open... and choose another project

Trying to launch two instances via the Steam menu doesn't work.
Trying to launch two instances via the project files (game.rmmzproject) doesn't work.

I hope it can help @howaboutno

Edit
I have pinned the exe on several locations (task bar, windows menu) to avoid the hassle of the first step.
 
Last edited:

howaboutno

Veteran
Veteran
Joined
Nov 21, 2014
Messages
61
Reaction score
72
First Language
English
Primarily Uses
N/A
Can you try closing your project. Close RPG Maker MZ. Open your project and do a re-instance.
I've done what you've shown and then tried a re-instance and I'm still getting the same optional parameters issue. :frown:
I can launch two instances of MZ, but I have to do the following:
- go to my steamapps folder and find the RPGMZ.exe, double click it
- it opens the last project i openned
- redo first and second steps for another instance of the editor
- go to the menu > File > Open... and choose another project

Trying to launch two instances via the Steam menu doesn't work.
Trying to launch two instances via the project files (game.rmmzproject) doesn't work.

I hope it can help @howaboutno

Edit
I have pinned the exe on several locations (task bar, windows menu) to avoid the hassle of the first step.
Thank you, I've tried what you've suggested and this is indeed a work around to the issue. I'll have to use this method in the meantime. But, I still do hope this optional parameter thing gets fixed. :LZSsmile:
 

Latest Threads

Latest Posts

Latest Profile Posts

It can be frustrating that so many commercial games have used up titles that might otherwise be great for a project.
Light up explosions with QABS and Community Lighting.
qcPQHt9.gif
Doing RPG Maker News #18 | Moghunter is Back, Encrypt MV/MZ Plugins, Isometric Geometric Tiles

Forum statistics

Threads
110,655
Messages
1,054,979
Members
143,778
Latest member
dsdgdsfa
Top