RPGMaker MV refuses to start ..

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
RPGMaker MV is refusing to start. This happened randomly without any interference from me. The client SEEMS to start but all i get is a not responding white window. I have tried the following steps.

1. Wait for 30 mins. No change.
2. Uninstalled MV, Restarted Computer, Reinstalled.
3. Updated graphics driver.
4. Shut down my anti virus software and tried to start it.
5. Trying an earlier release of MV.
6. Tried running MV from a different project file than the one I was working on.
7. Cleared Steam Download Cache.

I have the Steam version of MV.

I don't get any error messages the application just doesn't work.

Some hardware info ..
Intel I7 3.6ghz
Nvidia GTX 1070
16gb Ram
Rpgmaker MV is NOT installed on an SSD and is in the same drive as the game I'm trying to open.
 
Last edited:

ScorchedGround

Blizzards most disappointed fan
Veteran
Joined
Apr 12, 2020
Messages
418
Reaction score
623
First Language
German
Primarily Uses
RMMV
Do you have the Steam or non-Steam version of MV?
 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
OP updated I have the steam version.
 

ScorchedGround

Blizzards most disappointed fan
Veteran
Joined
Apr 12, 2020
Messages
418
Reaction score
623
First Language
German
Primarily Uses
RMMV
Then you could try to empty your download cache.

For that go to your steam settings and then the "Downloads" tab.
At the bottom of the window is a button called "empty download cache".

This might fix the issue but it might not. It's worth a try atleast.
 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
Unfortunately that did nothing. Thanks for the suggestion tho.
 

bvlgari

Villager
Member
Joined
Jan 14, 2018
Messages
29
Reaction score
4
First Language
english
Primarily Uses
RMMV
This happened to me in the past. Turned out that i was trying to open the program with steam closed. Maybe you did some changes on steam config and didnt notice?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,112
Reaction score
7,999
First Language
German
Primarily Uses
RMMV
who is the manufacturer for your display driver? Microsoft or the company who build the chip of the card?

Microsoft's drivers don't fully support OGL, the original driver are better - but once the MS driver is in the update function will never switch back automatically
 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
I downloaded the drivers from the Nvidia site. I'm not 100% sure how to check that. The driver provider is listed as Nvidia if that's what that means. With the signer saying something about windows compatability publisher. Steam is definitely open. I have tried launching from steam and from the exe. Both have the same result.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,112
Reaction score
7,999
First Language
German
Primarily Uses
RMMV
The driver provider is listed as Nvidia if that's what that means.
That's what I was asking (my windows is in German and I didn't know how it is named in english), and its correct.

Then either there is an interference with a different program than your regular antivirus blocking it (perhaps a network security or parental guidance program or whatever similar), or a driver conflict with a different driver - have you tried updating your audio drivers? Those are rarely the cause, but I heard that two or three times before as the cause of a conflict.
 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
Sure will give it a try but it's not like the drivers conflicted 2 days ago. One day it was working okay the next bam .. no more MV for you. I did try updating but it told me drivers are up to date.

By the way I also tried running rpgmaker VxAce. That works fine. So this issue is unique to MV. As has already beem mentioned I have tried running the app with no other apps open, No windows, No antivirus, No Discord. Nothing. Only Steam and Rpgmaker. And it still does the same thing.

If you are correct the only thing I can think of is theres some kind of malware interfering. I will run a deep scan. And clean the pc out as best I can. But honestly I don't understand any of this. Why can't the app at least give me an error msg to tell me what went wrong rather than just freezing on launch like this. But i see that devs where too busy reskinning MV as MZ in rather than actually fixing something they made. I suppose that's too much to ask these days .. Honestly even before this the thing hard crashed on a whim and while trying to save. I don't know why this app had to make everything so hard ..
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,112
Reaction score
7,999
First Language
German
Primarily Uses
RMMV
By the way I also tried running rpgmaker VxAce. That works fine. So this issue is unique to MV.
I assumed so. Most of the things that can cause conflicts were introduced by MV, like using HTML5 as a base or OGL instead of DirectX to enable non-Windows-OS handling.

One other option: please check if your Windows was updated two days ago. Microsoft can make mistakes, and although it is rare I have heard of at least two different cases where a Windows-Update caused problems with MV and the user had to deinstall that automatic update or wait until the mistake was corrected in the next update.
 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
I looked at my update history. There where a couple of updates on the 15th October. But MV was working after those dropped. It only stopped a couple of days ago. I left it alone cos I was busy and assumed a restart would fix it. Honestly should I just develop in VxAce? I've literally lost count of the amount of times a hard crash or some rubbish like this has cost me months of work or taken weeks to fix. I'm honestly just .. so .. tired of this. I've been through this before on these forums too. Seems no one has any clue on why MV does what it do. And I've had this on 2 completely different Pc's, Multiple reinstalls of windows. I've persevered with this engine. I really really have. But I can't help feel now .. when all's said and done that my time wouldn't have been better spent learning to ren'py.
 
Last edited:

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
Incidentally. I can play games made in the engine just fine. I tried an old fix of putting the opengl.dll in the install folder. Did nothing. Well I can hardly abandon my project .. trying a pc reset. Wish me luck.
 

Celestrium

Worldsmith
Veteran
Joined
Mar 3, 2020
Messages
250
Reaction score
268
First Language
English
Primarily Uses
RMMZ
You could try a system restore in windows to take you back to before you had the problem...I am throwing ideas I would try...
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
32,112
Reaction score
7,999
First Language
German
Primarily Uses
RMMV
I tried an old fix of putting the opengl.dll in the install folder. Did nothing.
of course not - that never was for a problem like you're having now.

when MV was first published, it needed the newest of the OGL versions.
OGL is usually installed together with the display driver, but at that time there were a lot of display drivers that had not yet been updated to include this new OGL.
And if you had a display driver with an older OGL, then the solution was to install the newer library to the program itself,overriding the older version of the library inside the display driver.

But since that time, every display driver got updated to several newer OGL versions...
 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
Thanks Celestrium. I basically went one step further and did a full reinstall of windows. I'm really really hoping that fixes it. Will update.
 

RHachicho

Veteran
Veteran
Joined
Jan 16, 2016
Messages
273
Reaction score
127
First Language
English
Welp .. Whatever WAS the problem .. that fixed it. I hate to have to do so drastic a solution but it was honestly that or keep picking at straws for a week or two. Thanks for everyone who tried to help.
 

Celestrium

Worldsmith
Veteran
Joined
Mar 3, 2020
Messages
250
Reaction score
268
First Language
English
Primarily Uses
RMMZ
Windows has been doing updates that have been causing known issues, I had to uninstall an update because it caused errors when I tried to dual screen MZ.
Anyway, I am glad you got the problem fixed, its frustrating to have technical issues like that.
 

Latest Threads

Latest Posts

Latest Profile Posts

Today is the day! I will be productive in game dev work! I will - *gets distracted by cat playing with her toy mouse* Awww <3
Whelp. I tried to be productive.
Decided to work on Fandom Scouts today. I've decided that instead of using the generic "scrolling text" event that MV has (I'm using MV for FS, not MZ) I'll use the movie option. I'm still trying to find a way to get Premiere Pro to output the compatible format though. If anyone can give me some help, it would be greatly appreciated!
Barthdry wrote on tln143's profile.
Hello tln143 Welcome to the RPG Maker Forum. We wish you enjoy and make good rpg games
Barthdry wrote on 00cassiesmells's profile.
Hello 00casiemells Welcome to the RPG Maker Forum. We wish you enjoy and make good rpg games
Remember guys: Drink water and workout is important too! Don't stay too much time on the PC working! :D

Forum statistics

Threads
109,034
Messages
1,041,503
Members
141,522
Latest member
Corporal_Siva
Top