Rune Skills (Skill System)

Discussion in 'JS Plugin Releases (RMMV)' started by mjshi, May 19, 2016.

    Tags:
  1. silversmithfara

    silversmithfara Warper Member

    Messages:
    3
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    I fixed that issue, thank you for your help! I have a new one where I can only use my first rune (the others don't work for some reason). I.E. my rune combo <runes: 30, 30, 30> = Flame Bolt works... but any other permutation e.g. <runes: 31, 30, 30> = Flame Wave does not work. I changed the combinations to make sure the child abilities (Flame Bolt and Flame Wave) work independently to the numbers calling them... they do... help me?
     
    #81
  2. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    915
    Likes Received:
    724
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @silversmithfara Do you mean that only the first skill with listed runes works but no other ones? If so, could you PM me a test project showing the issue? I'm a little busy at the moment but I'll get to it within 2 weeks or so.
     
    #82
  3. The_Black_Knight

    The_Black_Knight Veteran Veteran

    Messages:
    59
    Likes Received:
    3
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    Can I get some help, I'm trying to use Waterguy's version.
    I set in the plugin max runes to 2, and set two runes for the desired result skill, but after picking the runes in battle, the "ok" button stays greyed out.
     
    #83
  4. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    915
    Likes Received:
    724
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @The_Black_Knight Hi! Waterguy's version is a pretty different edit from mine, but have you made sure that your basic setup looks somewhat like the 4 screenshots in the main post?
    A cursory glance at his version reveals that there are some syntactic differences (check his help file for more info), did you make sure that your tags are correctly capitalized and spaced?
    Otherwise, does it work when you have everything set to the default parameters?
     
    #84
  5. The_Black_Knight

    The_Black_Knight Veteran Veteran

    Messages:
    59
    Likes Received:
    3
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    [USER]@mjshi [/USER] Yeah all of those are okay, I only encountered the problem when I try to make only two rune combinations work.
     
    #85
  6. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    915
    Likes Received:
    724
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @The_Black_Knight Does it work with any other combination/number of runes? Other than that, I'm not really sure... could be some set up differences, could maybe be conflicts if you have other plugins running. @Waterguy, any input?
     
    #86
  7. The_Black_Knight

    The_Black_Knight Veteran Veteran

    Messages:
    59
    Likes Received:
    3
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    Nope.
    I actually noted, that when I set the skill to active with three runes, the "OK" lighted up on two runes and greyed out on three, and when I set it to activate with two runes, it lighted up on three and stayed grey on two.
    Picking "OK" in these instances resulted in the "wait" command being used of course.
     
    #87
  8. Waterguy

    Waterguy Veteran Veteran

    Messages:
    1,234
    Likes Received:
    259
    Location:
    Brazil
    First Language:
    Portuguese
    Primarily Uses:
    RMMV
    I haven't touched my version ever since I lost the project I made it for in a hard drive loss...
    I'll download it again and check it out, but could you explain the problem in more details through a private message so as not to take over mjshi's topic?
     
    #88
    mjshi likes this.
  9. The_Black_Knight

    The_Black_Knight Veteran Veteran

    Messages:
    59
    Likes Received:
    3
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    @Waterguy
    @mjshi
    I solved it, and it was treacherously simple, I have to apologize.
    The skills I tried to use had been in an earlier test set to have tiny TP costs. Now when I was trying to rune them up, the character didn't have the TP required.
    Bleh, it's always the simple things you somehow don't notice.
     
    #89
    mjshi likes this.
  10. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    915
    Likes Received:
    724
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @The_Black_Knight Glad you figured out what the problem was! Yeah, sometimes it's really tiny things.
    Thanks @Waterguy for helping out, sorry to hear about your project... I really do appreciate your contributions to all this, though. Here's to hoping your future storage drives are sturdier!
     
    #90
  11. The_Black_Knight

    The_Black_Knight Veteran Veteran

    Messages:
    59
    Likes Received:
    3
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    @mjshi @Arkaik
    Hey, I ran into a problem with yanfly's equip skills and the allowed types, so I thought I'll ask you. I set up my runes to be an allowed type, and it shows the rune command in the battle window, but when I go there it is empty, without any commands. I have set the character to know all runes and combinations from level1, and set his maximum skill count to 99 just to be sure.
     
    #91
  12. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    915
    Likes Received:
    724
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @The_Black_Knight Are you sure you've set those skills to be the Rune skill type? If you don't they won't show up in the rune selection window.
     
    #92
  13. The_Black_Knight

    The_Black_Knight Veteran Veteran

    Messages:
    59
    Likes Received:
    3
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    Yeah they are. Also I completely forgot I was using waterguy's version, maybe I should have asked him about it.
    I tried switching back to yours though, and the runes appear now. Unfortunately then the game crashes when I choose the first rune :( I am running quite a lot of yanfly's plugins too, so I don't know which version I even should try to get working.
     
    #93
  14. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    915
    Likes Received:
    724
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @The_Black_Knight A useful debugging tip for that is to disable all of them, then enable Rune Skills, then try enabling half of your plugins at a time. So:

    EX:
    Try 1:
    Rune Skills -> ON
    #2-50 -> ON
    #51-100 -> OFF

    If Try 1 breaks:

    Rune Skills -> ON
    #2-50 -> OFF
    #51-100 -> ON

    If Try 1 works:
    Rune Skills -> ON
    #2-75 -> ON
    #76-100 -> OFF

    Keep subdividing until you have only 1 or 2 plugins remaining that are OFF, to narrow down the problem. This way, you'll know for sure what works and what's broken, which is a really good place to start.
     
    #94
  15. The_Black_Knight

    The_Black_Knight Veteran Veteran

    Messages:
    59
    Likes Received:
    3
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    @mjshi
    Good idea, I'll propably have to go through them like that.
    Oh yeah, here's the crash screen thingy, I don't know why I didn't think of adding it in the first time.
     

    Attached Files:

    #95
  16. The_Black_Knight

    The_Black_Knight Veteran Veteran

    Messages:
    59
    Likes Received:
    3
    First Language:
    Finnish
    Primarily Uses:
    RMMV
    @mjshi
    Hmm, even in a fresh project I get "Cannot read property "name" of undefined. Though without all the other text.
    Could there be an issue in how I've set it up?
     
    #96
  17. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    915
    Likes Received:
    724
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @The_Black_Knight Maybe? Have you checked with the "Checklist of how to get it to work" in the first post of this thread? Otherwise, I've looked at the line of code that's erroring and it seems to be that RuneSkills can't find the selected rune (maybe it doesn't exist?).
     
    #97
  18. Lunchbox1946

    Lunchbox1946 Warper Member

    Messages:
    3
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    Hello, I'd like to start out by saying I absolutely love this plugin, i'm using it for prominent feature in my game. I've been back and forth between Mjshi's and Waterguy's versions. But I keep coming up with a problem both ways. I use Yanfly's plugins (as many do). When I use Mjshi's the game doesn't save the rune combination and it is forever ??? skills. which is no good for sure, but when I use Waterguy's it works, but for some reason it won't play nice with YEP Enhanced TP plugin and I cannot change TP modes for some reason. It's really gotten me in a bind for the last 2 weeks trying to figure it out. I'm no programmer, I was hoping someone might know the answer to my dilemma!
    Thank's in advanced if someone can!
     
    #98
  19. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    915
    Likes Received:
    724
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @Lunchbox1946 Hello! Rune combinations should be able to save, I tested this just now on a fresh project and I encountered no issues saving runes. (general steps I did for testing was: enter combat, insert fire rune, is "???", attack with "Fire", end combat, save, exit game, start game, load, enter combat, insert fire rune --> "Fire")

    Are you sure you're using the latest version? Saving combinations was fixed in version 1.1b.
     
    #99
  20. Lunchbox1946

    Lunchbox1946 Warper Member

    Messages:
    3
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    @mjishi Ah well, I am using it with the entire suite of Yanfly plugins plus some others also designed to work with YEP systems. I assume there was some error in trying to use it in combination with. I did test to see if it would work stand alone, I should have mentioned that first and I do apologize for not. I'm having some overall issues with MV right now so I'll do some further testing when my RPG Maker MV isn't exploding in my face. XD
     

Share This Page