EthanFox

Veteran
Veteran
Joined
Oct 15, 2018
Messages
586
Reaction score
374
First Language
English
Primarily Uses
RMMV
Trying to export my game to run in the latest Ubuntu; right now I'm running it through a VM, to see if I can get it to work.

It took a while to overcome the initial issue, where I had to get a missing library (libgconf-2-4), and after that, my game would run.

However, if I load any map (for complicated reasons, I have 2 different options on my title menu that would load up a map, and this happens on either of them) I get this error:

1627321974177.png

Googling, I can see references to this in a few places but can't seem to find any solution.

Has anyone here had this problem? My next step is going to be trying to disable all of my plugins to see if it's one of them causing the problem, though I've just tried deleting some of the more conceptually awkward plugins already to see if it was anything which seemed obvious; that had no effect.
 

Beckx

Villager
Member
Joined
Mar 29, 2021
Messages
28
Reaction score
246
First Language
german
Primarily Uses
RMMV
i'm not quite sure but i stumbled upon this github issue (regarding something else, but basically wrapping JS) with the same error and maybe the answer does help you out?
here's the issue

Since the above issue is regarding React, i'm not sure a plugin would cause that?
 

EthanFox

Veteran
Veteran
Joined
Oct 15, 2018
Messages
586
Reaction score
374
First Language
English
Primarily Uses
RMMV
i'm not quite sure but i stumbled upon this github issue (regarding something else, but basically wrapping JS) with the same error and maybe the answer does help you out?
here's the issue

Since the above issue is regarding React, i'm not sure a plugin would cause that?
I just assumed it was a plugin because I can't find much reference to this with RPGMaker MV online, and I kinda thought that if it wasn't, surely anyone running Linux games would've had this problem - or at least a few people. Unfortunately I'm really struggling to find any information.

Thanks for offering advice though! Hopefully someone will be along who has fixed this.
 
Last edited:

Beckx

Villager
Member
Joined
Mar 29, 2021
Messages
28
Reaction score
246
First Language
german
Primarily Uses
RMMV
yeah, no problem... i kept on looking and this might still be a rpgmaker thing.... *or* your vm.
following the link in the issue, they're talking about a missing file.
I'm running and developing on ubuntu (though 18.04) and when i build my game with mv it, the game structure looks like this:

Bildschirmfoto von 2021-07-26 20-15-52.png
do you have the marked file in your output game folder? if not, that's probably the problem. if yes, that was all i got, sorry :D
 

EthanFox

Veteran
Veteran
Joined
Oct 15, 2018
Messages
586
Reaction score
374
First Language
English
Primarily Uses
RMMV
I do have that file; also I'm running Ubuntu 20.04. The quest goes on.
 

Beckx

Villager
Member
Joined
Mar 29, 2021
Messages
28
Reaction score
246
First Language
german
Primarily Uses
RMMV
damn, that would've been too easy, lol. I guess, disabling all your plugins and testing it out wouldn't be such a bad idea after all...
I stumbled upon the same issue in a adult game forum (so no link), but that post got ignored unfortunately. It did say that other MV games worked fine though, AND that they noticed this because some fade in or out looked off.
I also checked out some more stuff and it could really be a varity of things (which sucks, but that's Javascript for you :( )

eg it could be an issue with webgl OR maybe some plugin uses ES6 and it's somehow a building issue with node.js (unfortunately i have no idea how rpgmaker works in the background / what technologies it uses, so it's hard to tell right now)
I am leaning towards a v8 chromium bug, though....

how are you running Rpgmaker? i'm asking because i'm launching it through steam and was wondering if that could maybe have anything to do with it (installing more libraries or whatever)


EDIT to add:
you could try changing/checking your rendering method and try setting it to "canvas" if it's webgl (just to ckeck where the issue lies, it should be possible via the community_basic plugin which should theoretically be included(?) )
 
Last edited:

Latest Threads

Latest Posts

Latest Profile Posts

Woot got a promotion and a pay rise ᕙ( • ‿ • )ᕗ now I'm set.
does anyone feel like explaining to me the difference between simulation and emulation? you have my full permission to be as pedantic as you want.
About the Deer, I had to cut some piece of video due the *swearing* Youtube copyrights issues...
A caveman pokes his head in...
I was listening to songs by Chuck E Cheese's voice actor (Jaret Reddick from Bowling for Soup) when the meds I was taking for my stomach virus apparently stopped working. I can't take my next dose until morning, but it's no use anyway. I'm officially sick again. Of course, I'll definitely take the next dose either way, but it's useless now.

Forum statistics

Threads
116,006
Messages
1,094,845
Members
151,310
Latest member
adultcart1
Top