Screen doesnt fade in anymore?

KiraNet

Engel der Dunkelheit
Veteran
Joined
Jan 2, 2019
Messages
45
Reaction score
7
First Language
Deutsch
Primarily Uses
RMMV
In one Event I fade out the screen to show a text in a black screen (Which worked always fine) and then I switch to another Room with an autorun Event where I put in "Fade In Screen" (Or however its called exactly in the english version) but it keeps being black screen no matter in which order I put it in the Events... It starts the event... I hear it... I see the text box but just backscreen... If I start the game in this room it starts without black screen... What is wrong here?
 

KiraNet

Engel der Dunkelheit
Veteran
Joined
Jan 2, 2019
Messages
45
Reaction score
7
First Language
Deutsch
Primarily Uses
RMMV
It also random changes the weather effect if I fade it in with in the first event and dont use the other picture fade effects... If I start in that room it works fine?! Ehhh?
 

Jeremiah Eastman

Gladiator
Veteran
Joined
Apr 24, 2017
Messages
501
Reaction score
304
First Language
English
Primarily Uses
RMMV
This may be a bug in the current version, or possibly a plugin conflict. I have recently had the exact same issue. I use fade in and out all the time but a recent event simply would not fade back in but everything else in the event worked fine. I eventually got it to work by trying to place the fade in, in different locations, all of which failed until it finally worked. I don't know why it finally worked where it did but I would suggest maybe trying other ways of applying the fade in.

Sorry I couldn't be more helpful but I hope you get it all worked out.
 

KiraNet

Engel der Dunkelheit
Veteran
Joined
Jan 2, 2019
Messages
45
Reaction score
7
First Language
Deutsch
Primarily Uses
RMMV
This may be a bug in the current version, or possibly a plugin conflict. I have recently had the exact same issue. I use fade in and out all the time but a recent event simply would not fade back in but everything else in the event worked fine. I eventually got it to work by trying to place the fade in, in different locations, all of which failed until it finally worked. I don't know why it finally worked where it did but I would suggest maybe trying other ways of applying the fade in.

Sorry I couldn't be more helpful but I hope you get it all worked out.
I can let it fade in befor but it skips then the half event with no reason... It doesnt change the music and sound effect or Pictures and I made the weather effect with a plug in but it random changes it to the default rain effect so this method is useless... If I start directly in the room it works all normal...
 

Jeremiah Eastman

Gladiator
Veteran
Joined
Apr 24, 2017
Messages
501
Reaction score
304
First Language
English
Primarily Uses
RMMV
I would suggest trying something along the lines of, right before you need to fade in, end the current event, I would try a self switch, then, on the new page autorun the fade in only then self switch to another new page and continue on. I did something similar to this when I got it to work.
 

KiraNet

Engel der Dunkelheit
Veteran
Joined
Jan 2, 2019
Messages
45
Reaction score
7
First Language
Deutsch
Primarily Uses
RMMV
I would suggest trying something along the lines of, right before you need to fade in, end the current event, I would try a self switch, then, on the new page autorun the fade in only then self switch to another new page and continue on. I did something similar to this when I got it to work.
Didnt worked... Its still the same issue... but thanks
 

MushroomCake28

KAMO Studio
Global Mod
Joined
Nov 18, 2015
Messages
3,213
Reaction score
4,346
First Language
English
Primarily Uses
RMMV

@KiraNet , please avoid double posting, as it is against the forum rules. You can use the "Edit" function on your posts to add additional information you've forgotten or respond to multiple people. You can review our forum rules here. Thank you.


You can use the edit function to add any missing information to an existing post instead of posting twice in a row.
 

Jeremiah Eastman

Gladiator
Veteran
Joined
Apr 24, 2017
Messages
501
Reaction score
304
First Language
English
Primarily Uses
RMMV
Yeah unfortunately I don't know why it finally worked for me. I'll tell you how mine is actually set up though and maybe you can figure something out from it. So I have a parallel process on all of my maps that controls individual maps time of day conditions and occasionally some other things.

What I did was place the fade in inside the maps parallel but I placed it behind a switch lock condition so it only runs the fade in condition when the switch is on. The condition reads like:
If Switch 1 is on
Fade in.
Turn switch 1 off.

That way it will only run the fade in the one time when the switch is on. Everything you described was happening to me other than the weather. I don't use weather so I don't know if it would have been affecting that but it is possible. If not maybe the weather plugin is causing an issue. You may want to also try the event with any plugins you may use turned off just to see if they are interfering.
 

fluffymonster

She's So FLUFFY!
Veteran
Joined
May 23, 2020
Messages
155
Reaction score
193
First Language
English
Primarily Uses
RMMV
Do you understand german? I only have a German Version...
I don't know german, but someone who knows it could come along and be able to read it and give you pointers. When having issues with technical stuff, as much information as you can give is always best. Have you tried putting the event onto new testing maps or even in a new project?

Alternatively, you could also use "show picture" and just have a black picture. I do that for mine since my blackest black (on map) isn't pitch black and I wanted it to stay in theme.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,329
Reaction score
12,817
First Language
English
Primarily Uses
RMMV
Usually this happens because the person has put another fadeout somewhere else and it is also being run, after the fadein is run, so you don't actually see anything happening. The fact that you say it works if you START on that map indicates that it might be something on the previous map, maybe in the event that does the transfer, that might be causing it.
 

KiraNet

Engel der Dunkelheit
Veteran
Joined
Jan 2, 2019
Messages
45
Reaction score
7
First Language
Deutsch
Primarily Uses
RMMV
[DPOST]@KiraNet [/DPOST]
You can use the edit function to add any missing information to an existing post instead of posting twice in a row.
Oh I'm sorry I had it wrong in memory... I thought it meant not 1:1 the same post I'm very sorry! I will give attention on that now ^^"

To the problem...
Hm... It seems to be the previous event be the reason... I tried teleport on another map and another event and it worked normaly... But I dont see anything wrong in the previous event... Funny thing is I tried turn off the weather plug in and took out the rain effect completly and... IT WAS STILL RAINING??? I'm completly confused now... I dont have any weather effect turn on in the previous event... I tried switching some orders but no matter what I do it keeps skip the half of the next event... So I guess the fade in is not the problem... it gets skipped too along with the changing pictures and tint effects... Just at the text it starts but if I make a text as first it gets skipped too

Here is a YT link of the Previous Event (German): Would be much pictures so I just did a video scrolling through it if its okay...

Edit: Problem Solved! OMG I'm an idiot *facepalm* I have on my map where the error occured two Events... And now I see on Event 1 that I had a third Page with a test version of Event 2 and both have the same switch... So it triggered the test version not the finished version I wanted... I completly forgot that I test it befor on a site in Event 1... So there was no load error... When I tested the Map directly I gave Event 1 a switch and not Event 2 (Who has normally the switch) so only Event 2 triggered... Thats why it doesnt happend when I directly started it there... This was the easiest solution oh boy glad that it wasnt a bug XD But thanks for trying to help ^^
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

Right now, my free time is less when Covid 19 in my country.
Begin to reduce the number of daily infections to 0.
Okay someone really needs to fix that broken railing, its a health hazard...

I'm starting to wonder if I should go the Half Minute Hero route with my game. The character's main weapon is logistically way too strong. So I can't really let the player continuously grow it.... But if they had to build it up each time like HMH, that could work. Also it lets me take advantage of my randomly generated maps so much more. Hmm... This could work! :LZSexcite:

Forum statistics

Threads
99,205
Messages
963,031
Members
130,794
Latest member
zPeppe7
Top