Screen is blurry while playtesting

Discussion in 'RPG Maker MV' started by drwho10, Jul 30, 2017.

  1. drwho10

    drwho10 Veteran Veteran

    Messages:
    45
    Likes Received:
    30
    First Language:
    English
    It looks like this even without resizing to fullscreen, and it was just like this by default. The only plugins I'm using are Khas's core, graphics, and lighting effects plugins, but I was having this problem before I added them.
    sample screenshot from editor:
    screen1.png
    the same tiles look like this while playtesting:
    screen2.png
    How do I keep the tiles the same size, and sharp looking?
    The version I'm using is 1.4.0, my computer is a Microsoft Surface Pro 4, and the resolution is 2736x1824. (I don't want to have to change the resolution for the whole computer just to fix this.) I know very little about coding and literally nothing about javascript, so I would prefer solutions that don't involve those if possible.
    Also, not sure if this is related, but when I was taking the screenshots and pasting them into paint.net to look at them, I noticed that they are twice the size of pixels as it's supposed to be (like, the whole game screen, 17x13 tiles, is 1632x1248 instead of 816x624.) So for some reason my computer is blowing it up to twice its actual size. I don't know if this is normal or not. It does this even with screenshots of the editor, but there is still nothing wrong with those.
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,672
    Likes Received:
    6,594
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    That "blow up" is responsible for the blur, because such a blur usually happens on resizing only.
    You need to find that setting (it has to be either on your display driver, on your computer, or possibly in a zoom function provided by a plugin) and then look for better options at that place where it sets the zoom
     
    #2
  3. drwho10

    drwho10 Veteran Veteran

    Messages:
    45
    Likes Received:
    30
    First Language:
    English
    The scaling was set to 200% so I changed it to 100%... that fixed the blurriness, but made everything on my computer so small that it's unusable, so I had to change it back. I tried all the things in the display settings. There has to be some other problem though, since its apparently being blown up in the editor as well, and that still doesn't blur. Is there already an existing plugin that can fix this?
     
    #3
  4. CriticalGames

    CriticalGames Veteran Veteran

    Messages:
    217
    Likes Received:
    61
    Location:
    Australia
    First Language:
    English
    #4
  5. drwho10

    drwho10 Veteran Veteran

    Messages:
    45
    Likes Received:
    30
    First Language:
    English
    I could barely understand most of that thread... does anyone have a copy of the plugin they were talking about that I could download? I don't know anything about making one.
     
    #5
  6. Andar

    Andar Veteran Veteran

    Messages:
    28,672
    Likes Received:
    6,594
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    Of course it became smaller - that is the difference between 2D and 3D displays.

    To completely prevent any blurring, you have to use the original size, which is a lot smaller than your display.
    However, you need to know that this blurring also depends on the mathematical formula used for the zoom and resize.

    So the second best option is a zoom to exactly 200% with a formula that exactly doubles the pixels. Unfortunately most zoom programs don't allow you to select the mathematical zooming method.

    So if that is not possible the third best option is to use Shaz' Tilesize plugin to change the tileset used from 48 to 96 pixels and use Photoshop or GIMP to resize your tilesheet with the correct method.
    This is a lot more work however.

    The least best methods are 1) resizing the window screen size to a smaller number and let the display interpolation handle that (depends on the quality of the display electronics and has a good chance to get blirry) or use a virtual machine with its own display drivers (also a lot of configuration while still retaining a high chance of getting blurry)

    But in 2D, you cannot easily resize without mathematical blurring.
     
    #6
  7. drwho10

    drwho10 Veteran Veteran

    Messages:
    45
    Likes Received:
    30
    First Language:
    English
    I don't really understand? Does the tilesize plugin only affect the game screen while playing? Because that is the only issue I need fixed; it is not a problem with the tiles themselves. I do not want something that will change the entire game and program and assets.
     
    #7
  8. Andar

    Andar Veteran Veteran

    Messages:
    28,672
    Likes Received:
    6,594
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    The tilesize plugin allows you to use larger tiles, and that allows you to increase the screen size as well - as you could see from your own posts, you need to increase the game's screen size to have it playable on your screen, and to do that you have no choice but to increase the tilesize (or have a larger portion of a map with small tiles visible.

    And to increase tilesize you vcan either use a zoom (with the resulting blur you don't want) or replace the tiles with larger tiles that were not zoomed with a blurring mathematical formula.
     
    #8
  9. CriticalGames

    CriticalGames Veteran Veteran

    Messages:
    217
    Likes Received:
    61
    Location:
    Australia
    First Language:
    English
    Try this then - I've attached the results of KisaiTenshi's work in that thread as a plugin =) Simply put this file in your js/plugins folder.
     

    Attached Files:

    #9
  10. drwho10

    drwho10 Veteran Veteran

    Messages:
    45
    Likes Received:
    30
    First Language:
    English
    @Andar I tried the tilesize plugin, it didn't work since my computer still enlarges everything to twice the size it's supposed to be, and anyway looked awful in playtesting (even after changing only the size of all the tilesets in a duplicate folder, it messed them up and thought I used tiles I never even put on the map.)
    @CriticalGames I added it, but it didn't do anything, even in fullscreen.
    I think I'm going to just have to live with it, it's not too big an issue I guess, and it should look normal on other people's computers if they play it.
     
    #10
  11. Celianna

    Celianna Tileset artist Global Mod

    Messages:
    10,527
    Likes Received:
    5,533
    First Language:
    Dutch
    Primarily Uses:
    RMMV
    This is user end though - it's because of your own resolution. If other people were to play your game, they wouldn't run into the same issue (unless, of course, they're also playing on the same resolution).

    I'm using a 4k monitor, but I adjusted the settings to around a 125% zoom, and my game doesn't blur when playtesting.
     
    #11
  12. CriticalGames

    CriticalGames Veteran Veteran

    Messages:
    217
    Likes Received:
    61
    Location:
    Australia
    First Language:
    English
    Well, from what Celianna and Andar are saying, this is a problem on your end, so this stuff won't make a difference. But just in case, I realised I forgot one other element from that thread I mentioned. In addition to the plugin, you need to add this line to the index.html file (in your game's base folder):

    <style type="text/css"> CANVAS{image-rendering: pixelated;}</style>

    Open index.html with something like Notepad, and then near the bottom, under <script type="text/javascript" src="js/main.js"></script>, but above </body>, add the new line I mentioned above.

    As I say, it may not do anything, but it's worth a go. This helped me with some of my blurriness issues =)
     
    #12
    drwho10 likes this.
  13. drwho10

    drwho10 Veteran Veteran

    Messages:
    45
    Likes Received:
    30
    First Language:
    English
    #13
  14. CriticalGames

    CriticalGames Veteran Veteran

    Messages:
    217
    Likes Received:
    61
    Location:
    Australia
    First Language:
    English
    @drwho10 Huzzah! No worries - this has been a big issue for me as well (one of the many things hard-coded into the engine), so I'm glad I could help =D
     
    #14

Share This Page