script line 449 error, need help.

Discussion in 'RGSSx Script Support' started by Mrpaulyshore, Sep 14, 2014.

Thread Status:
Not open for further replies.
  1. Mrpaulyshore

    Mrpaulyshore Veteran Veteran

    Messages:
    76
    Likes Received:
    1
    First Language:
    english
    I need help, I was in the phase of doing the final testing for my game, however there is one part that I can not fix that has always worked before up until now.

    All it is that I try to tele port from one point to the next like any other normal transportation part in the game and I cannot shake this error. I know next to nothing about

    scripting so I don't want to mess with the source code and create more problems I can't fix...'

    here is a thumbnail and a link to show what the error looks like.

    [​IMG]

    (link incase thumbnail does not show)

    http://postimg.org/delete/6cot8ydri/

         result = eval(@params[1])

    this is the line of code the game says gets an error. 
     
    Last edited by a moderator: Sep 14, 2014
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,135
    Likes Received:
    6,372
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    Please tell us what scripts you have added to the game (link to them) and give screenshots of the event that is executed at that moment.


    That error message alone cannot tell us anything, because that is the line that executes other command, and we need to see the commands it tries to execute.
     
    #2
  3. Shaz

    Shaz Veteran Veteran

    Messages:
    37,328
    Likes Received:
    11,135
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    That line in Game_Interpreter is evaluating a script in a Conditional Branch.


    You have a conditional branch in an event somewhere that has Proxy as part of the command - either the command itself or one of its arguments.


    It's possible that you've either just added this and it's causing the problem, or that you HAD a script that used it, and you've removed the script. OR that you've done something else new (like turning on a switch that wasn't being turned on before) that's caused an event or common event to run that until now has stayed dormant.


    If it happens when you try to transfer from one map to another, then the command is either in the event that makes you transfer, or it's in an autorun or parallel process event on the map you're going to. OR it's in a common event that's being activated as soon as you go to the new map - likely because you've turned on a switch as part of the transfer or immediately after.
     
    Last edited by a moderator: Sep 14, 2014
    #3
  4. Mrpaulyshore

    Mrpaulyshore Veteran Veteran

    Messages:
    76
    Likes Received:
    1
    First Language:
    english
    The scripts I am using are YEA battle symphony and yami very basic. 

    [​IMG]

    http://postimg.org/delete/5kfw6aims/

    The event is just dialogue with no special events just very wordy. I don't know how else to present this to you so I hope the script bits will help.
     
    #4
  5. Shaz

    Shaz Veteran Veteran

    Messages:
    37,328
    Likes Received:
    11,135
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    It is not a script. Did you read my post? It's a conditional branch that has a script call in it, in an event.


    Please look for my PM.
     
    Last edited by a moderator: Sep 14, 2014
    #5
Thread Status:
Not open for further replies.

Share This Page